MySql User/Login Problem

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

MySql User/Login Problem

Postby Dev.Oli » 09. October 2011 16:07

Hallo,

mich quält schon seit einiger Zeit ein Loginproblem bei MySql und da ich im Internet nichts gefunden habe frage nun hier. Wenn ich mich mit einem in phpMyAdmin erstellten User an phpMyAdmin einloggen will bekomme ich immer "Die Anmeldung am MySQL-Server ist fehlgeschlagen." als Meldung bzw. "
Warning: mysql_connect() [function.mysql-connect]: Access denied for user 'modx'@'localhost' (using password: YES) in C:\xampp\htdocs\logintest.php on line 3
keine Verbindung möglich. Benutzername oder Passwort sind falsch" bei php-Skripten.
Wenn ich aber irgendetwas (außer root) beim Benutzernamen eingebe und Passwort leer lasse komm ich rein, sehe aber nur die Datenbank information_schema mit eingeschränkten Rechten.

Das Problem besteht sowohl bei 'cookie' als auch bei 'http' als Authentifikation Typ und lässt sich auch nicht durch Neuinstallation beheben.

Ich benutze XAMPP 1.7.7 unter Win7 Home Premium in der 64 Bit Version.

Ich bin für jeden konstruktiven Vorschlag oder Lösungsvorschlag dankbar.

Dev.Oli
Dev.Oli
 
Posts: 2
Joined: 09. October 2011 15:37

Re: MySql User/Login Problem

Postby glitzi85 » 20. October 2011 14:20

Und du hast auch immer schön auf den Link "Benutzerdaten neu laden" (oder so ähnlich) bei phpMyAdmin geklickt? Damit werden dann nämlich die Änderungen in der Benutzerdatenbank aktiv (FLUSH PRIVILEGES ist übrigens der dazugehörige SQL-Befehl).

Dass du nur die information_scheme siehst liegt daran, dass du zwar einen Benutzer angelegt hast, dieser aber keinerlei Rechte hat. Die Doku dazu findest du hier: http://dev.mysql.com/doc/refman/5.1/en/ ... ation.html (Punkt 5.4 und 5.5).

mfg glitzi
User avatar
glitzi85
 
Posts: 1920
Joined: 05. March 2004 23:26
Location: Dahoim

Re: MySql User/Login Problem

Postby Dev.Oli » 21. October 2011 16:57

ja habe ich.

ich hab den Fehler aber trotzdem durch deinen Post gefunden thx.

Das Problem war anscheinend, dass % als Host statt localhost eingetragen war :oops: .

Vielen Dank

Dev.Oli
Dev.Oli
 
Posts: 2
Joined: 09. October 2011 15:37


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 13 guests