Virtual Hosts geht nicht mehr

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Virtual Hosts geht nicht mehr

Postby nico44 » 26. September 2011 15:19

Hallo zusammen,

Wir haben letztes Wochenende die Domain umbenennt. Seitdem geht das Intranet, bzw. die virtuellen Hosts nicht mehr.
Wir haben 3 Sites. Intranet, Wiki und Inventory
meine httpd.conf sieht wie folgt aus:
Code: Select all
<VirtualHost *:80>
ServerName intranet
DocumentRoot c:/xampp/htdocs/intranetr4/
ErrorLog c:/xampp/htdocs/error_log
</VirtualHost>

NameVirtualHost wiki
<VirtualHost *:80>
ServerName wiki
DocumentRoot c:/xampp/htdocs/cbwiki/
ServerAlias wiki
ErrorLog c:/xampp/htdocs/error_log
</VirtualHost>

<VirtualHost *:80>
ServerName inventory
DocumentRoot c:/xampp/htdocs/Inventory/
ServerAlias inventory
ErrorLog c:/xampp/htdocs/error_log
</VirtualHost>


Seit der Umstellung geht nur noch die "Hauptseite", sprich das Intranet. Wenn ich im Browser wiki aufrufen will, komm ich immer aufs Intranet. Jedoch lokal gehts, d.h. wenn ich auf dem Webserver im Browser wiki eingebe funzt alles tiptop.

Hat mir vielleicht jemand einen Denkanstoss.
Vielen Dank.
Gruss
nico
nico44
 
Posts: 2
Joined: 26. September 2011 15:13

Re: Virtual Hosts geht nicht mehr

Postby Altrea » 26. September 2011 15:28

Hallo,

Zum einen: die NameVirtualHost Direktive kommt nach ganz oben, denn daran richtet sich alles aus, wenn man NameBased VHosts verwendet. Außerdem kann man sie ganz oben kaum übersehen, irgendwo mittendrin schon.

Dann: Bei dir funktioniert immer nur die erste VHost weil die erste immer die Default VHost ist. Heißt, die erste funktioniert wahrscheinlich auchnicht richtig, aber weil keine andere VHost Maske passt, wird eben die erste ausgeführt.

Warum das ganze nun nicht funktioniert ist damit auch beantwortet: Keine der VHosts matcht auf die angefragte URL. Überlege dir einfach mal, wie so ein VHost lokal funktioniert (wer routet und löst die IP da auf? Stichwort HOSTS Datei) und wie funktioniert das ansonsten (Stichwort DNS).

Das sollte erstmal reichen als Denkanstoß
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8297
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Virtual Hosts geht nicht mehr

Postby nico44 » 27. September 2011 10:19

Hallo,

Danke für die schnelle Antwort.

Welch Wunder. Habe heute nochmals probiert und nun scheint es zu funktionieren. War wahrscheinlich ein DNS-Cache Problem. Wobei ich den diesen geflushed habe. :shock:

Auch gut. nun gehts, ich kann alle drei sites aufrufen.

Gruss
nico
nico44
 
Posts: 2
Joined: 26. September 2011 15:13


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 6 guests