Windows 7 64Bit - Ldap aktivieren?

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Windows 7 64Bit - Ldap aktivieren?

Postby taggert » 26. September 2011 12:28

Moin Moin! :)

Ich suche mich nun schon die ganze Zeit im Internet tot.
Komme aber leider bisher nicht zu einer Lösung...
Ich habe mir ein neues Notebook gekauft und drauf ist Windows 7 64 Bit...
Also habe ich mir heute den XAMPP 1.7.7 geladen...

Dem Hinweis bei der Installation entspechend habe ich Xampp (da uac aktiviert ist) nicht nach C:\Program Files sondern nach D:\xampp installiert.
Apache und Mysql habe ich nicht als Service regisrtiert...
Apache und Mysql laufen über das Control Panel so weit auch ohne Probleme ...

Allerdings habe ich nun arge Proleme das LDAP Module zu aktivieren.
Wenn ich in der D:\xampp\php\php.ini
das extension=php_ldap.dll aktiviere und den Apachen neustarte bekomme ich:

Fehlermeldung 1:
Das Programm kann nicht gestartet werden, da libsasl.dll auf dem Computer fehlt. Installieren Sie das Programm erneut, um das Problem zu beheben.


Und direkt danach kommt
Fehlermeldung 2:
PHP Startup: Unable to load dynamic library 'D:\xampp\php\ext\php_ldap.dll' - Das angegebene Modul wurde nicht gefunden.


...
Die betroffenen DLLS (inklusive libeay32.dll und ssleay32.dll) nach Windows\System32 kopieren hat schonmal kein Stück geholfen.
(Habe danach auch XAMPP bzw, Apache2 und sogar den Rechner neugestartet)
...

Nun stehe ich ein bisschen auf dem Schlauch? ...
Habe online noch gelesen das es bei einigen Hiflt eine Windows-Systemvariable hinzuzufügen.
Wenn das die Lösung sein sollte: Was muss ich da wo eintragen? ^^

Vielen Dank schonmal vorab für eure Hilfe!

Grüße
Taggert
taggert
 
Posts: 2
Joined: 26. September 2011 12:17

Re: Windows 7 64Bit - Ldap aktivieren?

Postby taggert » 27. September 2011 08:20

Okay, habs raus...

Also meine XAMPP Installation läuft nun perfekt auf Windows 7 64 Bit.

XAMPP 1.7.7 mit Installer nach D:\xampp installiert.
Apache2 und MySQL NICHT als Service installiert.

Und dann Rechtsklick auf "Computer" => Eigenschaften => Erweiterte Systemeinstellungen => Umgebungsvariablen => Systemvariablen => Bei "Path" hinzufügen:
D:\xampp\php

Und Rechner neustarten...
Nun funktionieren auch alle Module... ohne DLL Dateien zu kopieren oder ähnlichem.
taggert
 
Posts: 2
Joined: 26. September 2011 12:17

Re: Windows 7 64Bit - Ldap aktivieren?

Postby ConnerMcLeod » 28. January 2015 12:18

Hallo,

ich hatte das gleiche Problem mit dem aktuellen XAMPP Paket 5.5.19-0-VC11. Vorher hatte ich auch die Version 1.7.7 installiert gehabt, wobei ich überhaupt keine Fehlermeldung angezeigt bekommen habe. Der Apache ist bei dieser Version einfach kommentarlos NICHT gestartet. Selbst im Error-Log war kein hilfreicher Eintrag zu finden.

Nun ja, der langen Rede kurzer Sinn: die PATH-Variable mit "C:\xampp\php" zu erweitern (ich hab's halt auf C: installiert), hat bei mir auch geholfen.
Vielen Dank für Deinen Beitrag, Taggert, so funktioniert ein Forum :-)

LG
Conner
ConnerMcLeod
 
Posts: 1
Joined: 28. January 2015 12:08
Operating System: Windows 7 64 Bit


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 10 guests