VirtualHost & .htaccess Probleme

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

VirtualHost & .htaccess Probleme

Postby TheRealDarklord » 19. September 2011 23:17

Hallo an alle,

nachdem ich festgestellt hatte, dass meine XAMPP-Version nun doch schon etwas veraltet war, habe ich gestern den letztmöglichen Stand runtergeladen und entpackt (zip-Version).
Da ich die neue Version so konfigurieren wollte, wie meine bis dahin alte Version, fing ich an die Config-Dateien für Apache zu bearbeiten.
Da sind mir anscheinend ein paar Schnitzer unterlaufen.

Ich wollte zunächst meinen Virtualhost für PHPMyAdmin wieder aktivieren. Der Eintrag in der hosts-Datei von Windows ist noch vorhanden.
Ich habe also in der httpd-vhosts.conf folgendes eingetragen (kopiert aus der Konfiguration des alten XAMPP):

Code: Select all
NameVirtualHost 127.0.0.1:80 // Ist das notwendig/richtig?
[...]
<VirtualHost 127.0.0.1:80>
   ServerName localhost
   DocumentRoot "/xampp/htdocs"
</VirtualHost>

<VirtualHost 127.0.0.1:80>
   ServerName sql
   DocumentRoot "/xampp/phpMyAdmin"
</VirtualHost>

Anmerkung: XAMPP befindet sich im Rootverzeichnis eines meiner Laufwerke.

Zusätzlich habe ich die httpd.conf mit Folgendem angepasst:
Code: Select all
ServerName 127.0.0.1:80 // Ist das notwendig/richtig?


Nun habe ich Apache- und MySQL-Server gestartet und wollte meinen Virtualhost aufrufen mittels "http://sql". Als Antwort kam: Zugriff verweigert, Fehler 403. Auch das Angeben der garantiert vorhandenen Datei index.php (zum Umgehen des etwa deaktivierten Directorybrowsings) ergab denselben Fehlercode. Ich habe die Kofigurationen beider XAMPP-Versionen so gut es geht miteinander verglichen und konnte keine Abweichungen feststellen. Mit der vorherigen XAMPP-Config geht es, mit der neuen nicht. Wo liegt mein Denkfehler?

Als weiteres ist mir aufgefallen, dass trotzt .htaccess auf Wurzelebene des htdocs-Verzeichnisses mit folgendem Inhalt:
Code: Select all
#AuthType Basic
#AuthName "Secure"
#AuthUserFile .htpasswd
#require valid-user

und natürlich gültigen Einträgen in der .htpasswd die Anmeldeaufforderung mit einem simplen Escape beendet werden kann und ich meine index.php präsentiert bekomme. Nach kurzem Abgleich weist auch die vorherige XAMPP-Konfiguration dieses Phänomen auf. Auch hier bin ich ratlos.

Ich erbitte Hilfe, danke im Voraus.
mfG, TRD
TheRealDarklord
 
Posts: 3
Joined: 19. September 2011 23:04

Re: VirtualHost & .htaccess Probleme

Postby glitzi85 » 20. September 2011 19:32

Hast du eventuell die httpd-xampp.conf nicht inkludiert? Die regelt das, wenn ich mich recht erinnere.

Prinzipiell liegt das Problem daran, dass im Apachen per Default alle Ordner gesperrt sind. Du musst also zusätzlich noch den PMA-Ordner freigeben:

Code: Select all
<VirtualHost 127.0.0.1:80>
   ServerName sql
   DocumentRoot "/xampp/phpMyAdmin"
   <Directory /xampp/phpMyAdmin>
      Order allow,deny
      allow from localhost
   </Directory>
</VirtualHost>


Hier noch ein bisschen Literatur dazu: http://httpd.apache.org/docs/2.2/mod/mo ... _host.html

In der error.log hättest du übrigens einen Hinweis darauf gefunden (Folder denied by client configuration oder so).

mfg glitzi
User avatar
glitzi85
 
Posts: 1920
Joined: 05. March 2004 23:26
Location: Dahoim

Re: VirtualHost & .htaccess Probleme

Postby TheRealDarklord » 20. September 2011 22:14

Upps, also das mit der error.log hatte ich bereits angeschaut, da steht auch genau das, was du vermutet hast.
Ich war nur verwundert, wieso ohne zutun in der alten Conf mein Virtualhost ging und nun nicht mehr. Ich glaube, ich habe den Verursacher in der httpd-xampp.conf gefunden
Code: Select all
#
# New XAMPP security concept
#
<LocationMatch "^/(?i:(?:xampp|security|licenses|phpmyadmin|webalizer|server-status|server-info))">
    Order deny,allow
    Deny from all
    Allow from 127.0.0.0/8
    ErrorDocument 403 /error/HTTP_XAMPP_FORBIDDEN.html.var
</LocationMatch>

Der Block ist neu im Vergleich zur alten Config und scheint das ganze nochmal abzusichern.
Gut, das hätte ich also behoben. Jetzt sorgt mich nur noch, dass ich den Auth-Dialog mit Escape unterbinden kann.
TheRealDarklord
 
Posts: 3
Joined: 19. September 2011 23:04

Re: VirtualHost & .htaccess Probleme

Postby Nobbie » 20. September 2011 22:26

TheRealDarklord wrote:Gut, das hätte ich also behoben. Jetzt sorgt mich nur noch, dass ich den Auth-Dialog mit Escape unterbinden kann.


Und mich wundert, dass überhaupt ein Dialog erscheint: die Zeilen, die Du uns oben zeigst, sind jedenfalls allesamt auskommentiert.
Nobbie
 
Posts: 8779
Joined: 09. March 2008 13:04

Re: VirtualHost & .htaccess Probleme

Postby TheRealDarklord » 20. September 2011 22:54

Au backe, ich hab hier ja richtigen Käse verzapft.
Du hast völlig recht, das ist auskommentiert und völlig sinnfrei. Der Dialog kam, weil auf der zu ladenden Index.php eine .css-Datei aus einem separat geschützten Verzeichnis (mit korrekter .htaccess) eingebunden wird. Da ist natürlich auch klar, dass ich das abbrechen kann, dann wird eben nur die CSS nicht geladen (ist mir aufgrund eines sehr einfachen Layouts nicht aufgefallen).
Habe nun die Kommentare entfernt. Dann kam auch hier Error 403. Da noch schnell die Config nachgebessert und ein Allow für meine 127.0.0.1 reingetan und es geht.

Sooo, jetzt nur noch der letzte Haken:
Ich würde nun auch im Netzwerk gerne auf die Seiten im htdocs zugreifen. Wenn ich jedoch die IP meines PCs eingebe kommt ein Seitenladefehler.
Da ich experimentell gänzlich ohne Firewall rangegangen bin, bin ich an dieser Stelle ratlos, warum ich keine Antwort vom Server erhalte. Anpingen (auch wenn das über einen anderen Port läuft) geht zumindest, sodass sichergestellt ist, dass eine Verbindung existiert.
Gibt es eine XAMPP-Restriktion, die verhindert, dass der Server nach außen erreichbar ist?

/Nachtrag:
Habe auch das letzte Problem beheben können. In der httpd.conf sollte man natürlich auch angeben, dass entweder generell auf Port 80 gelauscht wird, oder aber die IP im Netzwerk hinzufügen, sonst kann das auch nix werden. Alles angepasst, ne Menge gelernt. Danke für die Beihilfe zur Selbsthilfe :)
TheRealDarklord
 
Posts: 3
Joined: 19. September 2011 23:04


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 12 guests