remote_user und Windows

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

remote_user und Windows

Postby ThunderCat » 03. January 2003 13:32

hi,

ich versuche schon seid einiger Zeit ein Zugriff mittels .htacces und DB zustande zu bekommen.
Die dazugehörige Variable lautet ja uach $remote_user oder $http_server_vars['remote_user'] ... ist auch kein Problem, auf meinem Webspace im Internet funzt alles einwandfrei, nur ist das ein Linux Server.

Zu Hause setzte ich das WAMPP2C ein auf einem W2K Adv. Server (komme mit Linux nicht zurecht :( ).

Was muss ich einbinden, damit diese Variable auch unter Windows funktioniert ? Oder was muss ich einstellen ?

Kann mir jemand helfen ? Es ist einfach nur mühselig alles über nen FTP zu proggen, zu testen und dann wieder zu löschen :(

Grüsse
TC
ThunderCat
 

Postby ThunderCat » 07. January 2003 09:15

:( Ist die Frage so schwer :?:
ThunderCat
 

Postby Apache-User » 07. January 2003 11:38

zu .htaccess unter Win kann ich dir sagen das es nur uncodiert geht farg mich bitte nicht warum ist aber so also schreib mal in die htpasswd das passwort als reinen text also user:passwort und nicht user:hjgj24r5f dann geht dein htacces.... zu beachten ist auch noch das die htpasswd in deinem root verzeichniss liegt also C:\wampp2c\apache und nicht im docroot C:\wampp2c\htdocs
mfg
D.A.U.™
User avatar
Apache-User
 
Posts: 594
Joined: 30. December 2002 16:50
Location: anonym

Postby Oswald » 07. January 2003 12:41

Huhu ThunderCat!

Ich weiß ja nicht ob Du nur ungenau zitiert hast, aber $HTTP_SERVER_VARS["REMOTE_USER"] muß komplett groß geschrieben werden. Liegt's vielleicht daran?

Ansonsten hat's Apache-User ja auch schon angedeutet: Die HTTP-Authentication funktioniert schon richtig bei Dir?

Sonst wär ich auch ziemlich ratlos...

Grüße,
Oswald ;)
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
XAMPP Version: 5.5.19
Operating System: Linux

Postby ThunderCat » 07. January 2003 18:43

Hi Apache-USer,

an der .htpasswd - Datei liegts nicht, denn ich kann mich ja am Verzeichnis anmelden, und die DAtei habe ich auch mit dem Programm htpasswd.exe erstellt und da ist das Passwort verschlüsselt.
Ist aber richtig, denn die Passwort-Dateien von meinem Webhoster funzen unter Windows nicht, leider :(

Hi Kai Seidler,

jupp richtig, nur falsch geschrieben, aber die variable $REMOTE_USER gross/klein auf meinem Webhoster klappt, nur unter Windows bekomme ich folgendes
Notice: Undefined index: REMOTE_USER in <pfad>index.php on line 19


Ich habe mir dann die entsprechende Variable $HTTP_SERVER_VARS['REMOTE_USER'] per echo ausgeben lassen und diese ist NULL :(

Ich hatte das ganze in der Zwischenzeit auf einem Linux Mandrake 9 getestet und dort klappt es, nur setzt dieses Linux einen Apache-ExtranetServer 1.3.26 ein mit einem Modul, wo ich glaube, dass es für solche Variablen zuständigt ist, aber leider kenne ich das Modul nicht.
ThunderCat
 

Postby ThunderCat » 07. January 2003 18:44

So hab mich jetzt auch mal hier geregged :wink:
ThunderCat
 
Posts: 15
Joined: 07. January 2003 18:43

Postby ThunderCat » 11. January 2003 20:25

Keine Ideen mehr ? Denn ich habe leider keine mehr, schon alles mögliche durchsucht und nirgends finde ich was, womit ich was anfangen kann, alles immernur fürs Linux, nur da ich in Hinsicht Linux mehr als nur ein nOOb bin, kann ich das erstmal vergessen.
ThunderCat
 
Posts: 15
Joined: 07. January 2003 18:43


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 12 guests