Netzlaufwerk funktioniert nicht

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Netzlaufwerk funktioniert nicht

Postby biker5 » 01. August 2011 17:36

Hallo zusammen,

ich habe folgendes Problem:

unsere Fritz Box hat einen USB-Anschluss über den man ein Netzwerklaufwerk einrichten kann,
wenn man einen Stick oder externe Festplatte anschließt.
Das funktioniert auch prima und ich hatte die Idee unsere Website darauf abzulegen, damit man sie vom Notebook
oder dem lokalen Rechner bearbeiten kann - das geht auch. Nur die Vorschau mit Xampp funktioniert nicht.

Netzlaufwerk H:\
IP der Fritzbox 192.168.178.1

Wenn ich die Pfade in httpd-vhosts.conf anpasse:

NameVirtualHost 127.0.0.1

<VirtualHost 127.0.0.1>
ServerName localhost
AddType text/html .shtml
AddHandler server-parsed .shtml
ServerAdmin webmaster@localhost
DocumentRoot C:/xampp/htdocs
ScriptAlias /cgi-bin/ "c:/xampp/htdocs/cgi-bin/"

<Directory "C:/xampp/htdocs">
Options Indexes FollowSymLinks
Options +Includes
AllowOverride FileInfo
AllowOverride None
Order allow,deny
Allow from all
DirectoryIndex index.html index.htm index.php
</Directory>

</VirtualHost>

NameVirtualHost 192.168.178.1

<VirtualHost 192.168.178.1>
ServerName testsite
AddType text/html .shtml
AddHandler server-parsed .shtml
ServerAdmin webmaster@localhost
DocumentRoot H:/localserver/testsite
ScriptAlias /cgi-bin/ "c:/xampp/htdocs/cgi-bin/"

<Directory "H:/localserver/testsite">
Options Indexes FollowSymLinks
Options +Includes
AllowOverride FileInfo
AllowOverride All
Order allow,deny
Allow from all
DirectoryIndex index.html index.htm index.php
</Directory>

</VirtualHost>


Weiterhin Anpassen der Datei hosts in c:\windows\system32\drivers\etc

127.0.0.1 localhost
192.168.178.1 testsite


Wo liegt der Fehler, wer kann helfen? Oder kann das so nicht funktionieren?

Vielen Dank im Voraus
biker5
biker5
 
Posts: 2
Joined: 01. August 2011 16:59

Re: Netzlaufwerk funktioniert nicht

Postby Nobbie » 01. August 2011 21:35

biker5 wrote:
Das funktioniert auch prima und ich hatte die Idee unsere Website darauf abzulegen, damit man sie vom Notebook
oder dem lokalen Rechner bearbeiten kann - das geht auch. Nur die Vorschau mit Xampp funktioniert nicht.


Was genau "funkioniert prima"? Und was ist "die Vorschau mit Xampp"?

Genau genommen wird das gar nicht funktionieren, denn die gezeigte Konfiguration ist falsch und kann nicht funktionieren - egal was sie tun soll. Bei VirtualHost kann man nicht einfach irgendeine fremde IP angeben, das muss eine IP sein, die auf dem Xampp (Apache) Rechner von irgendeinem Netzwerkadapter belegt ist. Das ist aber garantiert nicht der Fall, denn diese IP ist die IP der Fritzbox.
Nobbie
 
Posts: 8772
Joined: 09. March 2008 13:04

Re: Netzlaufwerk funktioniert nicht

Postby biker5 » 07. August 2011 18:04

Hallo Nobbie,

sorry, dass ich erst jetzt antworte, aber die letzte Woche war stressig.

Da hatte ich mich wohl falsch ausgedrückt. Wir haben unsere Website offline auf unserem Rechner liegen. So kann man, bevor man Änderungen in's Netz stellt offline sich alles erst auf dem eigenen Rechner ansehen (Vorschau mit Xampp). Meine Idee war, die Offline-Website von den lokalen Rechnern auf ein Netzlaufwerk H:\ zu verlegen, um nur eine Kopie unserer Seite zu haben, als zwei Kopien (Notebook und stationärer Rechner) die immer abgeglichen werden müssen, je nach dem an welchen Rechner man arbeitet. So würden beide Rechner auf eine Kopie unserer Seite zugreifen.

Das Netzlaufwerk funktioniert. Das Bearbeiten im Netzlaufwerk (egal von welchem Rechner) auch. Nur habe ich Xampp noch nicht beibringen können wo jetzt unsere Seite liegt. Das einfache Austauschen des Laufwerksbuchstaben in der httpd-vhosts.conf von C:\ zu H:\ funktioniert nicht.
Wie ist die richtige Konfiguration für ein Netzlaufwerk, wo liegt mein Fehler?

Vielen Grüße und Danke im Voraus
biker5
biker5
 
Posts: 2
Joined: 01. August 2011 16:59


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 5 guests