MySQL error #2000 - mysqlnd cannot connect to MySQL 4.1+

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

MySQL error #2000 - mysqlnd cannot connect to MySQL 4.1+

Postby AndromedaXP » 01. August 2011 13:35

After updating to xampp 1.7.4 when connecting with phpmyadmin to a hetzner mysql-server I get this error...
#2000 - mysqlnd cannot connect to MySQL 4.1+ using the old insecure authentication. Please use an administration tool to reset your password with the command SET PASSWORD = PASSWORD('your_existing_password'). This will store a new, and more secure, hash value in mysql.user. If this user is used in other scripts executed by PHP 5.2 or earlier you might need to remove the old-passwords flag from your my.cnf file

I called them, but they say they definitely doesn't use the old authentication mechanism. I'm googling for a week now, no real answers... I tried:
- mysql per console: works
- phpmyadmin athentication (cookie, config, http, ...): same problem
- newest phpmyadmin version: same problem
- mysql config old_passwords=1: no solution (cause it only manages how the password is saved)
- phpmyadmin extensions (mysql, mysqli): same problem
an lots of more. The guy from Hetzner said, they have the problem quite often with xampp users, so maybe a bug??

THX in advance, Ben
AndromedaXP
 
Posts: 1
Joined: 01. August 2011 13:27

Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 12 guests