MYSQL läuft nicht ?!

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

MYSQL läuft nicht ?!

Postby susi_0815 » 10. March 2004 10:13

Hallo Ihr,

ich hatte eine funktionieren XAMPP-Inst. auf meinem Rechenr.
Ich habe unter PHPMYADMIN ein Passwort für root vergeben.
Danach kam ich nicht mehr in PHPMYADMIN rein.
Es kam auch irgend eine Meldung bezüglich des Paswortes ... (genaueres hab ich mir leider nicht gemwerkt).

Ich hab daraufhin XAMPP neu installiert (apache und mysql sind gestartet, zumindest laut Taskmanager (apache.exe, mysqld.exe)).
Die Startseite läuft ja auch. Nur der Test für MYSQL schlägt fehl.

Hab ich mir mit meinem gebastel wegen dem Passwort irgendwas so zerschossen, das ich nicht mal nach einer Neuinstallation wieder den Urzustand habe ?? :?:

Ciao - Susi
susi_0815
 
Posts: 4
Joined: 10. March 2004 10:02

Nachtrag zu meiner Frage

Postby susi_0815 » 10. March 2004 11:46

Ich habe jetzt folgende Fehlermeldung zu sehen bekommen wenn ich PHPMYADMIN von der XAMPP-Startseite starte:

Fehler

MySQL meldet:

#2003 - Can't connect to MySQL server on 'localhost' (10061)

Hilft das bei der Problemlösung ??

Ciao - Susi
susi_0815
 
Posts: 4
Joined: 10. March 2004 10:02

Postby Wiedmann » 10. March 2004 12:39

Naja, man könnte davon ausgehen das MySQL nicht läuft.

Bist du sicher, dass MySQL auch gestartet wird?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Ich denke schon

Postby susi_0815 » 10. March 2004 14:10

Ich habe sowohl die apache_start.bat als auch die mysql_start.bat ausgeführt.

Im Taskmanager tauchen danache die Prozesse apache.exe und mysqld.exe auf.

Die letzte Zeile des sich öffnenden Dos-Fensters beim start von MYSQL lautet: MYSQL is starting with mysql\bin\my.cnf (console).

Ich hoffe das reicht damit es laufen sollte.

Ciao - Susi
susi_0815
 
Posts: 4
Joined: 10. March 2004 10:02

mysql

Postby sgftp » 10. March 2004 15:26

hi

hatte mal ähnliche probleme, öffne in dein phpmyadmin-verzeichniss die datei " config.inc.php " mit deinem editor, und ändere die zeile:

$cfg['Servers'][$i]['user'] = 'root'; // MySQL user
$cfg['Servers'][$i]['password'] = 'dein PW'; // MySQL password (only needed

ich hoffe, ich konnte dir helfen
User avatar
sgftp
 
Posts: 6
Joined: 10. March 2004 01:28
Location: localhost

Hurra - es hat geklappt --> Danke !!!

Postby susi_0815 » 11. March 2004 06:46

Hey,

ganz ganz herzlichen Dank.

Nachdem ich mein Passwort eingegeben habe, hat die XAMPP-Testseite endlich gezeigt, das der MYSQL-Server läuft.

Ich weis zwar nicht wieso es in der Standareinstellung nicht lief (Ich habe ja alles plattgemacht und XQAMPP neu installiert), aber das hat geholfen.

Jetzt funktioniert es auch erst mal wieder ohne Passwort.

Bevor ich das nächste Mal an Passwörtern rumänder werd ich mich erst mal schlau machen wie es richtig geht.

Also nochmal vielen Dank für den Tip -- sgftp -- !!!

Ciao - Susi
susi_0815
 
Posts: 4
Joined: 10. March 2004 10:02


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 6 guests