WAMPP1, Perl & 403

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

WAMPP1, Perl & 403

Postby kokosnuss » 08. March 2003 10:26

Hallo,

ich bin neu und habe gleich ein aus meiner Sicht großes Problem.
Ich habe das WAMPP1-Paket unter WindowsXP PRo auf G:\ installiert.
Auch die PHP.INI habe ich angepasst. Dann alles gestartet und getestet.
Alles scheint zu funktionieren, aber wenn ich das Perl-Script von meiner Homepage local ausprobieren will, dann geht das nicht.

Wenn ich das Script starte wird immer die sub_403 angesprungen.
:?: Warum? Ich bin unter WinXP Admin und sollte doch vollen Zugriff haben.

MfG
Heiko

Hier mal das Script:
http://www.kohlroula.de/download/guestbook2.txt
kokosnuss
 
Posts: 42
Joined: 08. March 2003 10:04
Location: Bremerhaven
XAMPP Version: 5.6.3
Operating System: Windows 7 Pro

Postby boppy » 08. March 2003 11:47

ändere die erste zeile des scripts mal in

#!\%WAMPP-ORNDER%\perl\bin\perl.exe

Da musst du nämlich angeben, wo er die PERL.EXE findet...
...in diesem Sinne
yours boppy

Interpunktion und Orthographie dieses Beitrags sind frei erfunden.
Eine Übereinstimmung mit aktuellen oder ehemaligen Regeln wäre rein zufällig und ist nicht beabsichtigt.
User avatar
boppy
AF Moderator
 
Posts: 501
Joined: 27. December 2002 02:15
Location: W-E-City

Postby kokosnuss » 08. March 2003 14:09

Hallo Bobby,

boppy wrote:ändere die erste zeile des scripts mal in
#!\%WAMPP-ORNDER%\perl\bin\perl.exe

Da musst du nämlich angeben, wo er die PERL.EXE findet...


aua, danke das war mein größter Fehler. Bei lauter Rumprobiererei
habe das nicht angepaßt.

Ich bekomme ich aber wenn ich
http://www.kohlroula.de/download/guestbook2a.txt
aufrufe noch die folgende Fehlermeldung im "error.log":
"Can't open http://localhost/htdocs/usr/kohlroula.d ... tbook2.dat: Invalid argument".

Da ich ja aber eigentlich nur die Pfade angepaßt habe, verstehe ich diese Meldung jetzt nicht.

Kannst Du nochmal helfen?

MfG
Heiko
kokosnuss
 
Posts: 42
Joined: 08. March 2003 10:04
Location: Bremerhaven
XAMPP Version: 5.6.3
Operating System: Windows 7 Pro

Postby Morpheus » 08. March 2003 16:53

Hi
Code: Select all
Ich bekomme ich aber wenn ich
http://www.kohlroula.de/download/guestbook2a.txt
aufrufe noch die folgende Fehlermeldung im "error.log":
"Can't open http://localhost/htdocs/usr/kohlroula.de/cgi-bin/guestbook2.dat: Invalid argument".


Irgendwo stimmt ein Link nicht ganz : http://localhost/htdocs/usr/kohlroula.d ... tbook2.dat

Such mal, ob da irgendwas nicht stimmt, da /htdocs/usr ein Linux/Unix Dateiname ist und kein Windowsname.

Kontrolier mal den Link.
mfg
Morph
Morpheus
 
Posts: 218
Joined: 17. January 2003 20:58

Postby kokosnuss » 08. March 2003 19:33

Hallo,

Morpheus wrote:Hi
Irgendwo stimmt ein Link nicht ganz : http://localhost/htdocs/usr/kohlroula.d ... tbook2.dat

Such mal, ob da irgendwas nicht stimmt, da /htdocs/usr ein Linux/Unix Dateiname ist und kein Windowsname.

Kontrolier mal den Link.


das mit dem /usr/ stimmt schon, das ich als home localhost/usr definiert habe. Bei meinem Provider läuft es unter www.kohlroula.de.
Ich habe auch schon die verschiedenen Verzeichniskombinationen erfolglos probiert. Und schreibgeschützt ist die .DAT-Datei auch nicht.
Die .Dat ist eine einfache TXT in der die Einträge zeilenweise drinstehen.

Vielleicht hat noch jemand ein Idee. :?:

MfG
Heiko
kokosnuss
 
Posts: 42
Joined: 08. March 2003 10:04
Location: Bremerhaven
XAMPP Version: 5.6.3
Operating System: Windows 7 Pro

Postby Morpheus » 08. March 2003 19:47

Du testest das ganze doch lokal auf deinem Rechner, oder?

Dann brauchst du doch aber keinen Linux-Link, sondern einen Link für das Windowsdateisystem.

Wo ist den die Datei? Auf dem Webserver deines Hosters, oder bei dir Lokal?

mfg
Morph
Morpheus
 
Posts: 218
Joined: 17. January 2003 20:58

Postby kokosnuss » 08. March 2003 20:11

Hallo,

Morpheus wrote:Du testest das ganze doch lokal auf deinem Rechner, oder?

Ja.

Dann brauchst du doch aber keinen Linux-Link, sondern einen Link für das Windowsdateisystem.

Das ist mir schon klar. Ich habe die Bezeichnung nur gewählt um möglichst wenig ändern zu müssen.

Wo ist den die Datei? Auf dem Webserver deines Hosters, oder bei dir Lokal?

Lokal auf meinem Rechner im gleichen Verzeichnis wie die .PL-Datei.
Im Verzeichnis "G:\wampp1\htdocs\usr\kohlroula.de\cgi-bin".
Die die .OL-Datei aufrufende Datei liegt in "G:\wampp1\htdocs\usr\kohlroula.de" und ruft die .PL so auf: "<a href="cgi-bin/guestbook2.pl?user_read">Gaestebuch</a>" .

Wahrscheinlich sehe ich mal wieder den Wald vor lauter Bäumen nicht. :(

MfG
Heiko
kokosnuss
 
Posts: 42
Joined: 08. March 2003 10:04
Location: Bremerhaven
XAMPP Version: 5.6.3
Operating System: Windows 7 Pro

Postby Morpheus » 08. March 2003 20:15

Hi
Probier doch mal einen Direkten Link
Nicht http://localhost/htdocs/usr/kohlroula.d ... tbook2.dat, sondern G:\wampp\htdocsusr\kohlroula.de\cgi-bin\guestbook2.dat
mfg
Morph
Morpheus
 
Posts: 218
Joined: 17. January 2003 20:58

Postby kokosnuss » 08. March 2003 20:59

Hallo,

Morpheus wrote:Hi
Probier doch mal einen Direkten Link
Nicht http://localhost/htdocs/usr/kohlroula.d ... tbook2.dat, sondern G:\wampp\htdocsusr\kohlroula.de\cgi-bin\guestbook2.dat


:oops: Das war es - Danke.
Aber im Script selber scheint noch ein Fehler zu sein.
Wenn ich einen neuen Eintrag ausführen will, dann lädt der Browser
irgendwas runter, das Log zeigt keine Fehler, aber mehr passiert nicht. :cry:

Weißt Du zufällig wie ich Perl dazu bewege das Fenster nicht gleich zu schließen? Mit WindowsXP Mittel schaffe ich das nicht und ohne sehe ich nicht was da los ist.
Aber das gehört wahrscheinlich besser in das PERL-Forum.

MfG
Heiko
kokosnuss
 
Posts: 42
Joined: 08. March 2003 10:04
Location: Bremerhaven
XAMPP Version: 5.6.3
Operating System: Windows 7 Pro

Postby Morpheus » 08. March 2003 21:08

Hi
Probier mal Sysinfo von http://www.coder-world.de
mfg
Morph
Morpheus
 
Posts: 218
Joined: 17. January 2003 20:58

Postby kokosnuss » 08. March 2003 21:42

Hey,

Morpheus wrote:Hi
Probier mal Sysinfo von http://www.coder-world.de


Läuft leider auch nicht. Im Errorlog kann ich zwar einige Infos entnehmen
aber das wars dann auch.
Werde mir mal mein Script ausdrucken und versuchen den Fehler auf dem Papier zu finden.

Schönen Abend noch.

MfG
Heiko
kokosnuss
 
Posts: 42
Joined: 08. March 2003 10:04
Location: Bremerhaven
XAMPP Version: 5.6.3
Operating System: Windows 7 Pro


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 5 guests