Kann Apache-Server nicht über den Browser aufrufen

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Kann Apache-Server nicht über den Browser aufrufen

Postby luctho » 04. March 2004 13:29

Ich hatte vorher eine ältere Version eingerichtet. Dies erfolgte mit Hilfe des Adobe Dynamic Content Servers (Apache+Tomcat+PhP).

Dieser lief auf Port 82. Ich habe das Ganze deinstalliert und Xammp gem. Anleitung eingerichtet. Der Server startet auch (Kann ich im TaskManager und der Anwendungüberwachung der Firewall: MacAffee sehen). Die Applikation habe ich in der Firewall feigeschaltet und auch bereits mit deaktivierter Firewall getestet- ohne Erfolg.

Zunächst habe ich die Standardeinstellungen (Port 80, localhost) versucht und dann den Port auf 82, server geändert. Der Aufruf mit http://IP:82,
und http://server:82 war erfolglos.Alternativ habe ich Apache mit dem Installer-Packet (apache.org) installiert. Auch der läuft nicht.

Was tun ??
luctho
 
Posts: 2
Joined: 04. March 2004 12:00

Postby Kristian Marcroft » 04. March 2004 13:31

Hi,

Apache in der Firewall freigschaltet?
Auch Port 82? Deinstalliere mal deinen Mcafee...
Schau mal ins Error.log?
Schau mal ins access.log. Was kommt?

So long
KriS
User avatar
Kristian Marcroft
AF Moderator
 
Posts: 2962
Joined: 03. January 2003 12:08
Location: Diedorf

Das ging aber schnell !

Postby luctho » 04. March 2004 13:41

Apache in der Firewall freigschaltet?

Der Apache ist in der FW freigeschaltet. Habe die Fw auch mal komplett deaktiviert und die vorherige Apache 1.3.x -Version lief mit der Fw.

Schau mal ins Error.log?

[Thu Mar 04 13:09:35 2004] [notice] Parent: Created child process 2532
[Thu Mar 04 13:09:36 2004] [notice] Child 2532: Child process is running
[Thu Mar 04 13:09:36 2004] [notice] Child 2532: Acquired the start mutex.
[Thu Mar 04 13:09:36 2004] [notice] Child 2532: Starting 250 worker threads.
[Thu Mar 04 13:11:15 2004] [notice] Parent: Received shutdown signal -- Shutting down the server.
[Thu Mar 04 13:11:15 2004] [notice] Child 2532: Exit event signaled. Child process is ending.
[Thu Mar 04 13:11:16 2004] [notice] Child 2532: Released the start mutex
[Thu Mar 04 13:11:17 2004] [notice] Child 2532: Waiting for 250 worker threads to exit.
[Thu Mar 04 13:11:17 2004] [notice] Child 2532: All worker threads have exited.
[Thu Mar 04 13:11:17 2004] [notice] Child 2532: Child process is exiting
[Thu Mar 04 13:11:17 2004] [notice] Parent: Child process exited successfully.
[Thu Mar 04 13:11:23 2004] [notice] Parent: Created child process 3596
[Thu Mar 04 13:11:23 2004] [notice] Child 3596: Child process is running
[Thu Mar 04 13:11:23 2004] [notice] Child 3596: Acquired the start mutex.
[Thu Mar 04 13:11:23 2004] [notice] Child 3596: Starting 250 worker threads.
[Thu Mar 04 13:29:21 2004] [notice] Parent: Received shutdown signal -- Shutting down the server.
[Thu Mar 04 13:29:21 2004] [notice] Child 3596: Exit event signaled. Child process is ending.
[Thu Mar 04 13:29:22 2004] [notice] Child 3596: Released the start mutex
[Thu Mar 04 13:29:24 2004] [notice] Child 3596: Waiting for 250 worker threads to exit.
[Thu Mar 04 13:29:24 2004] [notice] Child 3596: All worker threads have exited.
[Thu Mar 04 13:29:24 2004] [notice] Child 3596: Child process is exiting
[Thu Mar 04 13:29:24 2004] [notice] Parent: Child process exited successfully.

Access.log ist leer!

Noch eine Idee?
luctho
luctho
 
Posts: 2
Joined: 04. March 2004 12:00

Re: Das ging aber schnell !

Postby Kristian Marcroft » 04. March 2004 15:33

luctho wrote:
Apache in der Firewall freigschaltet?

Der Apache ist in der FW freigeschaltet. Habe die Fw auch mal komplett deaktiviert und die vorherige Apache 1.3.x -Version lief mit der Fw.

Noch eine Idee?
luctho

Hi,

mit APache 2 sind mehrere Probleme mit Firewalls bekannt. Ein deaktivieren der Firewall bringt dann nichts. Die Firewall muss deinstalliert werden.

Probier das mal aus..
So long
KriS
User avatar
Kristian Marcroft
AF Moderator
 
Posts: 2962
Joined: 03. January 2003 12:08
Location: Diedorf


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 14 guests