xampp 1.7.4 php 4.4.9 als cgi über .htaccess einbinden

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

xampp 1.7.4 php 4.4.9 als cgi über .htaccess einbinden

Postby bamboleo » 30. April 2011 21:41

Hallo,

ich brauche für alte Zend-optimierte Dateien einen lauffähigen ZendOptimizer.

Der ZendOptimizer ist ja in der aktuellen Version installiert, aber er scheint die Dateien nicht korrekt zu dekodieren, da immer die Fehlermeldung kommt "ZendOptimizer ist nicht installiert".

Da ich das gleiche Problem schon bei meinem ehemaligen Hoster hatte, wenn ich die PHP-Version umgestellt habe, vermute ich, dass es an der PHP-Version liegt.
Bei meinem Hoster war das Problem weg, wenn ich die Seiten mit PHP 4.4.9 aufgerufen habe und wieder vorhanden, wenn ich es mit PHP 5.2.10 aufgerufen habe.
Könnte natürlich auch an einer Fehlkonfiguration beim Hoster gelegen haben, dass da bei den verschiedenen PHP-Versionen Zend jeweils anders konfiguriert war.

Was habe ich schon probiert:

Ich habe den neuesten xampp installiert.
Es läuft auch alles soweit ohne probleme.
Den Eaccelerator habe ich aktiviert, jedoch dekodiert er die Seiten nicht. Gibt es da eventull Probleme mit der Abwärtskompatibilität?

Nun habe ich php 4.4.9 runtergeladen und in einen neuen Ordner php-cgi entpackt und die empfohlene php.ini in dem Ordner aktiviert.
Dann habe ich die httpd.conf angepasst

Folgende Einträge habe ich eingefügt

Code: Select all
<Directory "C:/xampp/php-cgi/">
AllowOverride None
Options None
Order allow,deny
Allow from all
</Directory>


und

Code: Select all
ScriptAlias /php-cgi/ "C:/xampp/php-cgi/"


Damit der ZendOpztimizer auch von PHP 4.4.9 geladen wird, habe ich in die php.ini am Ende folgendes eingefügt
Code: Select all
;;;;;;;;;;;;;;;;;;;;
; Zend Options ;
;;;;;;;;;;;;;;;;;;;;
zend_extension="/zendOptimizer/lib/Optimizer/php-4.4.x/ZendOptimizer.dll"
zend_loader.enable=1
zend_loader.disable_licensing=0


und die Dateien aus dem eigentlichen PHP-Verzeichnis (C:\xampp\php\) in den Ordner von php4.4.9 kopiert.

In die .htaccess habe ich folgendes geschrieben

Code: Select all
SetEnv PHPRC "C:/xampp/php-cgi/php-4.4.9/"
AddHandler application/x-php449 .php
Action application/x-php449 "/php-cgi/php-4.4.9/php.exe"



Nun habe ich in der httpd-xampp.conf folgenden Eintrag gefunden:

Code: Select all
ScriptAlias /php-cgi/ "C:/xampp/php/"
<Directory "C:/xampp/php">
   AllowOverride None
   Options None
   Order deny,allow
   Deny from all
   <Files "php-cgi.exe">
       Allow from all
   </Files>
</Directory>


Welcher meine ganzen Einstellungen aushelbeln dürfte.

Wenn ich diesen Bereich allerdings mit # auskommentiere, startet der Apache nicht mehr.

Im Moment blick ich selbst grad nicht mehr durch, muss wohl mal ne Nacht drüber schlafen.
Vielleicht kann ja jemand was zu der Problematik sagen oder sieht schon einen Fehler.

Danke vorab und allen ein schönes Wochenende.
bamboleo
 
Posts: 1
Joined: 30. April 2011 21:17

Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 8 guests