Xampp 1.7.1 / Addon Tomcat / mod_jk konfigurieren?

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Xampp 1.7.1 / Addon Tomcat / mod_jk konfigurieren?

Postby lacma » 15. April 2011 16:42

Hallo
Installation: WinServer 2003 / Xampp Version 1.7.1 / Addon Tomcat
Will über Web auf eine neue Anwendung zugreifen. Diese läuft auf Tomcat. Der Server ist über eine dynamische IP-Adresse erreichbar. Mit Hilfe eines DYNDNS - Hostname greife ich auf den Server zu. Der Zugriff ist nur über die Standardports :80 bzw. :443 möglich da die Portnummer von DYNDNS nicht weitergereicht wird. D.h. ich muss über z.B. "http://domain.ch/subdomain/" einen Link bauen.

Tomcat ist lokal (nur) über localhost:8080 erreichbar. Der Konfiguration meiner Xampp-Installation ist derart kompliziert und unübersichtlich, dass ich nicht mehr durchblicke wie ich diese Weiterleitung auf Tomcat einrichten kann.
An der Installation von Xampp habe ich lediglich einen neuen <VirualHost> erstellt. Sonst ist alles gemäss Standard-Installation Xampp-Installer.

Gemäss meinen bisherigen 'Nachforschungen' gibt es hierfür ein Modul 'mod_jk'. Leider schaffe ich es nicht dieses funtionstüchtig einzurichten.
kann mir jemand eine Anleitung geben wie dies in Xampp einfach zu konfigurieren ist?

vielen Dank für die Unterstützung
lacma
lacma
 
Posts: 2
Joined: 13. October 2009 08:09
Location: Egerkingen

Re: Xampp 1.7.1 / Addon Tomcat / mod_jk konfigurieren?

Postby daniel1977 » 16. April 2011 14:18

moin,moin,
noch ein blutiger anfänger, aber irgendwann hat jeder mal angefangen!
also zur meiner frage:

OS.: Win7
Firewall.: Win & Zonealarm

XAMPP 1.7.4.
plus tomcat (ist schon mit dabei)
sowie JDK installiert

Ich habe den ganzen spass installiert, kann überall zugreifen, aber wenn ich versuche auf tomcat zuzugreiden, erhalte ich jedes mal die fehlermeldung 503.
Auf der Ebene von XAMPP steht drin, dass der tomcat nicht auf den port 8080 läuft. ich habe glaub´ich alles mögliche ausprobiert, FIREWALL´s deaktiviert, neuistallation und und und und, ich brauche HILFE.
daniel1977
 
Posts: 1
Joined: 16. April 2011 14:12

Re: Xampp 1.7.1 / Addon Tomcat / mod_jk konfigurieren?

Postby lacma » 17. April 2011 21:30

Hallo Daniel

diese Erfahrung hatte ich auch schon.
prüf einmal ob Du sonst eine Anwendung mit dem Port 8080 bedienst.
das führt zu Konflikten und so kannst Du den Service von Tomcat nicht starten.

zumindest war dies bei mir der Verursacher dieser Meldung 503.

Du hast mir demnach keinen Ratschlag wie man sich im .conf Daten-Jungle zurechtfindet, damit die mod_jk mit Tomcat richtig funktioniert?

Gruss
lacma
lacma
 
Posts: 2
Joined: 13. October 2009 08:09
Location: Egerkingen


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 14 guests