mod_rewrite > ordner weg?

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

mod_rewrite > ordner weg?

Postby NaMex » 28. March 2011 09:56

Guten Morgen zusammen :-)

ich habe leider über die Forensuche nix gefunden bzw bin jetzt auch ratlos nach was ich suchen sollte.

Ich habe folgendes Problem:

Ich habe eben mod_rewrite installiert bzw aktiviert.
Jetzt habe ich allerdings das problem das im ordner "htdocs > page > unterordner" die seite liegt und dieser wird nicht angezeigt.
Andere ordner "htdocs > page > CMS" oder datein die im Ordner "page" liegen werden z.b.angezeigt.

Normale Ordner werden angezeigt, aber genau dieser ordner wo die seite drin liegt, nicht...
Hätte jemand vllt. eine Idee?

Was bräuchtet Ihr noch für Informationen?

*** Edit
Liegt an der .htaccess Datei im Ordner...^^ >.<
sorry

RewriteCond %{HTTP_HOST} ^localhost/outfitter [NC]
RewriteRule ^(.*)$ http://localhost/outfitter/$1 [L,R=301]

kann mir da jemand sagen, wieso das nicht geht?
NaMex
 
Posts: 1
Joined: 28. March 2011 09:07

Re: mod_rewrite > ordner weg?

Postby WilliL » 28. March 2011 16:39

NaMex wrote:RewriteCond %{HTTP_HOST} ^localhost/outfitter [NC]
RewriteRule ^(.*)$ http://localhost/outfitter/$1 [L,R=301]

für mich sieht das wie ein Ringrouting aus:
mach mal in das Unterverzeichnis /outfitter/ eine .htaccess Datei rein mit dem Inhalt: RewriteEngine Off
Auch im Unterverzeichnis gilt deine .htacces mit deinem Inhalt noch, solange er nicht modifiziert wird. (oder hat sich dein %{HTTP_HOST} geändert? :wink: )
Willi
WilliL
 
Posts: 661
Joined: 08. January 2010 10:54
Operating System: Win7Home Prem 64 SP1


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 7 guests