Problem mit externen CSS Dateien bei Xampp (windows 7)

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Problem mit externen CSS Dateien bei Xampp (windows 7)

Postby JochenT » 22. March 2011 00:02

Hallo allerseits.
ich habe vor kurzem auf einem Rechner mit Windows7 Xampp (1.7.3) installiert um ein Web Projekt lokal zu testen und zu editieren. Mein Problem ist jedoch, dass Änderungen an meiner externen CSS Datei keinen Einfluss auf das Layout der Seite haben. An sich wird alles korrekt angezeigt, doch wenn ich an der Datei etwas ändere oder neue Tags hinzufüge werden diese Veränderungen im Browser nicht dargestellt.

Dass ich Fehler in der Syntax habe kann ich komplett ausschließen. Selbst wenn ich lediglich den Pixelwert einer bereits bestehenden Positionierung verändere tut sich da nichts.

Ich lade die CSS datei wiefolgt:
<link href="layout.css" media="screen" rel="stylesheet" type="text/css" />
Die Datei layout.css befindet sich im selben Ordner wie meine php Datei, daran liegt es also auch nicht.

Ist es möglich, dass Xampp irgendwelche besonderen Config-Einstellungen benötigt damit man reibungslos mit CSS files arbeiten kann?
Kann es eventuell auch sein, dass da permanent eine gecachte Datei benutzt wird anstatt meiner neu editierten?

Ich weiß wirklich nicht mehr weiter, finde auch im Netz keine konkrete Antwort auf das Problem...
somit schon einmal danke im Voraus für alle hilfreichen Anregungen 8)
JochenT
 
Posts: 2
Joined: 21. March 2011 23:55

Re: Problem mit externen CSS Dateien bei Xampp (windows 7)

Postby Altrea » 22. March 2011 01:36

Hallo Jochen,

JochenT wrote:Hallo allerseits.
ich habe vor kurzem auf einem Rechner mit Windows7 Xampp (1.7.3) installiert um ein Web Projekt lokal zu testen und zu editieren. Mein Problem ist jedoch, dass Änderungen an meiner externen CSS Datei keinen Einfluss auf das Layout der Seite haben. An sich wird alles korrekt angezeigt, doch wenn ich an der Datei etwas ändere oder neue Tags hinzufüge werden diese Veränderungen im Browser nicht dargestellt.

Bei diesem Szenario denke ich sofort an Browsercache. Mal geleert um das Problem eingrenzen zu können?

JochenT wrote:Dass ich Fehler in der Syntax habe kann ich komplett ausschließen. Selbst wenn ich lediglich den Pixelwert einer bereits bestehenden Positionierung verändere tut sich da nichts.

Würde ich bei deiner Schilderung nicht komplett ausschließen. Zum einen gilt es nachzuprüfen, ob die vorherige Positionierung überhaupt übernommen wurde oder nicht bereits durch zum Beispiel eine explizitiere Regel (Stichwort CSS Kaskaden-Modell) überschrieben wurde, oder vielleicht doch in der CSS Datei ein Syntax Fehler steckt, der zu diesem unvorhergesehenen Verhalten führt. Dies kann man mit Tools wire Firebug sehr schnell sehen, wenn eine Regel keine Beachtung findet.

Anlaufpunkt Nummer eins ist aber der Browsercache.

JochenT wrote:Ist es möglich, dass Xampp irgendwelche besonderen Config-Einstellungen benötigt damit man reibungslos mit CSS files arbeiten kann?
Kann es eventuell auch sein, dass da permanent eine gecachte Datei benutzt wird anstatt meiner neu editierten?

Apache sind die CSS Dateien völlig schnuppe. Das einzige was du da getan haben könntest wäre den CSS Dateien Expire Dates mitzugeben zur Cachesteuerung. Aber sowas tut man in der Regel nicht unbewußt.

JochenT wrote:Ich weiß wirklich nicht mehr weiter, finde auch im Netz keine konkrete Antwort auf das Problem...

Findest du bestimmt, nur wahrscheinlich unzählige verschiedene Antworten, da du das Problem nicht ausreichend genug eingegrenzt hast.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8286
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Problem mit externen CSS Dateien bei Xampp (windows 7)

Postby JochenT » 22. March 2011 19:14

Gut, ich habe eine recht simple Lösung gefunden, da mit der CSS Datei letztendlich wirklich alles in Ordnung war.
STRG + F5 bei geöffnetem Browserfenster drücken aktualisiert alles und leert nebenbei den Cache so dass es korrekt angezeigt wird.
Ich schätze man lernt halt nie aus...
JochenT
 
Posts: 2
Joined: 21. March 2011 23:55


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 18 guests