2 Ordner - 2 PHP Versionen?

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

2 Ordner - 2 PHP Versionen?

Postby chrisribal » 20. March 2011 22:29

Hallo,

ich betreibe mit der aktuellen xampp Version 1.7.4 einen kleinen Entwicklungsserver.

Nun habe ich von einem Kunden den Auftrag bekommen, seine Joomla Site zu optimieren.
Um den laufenden Betrieb während der Umbauarbeiten nicht zu gefährden, wollte ich die Joomla Installation nun auf meinen Server spiegeln und anschließend wieder auf den Online-Server spielen.

Leider läuft das Joomla aber auch nach Anpassung aller Programmpfade nicht auf meinem Server und wirft nur verschiedene Fehler aus. Nun habe ich im Internet gelesen, dass diese etwas veraltete Version von Joomla ganz einfach zu alt für die aktuellste PHP-Version ist. Auf seinem Server läuft immerhin PHP 5.2.6, auf meinem aber aben die 5.3.5.

Ich möchte mir, um ehrlich zu sein, aber nicht die Mühe machen und das komplette Joomla updaten, weil dort viele Module drinhängen und ein paar davon wiederum nicht mit der neuesten Joomla Version laufen etc.

Habe nun also die PHP 5.2.6 heruntergeladen und sie in den Ordner /xampp/php526 entpackt. In der httpd.conf habe ich einfach versucht, für das spezifische Projektverzeichnis im root eben diese PHP Version zu laden:

Code: Select all
<Directory "F:/htdocs/xxx.de">
   LoadModule php5_module "C:\Programme\xampp\php526\php5apache2.dll"
</Directory>
<Directory "F:/htdocs">
   # Restliche Einstellungen
</Directory>


Mir ist schon klar, dass das auf diesem Wege nicht so einfach machbar sein wird.

Wie kriege ich es nun hin, dass nur in dem einen Projektordner die 5.2.5 geladen wird?

Vielen Dank
Chris
chrisribal
 
Posts: 1
Joined: 20. March 2011 22:15

Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 8 guests