.htaccess Problem

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

.htaccess Problem

Postby Incognito » 21. February 2004 15:23

Ich möchte, dass in einem bestimmten Verzeichniss nicht die index.php aufgerufen wird, sondern die portal.php.

Habe jetzt schon stundenlang mit der .htaccess rumgespielt aber es klappt nicht.

Habe auch schon den Server neu gestartet aber er läd immer noch die index.php
Incognito
 
Posts: 33
Joined: 21. February 2004 15:20
Operating System: Windows 7

Postby DJ DHG » 21. February 2004 15:28

Moin Moin

wie sieht deine htaccess aus?

du kannst alternativ auch einfach weiterleiten?

mfg DJ DHG
User avatar
DJ DHG
AF Moderator
 
Posts: 2455
Joined: 27. December 2002 13:50
Location: Kiel

Re: .htaccess Problem

Postby steini » 21. February 2004 15:31

Incognito wrote:Ich möchte, dass in einem bestimmten Verzeichniss nicht die index.php aufgerufen wird, sondern die portal.php.

Habe jetzt schon stundenlang mit der .htaccess rumgespielt aber es klappt nicht.

Habe auch schon den Server neu gestartet aber er läd immer noch die index.php


Huhu.

mach dir doch einfach ne index.php mit folgendem inhalt:

Code: Select all
<meta http-equiv="refresh" content="0;URL=portal.php">


dann sollte das dein problem beheben
V-Server ab 7,90€ bei simplyroot
---
Image
User avatar
steini
 
Posts: 191
Joined: 24. October 2003 00:24
Location: Helmstedt
Operating System: Windows 10 Tech Preview

Postby Incognito » 21. February 2004 15:35

Die .htaccess sieht so aus:


DirectoryIndex index.html index.htm portal.php index.php


Ist evtl die Schreibweise falsch, oder fehlt da was ???





Die index.php kann ich nicht ändern, da die Datei auch gebraucht wird.
Incognito
 
Posts: 33
Joined: 21. February 2004 15:20
Operating System: Windows 7

Postby DJ DHG » 21. February 2004 15:35

@ steini19

warum PHP mit Java vergewaltigen? PHP kann das viel besser!

Code: Select all
<?PHP
header("Location: portal.php");
?>


mfg DJ DHG
User avatar
DJ DHG
AF Moderator
 
Posts: 2455
Joined: 27. December 2002 13:50
Location: Kiel

Postby DJ DHG » 21. February 2004 15:37

Incognito wrote:DirectoryIndex index.html index.htm portal.php index.php


gerade erst gesehn, stelle mal die portal.php an erster stelle.

es wird immer die datei zuerst aufgerufen die an erster stelle steht,

also

Code: Select all
DirectoryIndex portal.php index.html index.htm index.php


mfg DJ DHG
User avatar
DJ DHG
AF Moderator
 
Posts: 2455
Joined: 27. December 2002 13:50
Location: Kiel

Postby Incognito » 21. February 2004 15:43

Tja, hilft alles nicht...


Er scheint die .htaccess zu ignorieren...



Hat noch jemand ne Idee ???
Incognito
 
Posts: 33
Joined: 21. February 2004 15:20
Operating System: Windows 7

Postby DJ DHG » 21. February 2004 15:52

was passiert wenn du das so schreibst?

Code: Select all
DirectoryIndex portal.php


und eine neue leere zeile beginst, also einfach enter?

mfg DJ DHG
User avatar
DJ DHG
AF Moderator
 
Posts: 2455
Joined: 27. December 2002 13:50
Location: Kiel

Postby Incognito » 21. February 2004 19:28

Leider das gleiche.



Es wird immer die Index.php geladen. *grummel*
Incognito
 
Posts: 33
Joined: 21. February 2004 15:20
Operating System: Windows 7

Postby berni » 21. February 2004 23:14

Hi Incognito

ich werfe auch mal meine zwei Cents zum Thema .htaccess ein.

1) Warum musst du das ganze in der .htaccess machen - schreib es doch direkt in die http.conf -

<Directory /was/auch/immer>
DirectoryIndex portal.php
</Directory>

Bitte nicht schimpfen wenn die Syntax nicht genau stimmt :-), ich schreib das eben nur mal so runter

2) Wenn es denn in der .htaccess sein muss, und nachdem du schon sagst, dass du das Gefühl hast, dass er diese ignoriert - Hast du in der http.conf das entsprechende Verzeichnis auch so "geschaltet", dass die .htaccess auch ausgeführt wird

<Directory /was/auch/immer>
AllowOverride All (Options sollte theoretisch auch reichen)
</Directory>

Hope that somehow helps (und wenn nicht war es zumindestens gut gemeint :-)

Bernhard
berni
 
Posts: 8
Joined: 15. December 2003 16:27

Postby Incognito » 21. February 2004 23:22

Habs eben in der Config geändert und es geht.


Ist eigentlich auch egal, da es nur in einem Verzeichnis die portal.php gibt.


Danke nochmal für die Tipps...



EDIT:

Habe aber auch deinen zweiten Tipp nochmal probiert und
nach Freigabe des Verzeichnisses in der Config frisst er nun auch die .htaccess.
Incognito
 
Posts: 33
Joined: 21. February 2004 15:20
Operating System: Windows 7


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 6 guests