Domain Auf Ordner Zuweissen Problem

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Domain Auf Ordner Zuweissen Problem

Postby Sawyer2111 » 22. February 2011 00:01

hallo Apache Friends

Ich habe ein Problem seit dem ich das neue xampp habe geht das mit den Domain zuweisen nicht wirklich

Ich habe ein andren Thema was gefunden und die beschreiben das ganz einfach also habe ich das mal versucht =)

Code: Select all
NameVirtualHost *:80

<VirtualHost *:80>
   DocumentRoot /xampp/htdocs/Blog
   ServerName sawyerblog
   ServerAlias www.kingdomraee.de
</VirtualHost>

<VirtualHost *:80>
   DocumentRoot /xampp/htdocs/Forum
   ServerName NewmanForum
   ServerAlias www.deutsche-computer-helpline.t-tf.de
</VirtualHost>

<VirtualHost *:80>
   DocumentRoot /xampp/htdocs
   ServerName localhost
</VirtualHost>


so Stande das da bloß das da dann Domain.de stand statt meine Seiten

ich habe das vor halbes Jahr schon mal benutze und da ging es einwandfrei und jetzt nicht mehr ich verstehe es einfach nicht
wen ich auf kingdomraee.de geht dann ruft er das Blog auf aber wen ich dann auf deutsche-computer-helpline.t-tf.de gehe dann ruft er auch das Blog auf und nicht das Forum was er eigentlich sollte

weiß einer eine Lösung bedanke mich in vor raus =)

hier noch der error log falls einer den sehen will
Code: Select all
[Mon Feb 21 23:36:31 2011] [notice] Parent: Received shutdown signal -- Shutting down the server.
[Mon Feb 21 23:36:31 2011] [notice] Child 39392: Exit event signaled. Child process is ending.
[Mon Feb 21 23:36:32 2011] [notice] Child 39392: Released the start mutex
[Mon Feb 21 23:36:33 2011] [notice] Child 39392: All worker threads have exited.
[Mon Feb 21 23:36:33 2011] [notice] Child 39392: Child process is exiting
[Mon Feb 21 23:36:34 2011] [notice] Parent: Child process exited successfully.
[Mon Feb 21 23:36:41 2011] [notice] Digest: generating secret for digest authentication ...
[Mon Feb 21 23:36:41 2011] [notice] Digest: done
[Mon Feb 21 23:36:43 2011] [notice] Apache/2.2.17 (Win32) mod_ssl/2.2.17 OpenSSL/0.9.8o PHP/5.3.4 mod_perl/2.0.4 Perl/v5.10.1 configured -- resuming normal operations
[Mon Feb 21 23:36:43 2011] [notice] Server built: Oct 18 2010 01:58:12
[Mon Feb 21 23:36:43 2011] [notice] Parent: Created child process 8648
[Mon Feb 21 23:36:45 2011] [notice] Digest: generating secret for digest authentication ...
[Mon Feb 21 23:36:45 2011] [notice] Digest: done
[Mon Feb 21 23:36:46 2011] [notice] Child 8648: Child process is running
[Mon Feb 21 23:36:46 2011] [notice] Child 8648: Acquired the start mutex.
[Mon Feb 21 23:36:46 2011] [notice] Child 8648: Starting 150 worker threads.
[Mon Feb 21 23:36:46 2011] [notice] Child 8648: Starting thread to listen on port 443.
[Mon Feb 21 23:36:46 2011] [notice] Child 8648: Starting thread to listen on port 80.


Gruss saw
Sawyer2111
 
Posts: 4
Joined: 21. February 2011 23:50

Re: Domain Auf Ordner Zuweissen Problem

Postby Nobbie » 22. February 2011 12:09

Ist das wirklich die vollständige 1:1 Kopie der VirtualHost Konfiguration?
Nobbie
 
Posts: 8772
Joined: 09. March 2008 13:04

Re: Domain Auf Ordner Zuweissen Problem

Postby Sawyer2111 » 22. February 2011 14:08

ja ist sie ich kann dir ja mal sein Bild von machen
Image
Sawyer2111
 
Posts: 4
Joined: 21. February 2011 23:50

Re: Domain Auf Ordner Zuweissen Problem

Postby Nobbie » 22. February 2011 15:07

Du solltest in den VirtualHosts auch Logdateien und Berechtigungen festlegen (nicht außerhalb).

Was mir auffällt:

aber wen ich dann auf deutsche-computer-helpline.t-tf.de gehe


Für deutsche-computer-helpline.t-tf.de gibt es ja auch keinen VirtualHost (und keinen ServerAlias), dann ist logisch, dass Apache den ersten VirtualHost nimmt (das tut er immer dann, wenn der Domain Name unbekannt ist). Du müßtest schon www.deutsche-computer-helpline.t-tf.de eingeben (oder den ServerAlias deutsche-computer-helpline.t-tf.de definieren).
Nobbie
 
Posts: 8772
Joined: 09. March 2008 13:04

Re: Domain Auf Ordner Zuweissen Problem

Postby Sawyer2111 » 22. February 2011 15:40

ich habe doch www.deutsche-computer-helpline.t-tf.de drine stehen und die sub Domain ist auch angelt ich wollte eigentlich nur das man wen man www.deutsche-computer-helpline.t-tf.de auf ruft das die Sachen die im Forum Ordner drin stehen auf gerufen wird zb das Forum und das das Blog aus den Blog Ordner auf gerufen wird will freund sagte mache es dir doch einfacher
mache doch einfach zb www.deutsche-computer-helpline.t-tf.de/forum und dann wird automatisch das Forum auf gerufen ja aber wen ich dann nur www.deutsche-computer-helpline.t-tf.de mache dann wird wieder das Blog aufgerufen und das ist doof ich habe das auch damals vor halben Jahr gemacht da ging es aber jetzt nicht und so viel Ahnung habe ich auch nicht da von aber ich würde es gerne lernen
Sawyer2111
 
Posts: 4
Joined: 21. February 2011 23:50

Re: Domain Auf Ordner Zuweissen Problem

Postby Sawyer2111 » 22. February 2011 15:52

ich glaube es hat sich gelegt das problem ich habe zwar nixs gemacht aber igen wie geht das jetzt ..... trosdem grossen danke an dir nobbie =)
Sawyer2111
 
Posts: 4
Joined: 21. February 2011 23:50


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 8 guests