Virtualhosts Firefox 503 Service Unavailable

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Virtualhosts Firefox 503 Service Unavailable

Postby gardeler » 17. February 2011 15:23

Hallo,

ich habe ein komisches Problem mit meiner Xampp-Installation.
Ich habe versucht mir ein Virtual Host (Ich nenn ihn mal vhost_test) einzurichten, aber der Firefox (und nur dieser!) kann auf diesen vhost (vhost_test) nicht zugreifen. Ich bekomme immer ein 503 Service Unavailable. In anderen Browsern (IE 32/64bit, Safari, Opera, Chrome) funktioniert das ohne Probleme. localhost und 127.0.0.1 funktioniert auch im Firefox ohne Probleme.
Ich habe schon versucht Firefox und xampp neu zu installieren. Hat aber nichts geholfen.

Erstmal meine Umgebung:
Rechner:Windows 7 Pro 64 Bit
XAMPP für Windows 1.7.3 in Standardinstallation unter c:/xampp
Firefox 3.6.13 in Standardinstallation ohne Addons

Und hier die Virtualhosts-Konfiguration:
hosts-Datei Einträge (C:\Windows\System32\drivers\etc\hosts) (das sind die einzigen Einträge):
Code: Select all
127.0.0.1      localhost
127.0.0.1      vhost_test


httpd-vhosts.conf Einträge (C:\xampp\apache\conf\extra\httpd-vhosts.conf)
Code: Select all
NameVirtualHost 127.0.0.1

<VirtualHost 127.0.0.1>
    ServerName localhost
    AddType text/html .shtml
    AddHandler server-parsed .shtml
    ServerAdmin webmaster@localhost
    DocumentRoot "c:/xampp/htdocs"
    ScriptAlias /cgi-bin/ "c:/xampp/cgi-bin/"

    <Directory "c:/xampp/htdocs">
    Options Indexes FollowSymLinks
    Options +Includes
#   Options +
    AllowOverride FileInfo
    AllowOverride None
    Order allow,deny
    Allow from all
    DirectoryIndex index.php index.shtml index.html index.htm
    </Directory>
</VirtualHost>

<VirtualHost 127.0.0.1>
    ServerName vhost_test
    AddType text/html .shtml
    AddHandler server-parsed .shtml
    ServerAdmin webmaster@vhost_test
    DocumentRoot "c:/xampp/htdocs/vhosts/vhost_test"
    ScriptAlias /cgi-bin/ "c:/xampp/htdocs/vhosts/cgi-bin/"

    <Directory "c:/xampp/htdocs/vhosts/vhost_test">
    Options Indexes FollowSymLinks
    Options +Includes
#   Options +
    AllowOverride FileInfo
    AllowOverride None
    Order allow,deny
    Allow from all
    DirectoryIndex index.php index.shtml index.html index.htm
    </Directory>
</VirtualHost>


Die Konfiguration vom vhost habe ich von http://dev.weblication.de/wDev/knowledgebase/articles/20060215_artikel_xampp_virtualhosts.php. Ich habe aber auch schon diverse andere Konfigurationen versucht. Hat aber alles nichts geholfen.

Hab im Netz schon etliche Foren gewälzt, aber nichts gefunden. Hat zufällig jemand einen Idee?

Grüße
gardeler
 
Posts: 7
Joined: 17. February 2011 14:56

Re: Virtualhosts Firefox 503 Service Unavailable

Postby Nobbie » 17. February 2011 15:32

Versuche mal einen Hostnamen unter Unterstrich darin (also beispielsweise vhosttest statt vhost_test).
Nobbie
 
Posts: 8772
Joined: 09. March 2008 13:04

Re: Virtualhosts Firefox 503 Service Unavailable

Postby gardeler » 17. February 2011 15:37

der vhost_test ist nur ein Beispiel. Der Originale vhost ist ohne Unterstrich. Und das geht leider auch nicht.
gardeler
 
Posts: 7
Joined: 17. February 2011 14:56

Re: Virtualhosts Firefox 503 Service Unavailable

Postby WilliL » 17. February 2011 21:35

klappt denn 127.0.0.1:80 ?
Willi
WilliL
 
Posts: 661
Joined: 08. January 2010 10:54
Operating System: Win7Home Prem 64 SP1

Re: Virtualhosts Firefox 503 Service Unavailable

Postby gardeler » 17. February 2011 21:41

auf 127.0.0.1 ist ja localhost drauf. Das sollte genau so funktionieren. Kann ich jetzt leider nicht testen, da ich nicht an dem Rechner sitze...
Aber ich gehe mal davona aus, dass die IP auf localhost zeigt.
gardeler
 
Posts: 7
Joined: 17. February 2011 14:56

Re: Virtualhosts Firefox 503 Service Unavailable

Postby WilliL » 17. February 2011 21:43

sorry, ich meinte:

NameVirtualHost 127.0.0.1:80
und
<VirtualHost 127.0.0.1:80>
Willi
WilliL
 
Posts: 661
Joined: 08. January 2010 10:54
Operating System: Win7Home Prem 64 SP1

Re: Virtualhosts Firefox 503 Service Unavailable

Postby gardeler » 17. February 2011 21:50

oh, das kann ich jetzt leider nicht sagen. Werds morgen früh mal ausprobieren.
Aber wie am Anfang schon beschrieben, hab ich ja schon recht viele Konfigurationen ausprobiert. Denke sowas war auch dabei. Aber ich werds testen.
Bin aber schon fast eher der Meinung das muss irgendwas Firefox- oder Rechner-spezifisches sein. So ein Problem hatte ich noch nie. Das macht auch alles überhaupt keinen Sinn, weils ja nur im Firefox ist...
Vielleicht installiere ich auch mal ne ältere oder neuere Beta-Version vom Firefox. Vielleicht bringt das ja was.
gardeler
 
Posts: 7
Joined: 17. February 2011 14:56

Re: Virtualhosts Firefox 503 Service Unavailable

Postby gardeler » 18. February 2011 09:45

Hi,

ich hab das mit 127.0.0.1:80 und <VirtualHost 127.0.0.1:80> jetzt mal ausprobiert. Hat leider auch nichts gebracht. Nur diese Fehlermeldung:

503 Service Unavailable
Failed to resolve the name of server phpbb to connect

Das Firefox-Plugin Live HTTP Headers liefert mir das hier zurück:
Code: Select all
http://phpbb/

GET / HTTP/1.1
Host: phpbb
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 6.1; de; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13
Accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
Accept-Language: de-de,de;q=0.8,en-us;q=0.5,en;q=0.3
Accept-Encoding: gzip,deflate
Accept-Charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7
Keep-Alive: 115
Proxy-Connection: keep-alive
Cache-Control: max-age=0

HTTP/1.1 503 Service Unavailable
Proxy-Agent: IWSS
Content-Type: text/html; charset=UTF-8
Cache-Control: no-cache
Date: Fri, 18 Feb 2011 08:38:17 GMT

Das ist ja eigentlich nichts anderes als die Meldung da oben...
Im access.log wird auch kein Zugriff gespeichert.
Vom Internet Explorer wiederum bekomme ich diese Einträge im access.log, wenn ich darauf zugreife:
Code: Select all
127.0.0.1 - - [18/Feb/2011:09:37:29 +0100] "GET / HTTP/1.1" 200 640 "-" "Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.1; WOW64; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; MANM)"
127.0.0.1 - - [18/Feb/2011:09:37:29 +0100] "GET /icons/blank.gif HTTP/1.1" 200 148 "http://phpbb/" "Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.1; WOW64; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; MANM)"
127.0.0.1 - - [18/Feb/2011:09:37:29 +0100] "GET /favicon.ico HTTP/1.1" 404 1172 "-" "Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; WOW64; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; MANM)"


In phpbb ist übrigens noch nichts drin, deswegen sind das nur so wenige...
gardeler
 
Posts: 7
Joined: 17. February 2011 14:56

Re: Virtualhosts Firefox 503 Service Unavailable

Postby Nobbie » 18. February 2011 12:05

Das liegt nicht an Apache, sondern das vermutlich ein Problem der Hosts Datei. Der Name phpbb wird nicht aufgelöst in Firefox.

a) welches Windows ist installiert?
b) mit welchem Editor wurde die hosts Datei bearbeitet?
c) in welchem Verzeichnis wurde die hosts Datei gefunden? Oder wurde sie neu angelegt?
d) welche Versionen der Browser sind installiert? 32bit / 64bit?
Nobbie
 
Posts: 8772
Joined: 09. March 2008 13:04

Re: Virtualhosts Firefox 503 Service Unavailable

Postby gardeler » 18. February 2011 12:29

a) Windows 7 Professional 64 Bit

b) meistens mit dem Editor von Windows. Manchmal auch mit ActiveState Komodo

c) Die hosts-Datei liegt hier: C:\Windows\System32\drivers\etc\hosts
Ich habe, um die Datei zu editieren, diese auf den Desktop verschoben. Dann editiert und anschließend wieder ins Ursprungsverzeichnis zurück verschoben.

d) http://phpbb/ habe ich getestet mit
Firefox Version 3.6.13 (aktuellste Version) -> 503 Service Unavailable
Firefox Version 3.6.13 im abgesicherten Modus komplett ohne Plugins/Addons/etc -> 503 Service Unavailable
Firefox Version 4 Beta 11 -> 503 Service Unavailable
Opera, Chrome, IE 32 Bit, IE 64 Bit -> funktioniert

Ich glaube von Firefox gibt es kein 64 Bit Version. Hab auf jeden Fall explizit keine gefunden.

Eigentlich kann es nur Windows oder Firefox sein. Glaube kaum das Xampp da irgendwo Problem macht.
gardeler
 
Posts: 7
Joined: 17. February 2011 14:56


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 16 guests