erste schritte

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

erste schritte

Postby Ramin » 07. February 2011 17:36

Hallo zusammen,

ich habe gerade XAMPP 1.7.4 auf meinem system installiert (wiin 7, 64bit) und habe ein paar anfängliche fragen.

Bei den vorraussetzungen steht das 32bit verlangt wird. einiges funktioniert trotzdem, aber habe ich wirklich einschränkungen wegen 64bit?

tomcat wird scheinbar nicht mit XAMPP(oder apache) mitgestartet. erst wenn ich catalina_start.bat aus dem tomcat verzeichnis starte und offen lasse, kann ich tomcat beispiele sehen

http://localhost führt nicht auf die "it works!" seite sondern zu http://127.0.0.1/xampp/ (ist das richtig so?)

php funktioniert gar nicht.



gibt es tutorials, wie ich die eigene seite, mit servlets und co einrichten kann?

viele grüße,
ramin
Ramin
 
Posts: 4
Joined: 07. February 2011 17:23

Re: erste schritte

Postby Ramin » 07. February 2011 18:24

die index.php zwugt nix an, und auch eine selbst geschriebene hello wrold führt zu nix
Ramin
 
Posts: 4
Joined: 07. February 2011 17:23

Re: erste schritte

Postby steini » 07. February 2011 20:25

Stichwort "open_tags" in der php.ini oder du lernst es gleich anders ;)
V-Server ab 7,90€ bei simplyroot
---
Image
User avatar
steini
 
Posts: 191
Joined: 24. October 2003 00:24
Location: Helmstedt
Operating System: Windows 10 Tech Preview

Re: erste schritte

Postby Nobbie » 07. February 2011 21:53

Ramin wrote:die index.php zwugt nix an, und auch eine selbst geschriebene hello wrold führt zu nix


Wenn Du vo siele Felher auch im Srpit hast, wunrdet mcih nithcs
Nobbie
 
Posts: 8758
Joined: 09. March 2008 13:04

Re: erste schritte

Postby Ramin » 08. February 2011 09:48

hallo,

in der php.ini habe ich nur short_open_tag gefunden. das steht auf on.

in der index.php steht:

<!DOCTYPE html PUBLIC "WC//W3C//DTD XHTML 1.0 Transitional//EN"
"http://www.w3.org./TR/xhtml1/DTD/xhtml1-transitional.dtd">

<?php
if (!empty($_SERVER['HTTPS']) && ('on' == $_SERVER['HTTPS'])) {
$uri = 'https://';
} else {
$uri = 'http://';
}
$uri .= $_SERVER['HTTP_HOST'];
header('Location: '.$uri.'/xampp/');
exit;
?>
Something is wrong with the XAMPP installation :-(
und "Something is wrong with the XAMPP installation :-(" ist auch was ich sehe
Ramin
 
Posts: 4
Joined: 07. February 2011 17:23

Re: erste schritte

Postby Ramin » 08. February 2011 09:53

wie kann ich denn umstellen, das man nicht direkt zur lokalen xampp seite geleitet wird?
Ramin
 
Posts: 4
Joined: 07. February 2011 17:23

Re: erste schritte

Postby Nobbie » 08. February 2011 11:17

a) entweder die index.php durch eine eigene index.php ersetzen
b) oder den DocumenRoot in httpd.conf anders deklarieren
c) oder mit VirtualHosts verschiedene Domainnamen anlegen mit verschiedenen DocumentRoot
Nobbie
 
Posts: 8758
Joined: 09. March 2008 13:04


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 5 guests