Perl unter XAMPP

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Re: Perl unter XAMPP

Postby Nobbie » 03. February 2011 17:20

Altrea wrote:
Nobbie wrote:Wenn Du aus mir nicht bekannten Gründen unbedingt auf die neue Version 1.7.4 angewiesen bist, würde ich Dir empfehlen, eine ältere Version zu installieren.

Der Satz macht so irgendwie keinen Sinn. Fehlt da vielleicht eine Verneinung? :shock:


Stimmt auffallend - fehlt das "nicht" nach "Wenn Du ...". :roll:
Nobbie
 
Posts: 8770
Joined: 09. March 2008 13:04

Re: Perl unter XAMPP

Postby Dirk1 » 03. February 2011 18:04

Hallo,
ich habe jetzt meinen VHost soweit, dass ich dort HTML und Perl aufrufen kann.
Allerdings kommt jetzt die Fehlermeldung
Variable "$i" will not stay shared at D:/test1/cgi-bin/kontakt.pl line 320
In der Internet-Version kommt dies nicht.
Habe da mal etwas von mod_perl gelesen.
1. Kann dies an der Perl-Version liegen?
2. Gibt es eine kurze, verständliche Beschreibung zum Unterschied zwischen mod_perl und anderen Perls?
3. Welches Perl ist standardmäßig in xampp integriert?


wole wrote:
Dirk1 wrote:Welches Perl ist standardmäßig in xampp integriert?

Wer Lesen kann ist klar im Vorteil!!!
Das steht als 1. Antwort auf deine Threaderöffnung 8)

Dort steht ja nur Perl und eine Version. Ist demnach Perl das Gegenstück zu mod_perl? Gerade habe ich noch etwas von Perl CGI gelesen - noch eine Variante?
Dann bleiben aber noch meine beiden anderen Fragen.
Last edited by Dirk1 on 03. February 2011 18:55, edited 2 times in total.
Dirk1
 
Posts: 22
Joined: 22. December 2010 09:50

Re: Perl unter XAMPP mod-perl deaktivieren

Postby Dirk1 » 06. February 2011 18:05

Hallo,
wie kann ich das offensichtlich aktive mod-perl deaktivieren, damit ich über cgi-Schnittstelle testen kann.
(Vermutlich ist die Formulierung nicht fachmännisch, hoffentlich trotzdem verständlich?)
Dirk1
 
Posts: 22
Joined: 22. December 2010 09:50

Re: Perl unter XAMPP mod-perl deaktivieren

Postby Nobbie » 06. February 2011 18:56

Dirk1 wrote:Hallo,
wie kann ich das offensichtlich aktive mod-perl deaktivieren, damit ich über cgi-Schnittstelle testen kann.


mod_perl ist nicht aktiv (sowieso nicht offensichtlich, wieso meinst Du das?), Du testet über die cgi-Schnittstelle.
Nobbie
 
Posts: 8770
Joined: 09. March 2008 13:04

Re: Perl unter XAMPP

Postby Dirk1 » 06. February 2011 20:31

Eingestellt ist der Environment-Parameter
MOD_PERL="mod_perl/2.0.4".
Ich möchte aber nicht mod_perl sondern Perl allein (wie immer man das nennen mag).
Dirk1
 
Posts: 22
Joined: 22. December 2010 09:50

Re: Perl unter XAMPP

Postby Dirk1 » 08. February 2011 15:20

Hallo,
habe jetzt bei einem Freund nachgeschaut, der hat eine ältere Version von XAMPP.
Und bei ihm läuft mein Programm.
Dort hat er in httpd.conf das Statement "ScriptInterpreterSource Registry aktiviert.
Dieses Statement gibt es in dem httpd.conf des neuen XAMPP gar nicht.
Kann das Problem daran liegen?
Er selbst weiß nicht mehr, was er alles angepasst hat.
Ich hatte angedacht, einfach die Dateien bei ihm mit meinen zu vergleichen, aber die sehen total unterschiedlich aus, so dass man nich feststellen kann, ob es Änderungen in Xampp sind oder Änderungen durch ihn.
Dirk1
 
Posts: 22
Joined: 22. December 2010 09:50

Re: Perl unter XAMPP - Neuer Anlauf

Postby Dirk1 » 08. February 2011 18:14

Hallo,
ich habe jetzt xampp noch einmal neu installiert, da ich dachte durch das viele Herumprobieren hätte ich es zerschossen.
Aber auch jetzt kommen beim Aufruf eines Perl-Programms aus einer HTML-Datei die Fehler
Variable "$..." will not stay shared at D:/neu/test/cgi-bin/test.pl line 8


Da hier immer von mod_perl die Rede war, vermute ich, dass es an einer der beiden Dateien httpd-perl.conf und startup.pl liegen muss.
Vielleicht kann mir jemand einen Tipp geben, was ich ändern muss. Ich zeige deshalb die Dateiinhalte (ohne die Kommentarzeilen am Anfang) hier an.
(Meine Perl-Programme haben das Suffix pl und liegen in d:/neu/test/cgi-bin)
httpd-perl.conf
Code: Select all
LoadFile "/xampp/perl/bin/perl510.dll"
LoadModule perl_module modules/mod_perl.so
PerlPostConfigRequire "/xampp/apache/conf/extra/startup.pl"

<IfModule mime_module>
    AddType text/html .pl
</IfModule>

<FilesMatch "\.pl$">
    SetHandler perl-script
    PerlResponseHandler ModPerl::Registry
    PerlOptions +ParseHeaders
</FilesMatch>

<Directory "/xampp/cgi-bin">
    <FilesMatch "\.pl$">
        SetHandler cgi-script
    </FilesMatch>
</Directory>

# ASP settings
Include "conf/extra/httpd-perl-asp.conf"


startup.pl
Code: Select all
use ModPerl::Util ();
use Apache2::RequestRec ();
use Apache2::RequestIO ();
use Apache2::RequestUtil ();
use Apache2::ServerRec ();
use Apache2::ServerUtil ();
use Apache2::Connection ();
use Apache2::Log ();
use Apache2::Const -compile => ':common';
use APR::Const -compile => ':common';
use APR::Table ();
use Apache2::compat ();
use ModPerl::Registry ();
use CGI ();
use Apache::ASP ();
1;

In beiden Dateien habe ich versuchsweise Registry ersetzt durch PerlRun, aber ohne Erfolg.
Ich hoffe Ihr könnt mir weiterhelfen!
Schönen Abend
Dirk1
 
Posts: 22
Joined: 22. December 2010 09:50

Previous

Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 17 guests