Verzeichnisschutz funktioniert nicht

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Verzeichnisschutz funktioniert nicht

Postby HeckMc » 24. January 2011 09:56

Hallo zusammen,

ich nutze den Apache unter W2k3 und möchte ein Verzeichnis schützen. Dazu habe ich in der .conf folgendes eingetragen:

AllowOverride All - ich nehme mal an das gilt nicht nur fürs Document Root sondern auch für Unterordner

Meine .htaccess sieht so aus:
AuthUserFile c:\passwords
AuthName "Preview"
AuthType Basic
AuthBasicProvider file
require user heckmc

und die Dati passwords liegt im C: Root und sieht so aus:
heckmc:$apr1$yea1qUEt$noiJwABggPDTWH.fIo.sc0

Das PW habe ich mit htpasswd aus dem apache bin Verzeichnis generiert. Es spielt aber keine Rolle ob es verschlüsselt ist oder im Klartext vorliegt.
Ich bekomme beim Aufruf der Seite das Anmeldefenster angezeigt, aber egal was ich mache, er lehnt die Authentifizierung immer ab.

Habt ihr eine Idee was falsch ist? Ich habe bereits etliche PW-Generatoren versucht, ebenfalls Klartext, nichts funktioniert.

Dank und Grüße
HeckMc
HeckMc
 
Posts: 2
Joined: 24. January 2011 09:50

Re: Verzeichnisschutz funktioniert nicht

Postby WilliL » 24. January 2011 21:16

versuch mal die require-Zeile:
require valid-user
Willi
WilliL
 
Posts: 661
Joined: 08. January 2010 10:54
Operating System: Win7Home Prem 64 SP1

Re: Verzeichnisschutz funktioniert nicht

Postby HeckMc » 25. January 2011 13:59

Hi,

auch mit require valid-user habe ich genau das gleiche Problem. :(

Ist der Pfad zur passwords Datei denn richtig angegeben wenn diese im Root von Laufwerk C liegt?

Kann ich irgendwo in einem Logfile feststellen, warum die Authentifizierung scheitert?

VG
HeckMc
 
Posts: 2
Joined: 24. January 2011 09:50

Re: Verzeichnisschutz funktioniert nicht

Postby Altrea » 25. January 2011 15:45

heißt die Datei denn auch einfach passwords, ohne Dateiendung?
oder vielleicht .passwords?
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8298
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Verzeichnisschutz funktioniert nicht

Postby Nobbie » 25. January 2011 16:38

HeckMc wrote:Kann ich irgendwo in einem Logfile feststellen, warum die Authentifizierung scheitert?


Im Error_Log sollte etwas zu finden sein.
Nobbie
 
Posts: 8779
Joined: 09. March 2008 13:04


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 6 guests