Kodierung der Konfig: Apache vs. PHP

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Kodierung der Konfig: Apache vs. PHP

Postby Rabenschwinge » 20. January 2011 14:33

Hallo. Ich bin neu bei XAMPP und versuche gerade einen IP-basierten virtual Host einzurichten, der einfach auf meinen Eclipse-Workspace zielt. Leider benötigen Apache selbst und das PHP Modul aber anscheinend unterschiedliche kodierungen für Pfadnamen:

Wenn ich die Datei als ANSI speichere weigert sich Apache zu starten, mit dem Hinweis, dass der Pfad, den ich als DocumentRoot angegeben habe, nicht existiert. Wenn ich die Datei als UTF-8 speichere und liefert die Datei mit Code 200 aus, von PHP bekomme ich aber die Fehlermeldung, dass der Pfad nicht geöffnet werden kann, wobei ein "ö" im Pfad als "ö" dargestellt wird. Ein deutlicher Hinweis darauf, dass UTF-8 als ANSI, ISO-8859-1 oder dergleichen interpretiert wird:

Code: Select all
Fatal error: Unknown: Failed opening required 'C:/Users/Björn/Documents/workspace/dev/index.php' (include_path='.;C:\xampp\xampp\php\PEAR') in Unknown on line 0


Der "combined" Log-Eintrag dazu:
Code: Select all
127.0.0.1 - - [20/Jan/2011:14:26:02 +0100] "GET / HTTP/1.1" 200 320 "-" "Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; Win64; x64; Trident/4.0; .NET CLR 2.0.50727; SLCC2; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; .NET4.0C)"


Die Apache Prozesse werden von mir selbst ausgeführt und ich werde auch als Benutzer von "httpd.exe" in der Prozessliste aufgeführt, d.h. an den Zugriffsrechten kann es nicht liegen.

Gibt's irgendeine Möglichkeit den Apache zu überreden seine Konfiguration ANSI zu interpretieren oder PHP dazu zu kriegen die vom Apache übergebenen Parameter als UTF-8 zu interpretieren?
Rabenschwinge
 
Posts: 1
Joined: 20. January 2011 14:12

Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 7 guests