umstellen von php5 auf php4

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

umstellen von php5 auf php4

Postby michimax » 14. January 2011 11:08

Ich möchte mein Xampp temporär auf php4 umstellen.
Hallo ich habe Probleme beim umstellen, ich dachte es gibt irgendwo so eine Art Switch, doch ich kann ihn nicht finden.
Vieleicht kann mir hier jemand weiterhelfen.

Für eine Hilfe wäre ich sehr dankbar

Michi
michimax
 
Posts: 3
Joined: 14. January 2011 11:05

Re: umstellen von php5 auf php4

Postby Altrea » 14. January 2011 11:54

Diesen Switch gibt es seit XAMPP 1.7.0 nichtmehr.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8286
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: umstellen von php5 auf php4

Postby michimax » 14. January 2011 12:55

Kann man das sonst irgendwie machen????
michimax
 
Posts: 3
Joined: 14. January 2011 11:05

Re: umstellen von php5 auf php4

Postby Nobbie » 14. January 2011 14:24

"Irgendwie" kann man das sicherlich machen, aber es empfiehlt sich nicht, Xampp als Grundlage zu nehmen.

Es dürfte weniger fehlerträchtig sein, Apache, PHP (dann in der Version 4.x) und MySQL einzeln zu installieren und anzupassen, als Xampp zu verbiegen.
Nobbie
 
Posts: 8762
Joined: 09. March 2008 13:04

Re: umstellen von php5 auf php4

Postby Pitze » 14. January 2011 17:40

Warum auf eine ältere PHP-Version umsteigen das macht schon wegen der Sicherheit keinen Sinn dann noch die entsprechenden alten Scripte. Wenn man sich das vorstellt schon der reinste Horror nicht zu empfehlen.
Besser ist es Updates der verwendeten Scripte zu benutzen, wenn es keine gibt nach Allternatieven umsehen und sollten es eigene sein eben diese entsprechend anpassen.
Der grösste Vertrauensbruch ist der Blitzableiter auf der Kirchturmspitze
User avatar
Pitze
 
Posts: 210
Joined: 20. November 2003 21:38
Location: Huskvarna-Schweden
Operating System: Windows Vista

Re: umstellen von php5 auf php4

Postby Altrea » 14. January 2011 19:49

Er schrieb etwas von "temporär".
Vielleicht ist das ja seine Art seine Scripte Schritt für Schritt auf einen aktuellen Stand zu bringen.
Oder er möchte seine Scripte auf Kompabilität zu PHP4 testen (aus welchen Gründen auch immer).
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8286
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: umstellen von php5 auf php4

Postby Nobbie » 14. January 2011 21:55

Pitze wrote:Besser ist es Updates der verwendeten Scripte zu benutzen, wenn es keine gibt nach Allternatieven umsehen und sollten es eigene sein eben diese entsprechend anpassen.


Das sagt sich so leicht - es kann nicht jeder einfach mal so PHP programmieren und veraltete Scripts anpassen. Solche Tipps finde ich nicht sonderlich hilfreich.
Nobbie
 
Posts: 8762
Joined: 09. March 2008 13:04

Re: umstellen von php5 auf php4

Postby Luiking » 12. August 2011 08:10

Ich habe das selbige Problem!

Es gibt da einen Chat, der sozusagen PHP 4 benötigt bei höher streikt!

Ich habe folgendes gefunden!
Jedoch habe ich keine Möglichkeit gefunden, wieder auf php 4 umzusteigen!
Oder gibt es ne Möglichkeit für jede Datenbank ein eigenes PHP Paket zu benutzen!?
Image
Luiking
 
Posts: 3
Joined: 12. August 2011 07:57

Re: umstellen von php5 auf php4

Postby Luiking » 12. August 2011 08:24

Nu hab ich das gefunden!

Wie kriege ich das jetzt vereint!?
max. 5.2 PHP darf ich haben! Mist


X7 Chat Joins Go PHP 5

Go PHP 5 is a group of PHP projects that all plan to cease support of PHP verions older than version 5.2 by February 5, 2008. This initiative is backed by major projects such as PhpMyAdmin, Drupal, and PEAR. The X7 Chat project will be joining this group of developers in their quest for PHP 5 adoption. Starting with X7 Chat 3.0.0 Alpha 2, the X7 Chat project will be dropping support for PHP versions older than 5.2 in all future X7 Chat releases.

PHP Chatrooms require extremely efficient code to avoid overloading the web server. By adopting PHP 5 we will be able to write much more efficient software. The new features introduced in PHP 5.2 will allow X7 Chat 3 to support a much greater number of features and simultaneous users than any previous version.

The PHP Group has officially announced that as of 2008-08-08 they will completely stop supporting PHP 4. After this date even critical security patches will not be released and running PHP 4 will be detrimental to your website's security. The X7 Chat project is completely behind the PHP Group on this decision, we feel that is far past time that PHP 5 be fully adopted.

Please note that X7 Chat Versions 1 and Versions 2 will still work on PHP 4 and Version 2 will still be supported on PHP 4 until support for Version 2 ends.
Luiking
 
Posts: 3
Joined: 12. August 2011 07:57

Re: umstellen von php5 auf php4

Postby Altrea » 12. August 2011 09:24

Luiking wrote:max. 5.2 PHP darf ich haben! Mist

PHP 5.2 ist mittlerweile ebenfalls out of Support. => http://www.php.net/archive/2011.php#id2011-03-17-1
All PHP users should note that the PHP 5.2 series is NOT supported anymore. All users are strongly encouraged to upgrade to PHP 5.3.6.


Solch ein System produktiv einzusetzen würde ich mir also überlegen, denn die Arbeit die du jetzt da rein steckst, das Script auf PHP 5.2 zum Laufen zu bekommen wirst du früher oder später nochmals haben um es auf PHP 5.3+ zu portieren.

Als lokale Testumgebung könntest du XAMPP 1.7.1 einsetzen. Die kommt noch mit PHP 5.2.9 daher.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8286
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 4 guests