xampp 1.7.2 - MySQL bricht start ab

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

xampp 1.7.2 - MySQL bricht start ab

Postby schwubbe » 02. January 2011 00:41

Moin moin

Ich wünsche euch ein frohes neues Jahr allerseits :)

Da ich mir die Mediawiki genauer anschauen und herausfinden möchte wo ich was wie anpassen könnte habe ich mir vorhin xampp 1.7.2 heruntergeladen, denn Mediawiki weigert sich ja konsequent mit PHP 5.3.1 zu arbeiten :roll:
Jetzt habe ich von xampp folgende Versionen an nebenstehenden Orten:
  • 1.7.3 zip Laptop
  • 1.7.3 zip externe Festplatte
  • 1.7.2 zip externe Festplatte

Nun habe ich aber leider ein Problem:
Wenn ich über xampp-control.exe den Apache starte läuft er, starte ich jedoch MySQL, so wird selbiges nach 4-5 Sekunden abgebrochen; teilweise zeigt er mir im Log auch "WARNING: terminating worker thread 1" an.
Als Service kann ich MySQL gar nicht einrichten, da es - sobald ich die Checkbox dafür anklicke - sofort abgebrochen wird.

[edit]

Ich habe gerade durch einen anderen thread hier im Forum die MySQL-Error-Datei gefunden, in meiner wiederholt sich folgende Passage:
110102 0:37:18 [Note] Plugin 'FEDERATED' is disabled.
110102 00:37:18 [Note] PrimeBase XT (PBXT) Engine 1.0.08 RC loaded...
110102 00:37:18 [Note] Paul McCullagh, PrimeBase Technologies GmbH, http://www.primebase.org
110102 00:37:18 [Note] The server was not shutdown correctly, recovery required
110102 0:37:18 InnoDB: Operating system error number 87 in a file operation.
InnoDB: Some operating system error numbers are described at
InnoDB: http://dev.mysql.com/doc/refman/5.1/en/ ... codes.html
InnoDB: File name G:\xampp-wiki\xampp\mysql\data\ib_logfile0
InnoDB: File operation call: 'aio read'.
InnoDB: Cannot continue operation.

[/edit]

Fragen:
Kann es daran liegen, das ich verschiedene Versionen vorliegen habe, auch wenn die anderen nicht laufen?
Wenn nein: Woran könnte/wird es sonst liegen?
Wie kann ich es beheben?

Fragen über Fragen ... Ich hoffe Ihr könnt mir da helfen, denn davon habe ich leider nicht den blassesten Dunst :(

Liebe Grüße
schwubbe
schwubbe
 
Posts: 17
Joined: 29. October 2010 23:49
Location: Hamburg

Re: xampp 1.7.2 - MySQL bricht start ab

Postby WilliL » 02. January 2011 11:46

ich habe nur eine XAMPP-Version am laufen ..
hast du mal versucht, den Server über die Batch-Dateien zu starten?
Drive:\xampp\apache_start.bat und mysql_start.bat

Vorher eventuell laufende Dienste (svc - Haken) im Panel entfernen, bzw vorsichtshalber in den anderen Versionen die X-stop.bat aufrufen ..
(110102 00:37:18 [Note] The server was not shutdown correctly, recovery required)
Willi
WilliL
 
Posts: 661
Joined: 08. January 2010 10:54
Operating System: Win7Home Prem 64 SP1

Re: xampp 1.7.2 - MySQL bricht start ab

Postby schwubbe » 02. January 2011 16:53

WilliL wrote:ich habe nur eine XAMPP-Version am laufen ..
hast du mal versucht, den Server über die Batch-Dateien zu starten?
Drive:\xampp\apache_start.bat und mysql_start.bat

Vorher eventuell laufende Dienste (svc - Haken) im Panel entfernen, bzw vorsichtshalber in den anderen Versionen die X-stop.bat aufrufen ..
(110102 00:37:18 [Note] The server was not shutdown correctly, recovery required)


Hatte ich ausgeschloßen, da ich zwischendurch 2-3 mal einen neustart machte.
Habs dennoch eben ausprobiert, Resultat:
xampp_stop.exe lief ne Sekunde und war fertig.
mysql_stop.bat zeigt folgenden Text in der DOS-Box:
Can't find process "G:\xampp-wiki\mysql\bin\mysqld.exe
Und ja, die Datei existiert nicht, lediglich eine mysql.exe ist vorhanden.
Bei Ausführen der Datei mysql_start.bat kommt folgender Text in der DOS-Box:
No we start MySQL
Starting "mysql"...

dann ein paar Sekunden nichts und anschließend:
"mysql" is not started.
Keine weitere Fehlermeldung.

Also wenn keiner eine bessere Idee hat werde ich nachher wenn ich mehr Zeit habe xampp 1.7.2 einfach neu entpacken, aufdaß das Verzeichnis xamppp\mysql\ dann vollsändiger ist. :cry:
schwubbe
 
Posts: 17
Joined: 29. October 2010 23:49
Location: Hamburg

Re: xampp 1.7.2 - MySQL bricht start ab

Postby schwubbe » 02. January 2011 20:43

aaaalssoooo

Ich habe jetzt xampp 1.7.2 fachgerecht via uninstall.bat runtergeschmissen, neu entpackt und auf Vorhandensein der Datei mysqld.exe gecheckt.

MySQL wird dennoch nach wenigen Sekunden abgebrochen.

Inhalt der mysql.err:
110102 20:13:08 [Note] Plugin 'FEDERATED' is disabled.
110102 20:13:09 [Note] PrimeBase XT (PBXT) Engine 1.0.08 RC loaded...
110102 20:13:09 [Note] Paul McCullagh, PrimeBase Technologies GmbH, http://www.primebase.org
110102 20:13:12 InnoDB: Operating system error number 87 in a file operation.
InnoDB: Some operating system error numbers are described at
InnoDB: http://dev.mysql.com/doc/refman/5.1/en/ ... codes.html
InnoDB: File name G:\xampp-wiki\xampp\mysql\data\ib_logfile0
InnoDB: File operation call: 'aio read'.
InnoDB: Cannot continue operation.


Laut des Fehlercodes 87 ist irgend ein Parameter falsch, was mir persönlich mal so rein gar nichts sagt.

ABER ich vermute etwas: Es liegt daran, das ich wie folgt die Verzeichnisse angelegt habe:
D:\xampp
externe Festplatte:\xampp\
externe Festplatte:\xampp-wiki\xampp\

Als ich eben mal den thread von CheckThat überflog erinnerte ich mich daran, das man ja durchaus darauf hingewiesen wurde das man xampp direkt ins root-Verzeichnis packen soll, und nicht in Unterordner :|

Ich werds daher nomma probieren, wenn ich xampp 1.7.2 ins root ghepackt hab.
Sollte es dann immernoch nicht laufen, dann meldsch mich nochmal.

LG
schwubbe
schwubbe
 
Posts: 17
Joined: 29. October 2010 23:49
Location: Hamburg

Re: xampp 1.7.2 - MySQL bricht start ab

Postby Altrea » 02. January 2011 20:50

Hallo schwubbe,

schwubbe wrote:Als ich eben mal den thread von CheckThat überflog erinnerte ich mich daran, das man ja durchaus darauf hingewiesen wurde das man xampp direkt ins root-Verzeichnis packen soll, und nicht in Unterordner :|


Das ist richtig. Im Grunde sollte eine Installation aber auch in einem Unterordner funktionieren, sofern dieser keine Leerzeichen oder Sonderzeichen enthält. Also zumindest die Installation im Ordner C:\xampp\ sollte ebenfalls problemlos funktionieren. Bei Minus-Zeichen weiß ich es nicht.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8293
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: xampp 1.7.2 - MySQL bricht start ab

Postby schwubbe » 02. January 2011 23:10

wuäähhhh :cry:

Ich habe jetzt (mal wieder) xampp 1.7.2 deinstalliert, habe es danach im root-Ordner (G:\xampp\) entpackt, Setup laufen lassen aber nix, keine Änderung.
Dann versuchte ich erneut locker 20 Minuten xampp unter dieser URL in der zip-Version 1.7.2 herunter zu laden, aber nüscht.
Danach habe ich versucht die 1.7.4 Beta laufen zu kriegen, aber selbes Problem. Jetzt läuft nicht einmal mehr die Version 1.7.3, welche vorher tadellos lief und NIE Probleme machte. Auch hierzu mal ein Auszug aus dem Error-Log:
110102 22:42:02 [Note] Plugin 'FEDERATED' is disabled.
110102 22:42:02 InnoDB: Operating system error number 87 in a file operation.
InnoDB: Some operating system error numbers are described at
InnoDB: http://dev.mysql.com/doc/refman/5.1/en/ ... codes.html
InnoDB: File name G:\xampp\mysql\data\ib_logfile0
InnoDB: File operation call: 'aio read'.
InnoDB: Cannot continue operation.


Und joa, ich habe (seit es mir in besagtem thread wieder auffiel) grundsätzlich darauf geachtet das jeweilige xampp-Archiv im Root-Ordner der externen Festplatte zu entpacken. Ich habe jedes mal (außer bei der Beta 1.7.4) darauf geachtet das die Setup-Datei die Pfade neu erkennt, nie die "drive-letters" anlegen lassen (xampp liegt ja auf ner externen) und ich habe auch noch nie die Funktion Service genutzt.

Ich weiß das ich irgend etwas falsch gemacht haben werde, nur ich habe nicht die geringste Ahnung wo ich was falsch machte.
Ich bin echt kurz vorm verzweifeln.
Eigentlich überlegte ich evtl meine HP oder Teile davon auf die MediaWiki umzustellen. Doch wenn ich schon derartige Probleme habe, wofür denn dann die Mühe wenn ich Gefahr laufe das ich die selben oder gar ganz neue Probleme auf dem Server bekomme.
Aber hey, selbst wenn ich davon Abstand nehme, ich kann ja derzeit auch keine anderen Projekte verfolgen, da ja nicht einmal mehr die sonst so stabile Version 1.7.3 läuft, MySQL quasi gänzlich streikt/blockiert wird.

Wenn da also jemand für mich Tipps, Tricks, Ideen oder sonst welche weiterführende Hilfen hätte, ich wäre sehr dankbar.
Vorerst danke ich WilliL und Altrea schon mal für die Ideen.

[edit]
Hab den Stick gerade eben auch noch mal an 'n Desktop-PC gekloppt (auf welchem mysql-3.23.38 Server and blablabla als Dienst eingerichtet (aber abgebrochen) ist), xampp relocated, MySQL via mysql_start.bat aber nichts, auch hier brach MySQL ab.
[/edit]

[edit2]
Beim Starten von MySQL per xampp-control.exe bleibt es am laufen grad. Klappte am LapTop jedoch nicht.
[/edit2]

LG
schwubbe
schwubbe
 
Posts: 17
Joined: 29. October 2010 23:49
Location: Hamburg

Re: xampp 1.7.2 - MySQL bricht start ab

Postby Altrea » 03. January 2011 23:56

Ich habe keine neuen Hinweise für dich, aber einen kleinen Tipp, da du dich ja öfters mal einloggst:

Wenn du einen Beitrag editierst, wird dieser nicht wieder als ungelesen markiert.
Hast du also etwas neues wo es wichtig ist, dass jemand der den Beitrag vorher schonmal gelesen hat, sich diesen nochmal anschauen soll, dann häng lieber einen weiteren post an statt einen älteren Beitrag zu editieren. :D
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8293
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: xampp 1.7.2 - MySQL bricht start ab

Postby schwubbe » 03. January 2011 23:58

Altrea wrote:Hast du also etwas neues wo es wichtig ist, dass jemand der den Beitrag vorher schonmal gelesen hat, sich diesen nochmal anschauen soll, dann häng lieber einen weiteren post an statt einen älteren Beitrag zu editieren. :D

ok, werde ich mir merken, wollte nur nicht wegen jeder Kleinigkeit "nerven", u.a. weil ich nicht davon ausgiung das die angefügten Infos entscheidend sein sollten. :lol:
schwubbe
 
Posts: 17
Joined: 29. October 2010 23:49
Location: Hamburg

Re: xampp 1.7.2 - MySQL bricht start ab

Postby schwubbe » 08. January 2011 14:55

Aufgrund der fortwährenden Probleme, den doch sehr zahlreichen Lösungsvorschlägen (war klar das ich mir wieder 'nen Exoten 'rauspicke), der Tatsache das mein XP auf dem Laptop bereits seit 2008 drauf ist und ein paar weiteren Winzigkeiten werd ich das Ding später mal radikal platt machen, nebst USB-Stick und externer Festplatte.
Zum Neustart wollte ich mir dann direkt xampp 1.7.2 draufdonnern, da ich die Idee mit der Wiki noch nicht gänzlich aufgegeben habe.
Jetzt hab ich aber das Problem, das ich die Version 1.7.2 bei Sourceforge.net konsequent nicht downloaden kann, weder die .exe, noch die .zip; ebenso bei der 1.7.2-lite.
Ich klicke auf den Link, er sagt mir das der Download in Kürze starten soll, aber nichts passiert.
Darunter meint die Site dann das ich bei Problemen den Direkt-link oder einen anderen Mirror testen soll, doch auch da wirds nix.

Kann mir irgendwer das Ding bitte via eMail zusenden?
Am liebsten wäre mir xampp-win32-1.7.2.zip.
[Edit]eMail-Addy gibt's gern via PN[/edit]

@ xampp-Team
Könnt ihr da bei Sourceforge mal nachhaken warum man min. seit Beginn des Jahres nicht auf diese Version zugreifen kann?


Besten Dank und liebe Grüße
Marcel
schwubbe
 
Posts: 17
Joined: 29. October 2010 23:49
Location: Hamburg

Re: xampp 1.7.2 - MySQL bricht start ab

Postby schwubbe » 09. January 2011 08:10

Habe mir gestern Abend die Mühe gemacht und den Laptop platt gemacht und neu aufgesetzt.
Auf der externen Festplatte bekomme ich MySQL noch immer nicht zum Laufen, egal wlche xampp Version.
Auf dem Laptop laufen jetzt sowohl 1.7.3 als auch die 1.7.4Beta, sofern ich die xampp_setup.exe NICHT laufen lasse.
Die 1.7.2 habe ich jetzt nicht wieder getestet.

Ich habe unter der 1.7.4Beta jetzt aber das ipv6-Problem (sollte euch ja was sagen). Im Browser zeigt xampp mir wie wohl von euch gewollt die zwei Wege auf denen man das Problem lösen kann, doch leider klappt nun genau das nicht bei mir -.-
In meiner Host-Datei (c:\windows\system32\drivers\etc\host) steht neben der auskommentierten Erklärung nur folgender Eintrag:
127.0.0.1 localhost

Wenn ich über cdm.exe vorgehen will, so kommt auf den Befehl "ipv6 uninstall" das der Dienst nicht installiert sei.
Befehle ich erst "ipv6 install" anschließend "ipv6 uninstall" und mache dann den Neustart ist danach alles wie zuvor :|
schwubbe
 
Posts: 17
Joined: 29. October 2010 23:49
Location: Hamburg


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 10 guests