Problem: Win7 Xampp und IE9 beta

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Problem: Win7 Xampp und IE9 beta

Postby JuK » 29. December 2010 19:19

Hallo,

ich habe hier schon den ganzen Tag gelesen, aber noch keine Lösung für mein Problem gefunden.
Als BS habe ich Win7 32bit. Als Browser läuft IE9 beta.
Xampp 1.7.3 ist installiert und funktioniert soweit.
Wenn ich meine abc.php über den webwaver im browser aufrufe, wird diese auch angezeigt.
Wird aber der Button "Startseite" angeclickt, wird weder ein "include" noch ein "href" ausgeführt. Stattdessen wird, vermutlich von IE9, ein Fenster geöffnet, indem ich nur "Öffnen" oder "Speichern" auswählen kann.
Die Ports 80 und 443 sind laut netstat -a -n -o von Xampp belegt. IIS läuft nicht. In der Firewall von Win7 ist httpd.exe freigegeben, ich bin Admin auf dem PC. Auch in der externen Firewall ist xampp als zuverlässiges Prog eingetragen.
Daher vermute ich das Problem beim IE9 beta.
Hat jemand auch diese Erfahrung gemacht oder eine Lösung?

Danke!
JuK
 
Posts: 4
Joined: 29. December 2010 19:02

Re: Problem: Win7 Xampp und IE9 beta

Postby Pitze » 29. December 2010 22:53

In der Firewall von Win7 ist httpd.exe freigegeben,

Warum? Für eine Testumgebung nicht nötig.
Daher vermute ich das Problem beim IE9 beta.

Vermute?? Wie wäre es mal mit einem anderen Browser Testen und warum benutzt man einen solchen Schrott wie IE??
Der grösste Vertrauensbruch ist der Blitzableiter auf der Kirchturmspitze
User avatar
Pitze
 
Posts: 210
Joined: 20. November 2003 21:38
Location: Huskvarna-Schweden
Operating System: Windows Vista

Re: Problem: Win7 Xampp und IE9 beta

Postby Altrea » 29. December 2010 22:59

Dass ein include nicht ausgeführt wird kann rein garnichts mit dem Browser zu tun haben, denn PHP wird schon bevor der Browser überhaupt etwas zu Gesicht bekommt serverseitig vom PHP parser verarbeitet und erst das Ergebnis davon dem Browser zurückgesendet.

Um dem Fehler auf den Grund zu gehen, wäre ein Test Quellcode nicht schlecht.

Pitze wrote:und warum benutzt man einen solchen Schrott wie IE??

Microsoft ist da doch schon auf dem Weg der Besserung. Den IE9 finde ich bisher recht vielversprechend. Es wird zwar auch kein Vorreiter aber er findet wieder Anschluß an die Konkurrenz.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8293
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Problem: Win7 Xampp und IE9 beta

Postby Pitze » 29. December 2010 23:18

Dass ein include nicht ausgeführt wird kann rein garnichts mit dem Browser zu tun haben, denn PHP wird schon bevor der Browser überhaupt etwas zu Gesicht bekommt serverseitig vom PHP parser verarbeitet und erst das Ergebnis davon dem Browser zurückgesendet.

Dessen bin ich mir schon bewusst, mir gehts eigendlich um das "vermute" im grunde will ich einfach nur das er versucht den Fehler vom Anfang her Logisch nachzuvollziehen und selber Nachzudenken.
Es nervt dieses ich habe ein Problem ich vermute, dahinter steht einfach nur gebt mir eine Lösung macht fertig, wer schon an so simple Probleme scheitert(fehleranzeige in PHP aktivieren) sollte nicht auch noch den Apache durch die Firewall schleifen.
Microsoft ist da doch schon auf dem Weg der Besserung. Den IE9 finde ich bisher recht vielversprechend. Es wird zwar auch kein Vorreiter aber er findet wieder Anschluß an die Konkurrenz.

Hatte bis dato leider noch nicht die Zeit mir den anzusehen, bisher war der IE weit davon entfernt ein Webkomformer Browser nach dem W3C zu sein wer Webseiten nach dem Standart macht kann ein Lied davon singen.
Der grösste Vertrauensbruch ist der Blitzableiter auf der Kirchturmspitze
User avatar
Pitze
 
Posts: 210
Joined: 20. November 2003 21:38
Location: Huskvarna-Schweden
Operating System: Windows Vista

Re: Problem: Win7 Xampp und IE9 beta

Postby Altrea » 29. December 2010 23:47

Pitze wrote:Dessen bin ich mir schon bewusst

Dieser Teil des Posts war ja nicht an dich gerichtet. Dieses Wissen würde ich dir nicht absprechen wollen :D

Pitze wrote:im grunde will ich einfach nur das er versucht den Fehler vom Anfang her Logisch nachzuvollziehen und selber Nachzudenken.

Ich sehe das ähnlich. Man lernt am meisten wenn man sich selbst die Lösung herleitet.
In diesem Fall hier weiß ich aber nicht, ob du dem Fragestellenden einen Gefallen mit den Brotkrumen, die du ihm hingeworfen hast, getan hast - besser gesagt ob diese groß genug waren, dass er selbst den richtigen Weg einschlagen kann.
Wenn man die ganze Latte an HTML + Browser + PHP + Apache Eigenarten im Verdacht hat ein Problem zu verursachen, ist man, denke ich, für jeden Tipp dankbar der die Verdächtigen etwas eingenzen kann.
Und wenn man ganz ehrlich ist, ist das Themengebiet PHP + Apache immernoch groß genug, dass die Lösung nicht auf dem Silbertablett offenliegt.

Ich denke und hoffe, dass er daraus noch genug lernt 8)
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8293
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Problem: Win7 Xampp und IE9 beta

Postby Pitze » 30. December 2010 00:18

Stimmt schon manchmal sieht man den Wald vor lauter Bäumen nicht und vergiesst das man selber mal angefangen hat.
Leider glauben einige aber das es hier so etwas wie eine Servicepflicht gibt und erwarten fertige Lösungen andere machen es sich einfach nur leicht, warum selber denken wenn die das im Forum doch machen.
Ist schwer die Spreu vom Weizen zu trennen oder ich muss mal einfach wieder öfter hier reinschauen um mehr Übersicht zu haben.

Pitze
Der grösste Vertrauensbruch ist der Blitzableiter auf der Kirchturmspitze
User avatar
Pitze
 
Posts: 210
Joined: 20. November 2003 21:38
Location: Huskvarna-Schweden
Operating System: Windows Vista

Re: Problem: Win7 Xampp und IE9 beta

Postby JuK » 30. December 2010 07:41

Hallo,

wer lesen kann, ist klar im Vorteil!
Wird aber der Button "Startseite" angeclickt, wird weder ein "include" noch ein "href" ausgeführt. Stattdessen wird, vermutlich von IE9, ein Fenster geöffnet, indem ich nur "Öffnen" oder "Speichern" auswählen kann.


Da es im Opera funktioniert und dieses Fenster nur beim IE9 kommt, lasst mich logisch denken, wird es wohl am IE liegen.

Leider glauben einige aber das es hier so etwas wie eine Servicepflicht gibt und erwarten fertige Lösungen andere machen es sich einfach nur leicht, warum selber denken wenn die das im Forum doch machen.

...schön, dass ihr Euch die Antwort gleich selber gebt.
Stimmt schon manchmal sieht man den Wald vor lauter Bäumen nicht und vergiesst das man selber mal angefangen hat.


Themen-/Problembezogene Antworten gehören auch dazu, anstatt sich über die angebliche Unfähigkeit von Fragestellern auszulassen!
Nein, das setze ich nicht vorraus, da ich selbst Admin in einem Forum mit über 6000 Mitgliedern bin.

PHP kann ich selbst, denn das ist mein Beruf. Die Frage ist, ob es bekannte Probleme mit Win7 und Xampp in Verbindung mit dem IE9beta gibt und nicht ob oder ob nicht IE9. Wenn ja, gibt es eine Lösung dafür?


Über problemlösende Hilfestellung wäre ich dankbar, um eben den Wald und nicht nur die Bäume zu sehen. Auf das andere kann ich verzichten.
JuK
 
Posts: 4
Joined: 29. December 2010 19:02

Re: Problem: Win7 Xampp und IE9 beta

Postby Altrea » 30. December 2010 14:31

JuK wrote:Themen-/Problembezogene Antworten gehören auch dazu, anstatt sich über die angebliche Unfähigkeit von Fragestellern auszulassen!

Das hat mit Unfähigkeit nichts zu tun. Deinen Kenntnisstand konnte man aus deinem ersten Beitrag bei weitem nicht herauslesen.
Erwartet man eine ganz präzise Art von Antwort, dann sollte schon die Frage so präzise gestellt sein, dass dies klar wird - dazu gehört neben einer detaillierten Fehlerbeschreibung ebenso eine kurze Beschreibung der eigenen Fähigkeiten.
Anderenfalls darfst du dich nicht beschweren, wenn man dies versucht aus deinen Sätzen oder dem allgemeinen Kenntnisniveau des Forums herauszulesen.


JuK wrote:wer lesen kann, ist klar im Vorteil!
Wird aber der Button "Startseite" angeclickt, wird weder ein "include" noch ein "href" ausgeführt.


Sehr unpräzise:
Was macht der Button "Startseite"?
- Steckt dahinter ein HTML-Formular?
- Wird eine JavaScript Funktion aufgerufen?
- href kenne ich in Verbindung mit HTML-Verweisen, aber mit Buttons?
- Wie sieht der include aus und wie steht der im Zusammenhang mit dem Button?
All diese Fragen hättest du mit wenigen Zeilen Quellcode erschlagen können.

JuK wrote:Stattdessen wird, vermutlich von IE9, ein Fenster geöffnet, indem ich nur "Öffnen" oder "Speichern" auswählen kann.
Da es im Opera funktioniert und dieses Fenster nur beim IE9 kommt, lasst mich logisch denken, wird es wohl am IE liegen.

Das ist eine Fehlannahme.
Der öffnen/speichern Dialog erscheint immer dann, wenn der Browser mit dem im Response-Header angegebenen Dateityp nichts anzufangen weiß.
Es ist also durchaus möglich, dass der Opera ein Plugin oder einen Failback hat, der ihm die Möglichkeit gibt die Rückgabe anders zu interpretieren als der IE. Das ist dann aber nicht die Schuld des IE, vielmehr würde ich mir ansehen, was da überhaupt von deinem Server zurückgeschickt wird.
Aber das ist alles reine Spekulation, denn ohne irgendwelche Kenntnisse darüber zu haben was überhaupt passiert und was zurückkommt ist hier jedes Wort zuviel.

JuK wrote:PHP kann ich selbst, denn das ist mein Beruf. Die Frage ist, ob es bekannte Probleme mit Win7 und Xampp in Verbindung mit dem IE9beta gibt und nicht ob oder ob nicht IE9. Wenn ja, gibt es eine Lösung dafür?

Es gibt bisher keine bekannten Probleme, die mit der Kombination Win7, XAMPP und IE9beta zusammenhängen. Aber vielleicht finden wir dennoch die Ursache des Problems.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8293
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Problem: Win7 Xampp und IE9 beta

Postby Pitze » 30. December 2010 19:30

wer lesen kann, ist klar im Vorteil!

Dazu muss erst mal genügend Info zum lesen da sein mit ich klicke auf einen Button und er macht nicht was er soll reicht eben nicht.
Da es im Opera funktioniert und dieses Fenster nur beim IE9 kommt, lasst mich logisch denken, wird es wohl am IE liegen.

Falsch gedacht und logisch schon garnicht.
Der IE9 ist eine beta Version schon mal dran gedacht das ganze mit IE7 oder IE8 zu überprüfen und auch Mozilla bzw google mit ins Boot zu nehmen.
PHP kann ich selbst, denn das ist mein Beruf.

Aber da ist dann auch schon Sendeschluss.
Sind Änderungen an der Config des Servers vorgenommen worden?
Was ist mit der Art und Weise wie die Startseite aufgerufen wird, ist überhaupt sichergestellt das die Seite über den Server läuft, gibt es das Problem im IE7-8 auch?
Sind andere Browser ausser Opera getestet worden?
Ist das ganze mal mit einem anderen Skript getestet worden?
Fragen über Fragen und du redest von Logisch denken. Ups!
Der grösste Vertrauensbruch ist der Blitzableiter auf der Kirchturmspitze
User avatar
Pitze
 
Posts: 210
Joined: 20. November 2003 21:38
Location: Huskvarna-Schweden
Operating System: Windows Vista

Re: Problem: Win7 Xampp und IE9 beta

Postby JuK » 31. December 2010 14:11

Hallo.
webweaver wurde irgendwann umbenannt in webcraft und wird seit 2005 nicht mehr weiterentwickelt ...

Das war mir bekannt. Daher habe ich heute mal phase5 ausprobiert. Selbes Fehlerbild.

Als ich die abc.php in abc.php5 umbenannt habe, hat sie auch der IE9 beta genommen und angezeigt.

Der Button "Startseite" dient dazu, um innerhalb einer Website, mit ihren Unterseiten, zurück auf die Startseite zu kommen. Sprich er ist nur ein Teil der Navigation.
JuK
 
Posts: 4
Joined: 29. December 2010 19:02

Re: Problem: Win7 Xampp und IE9 beta

Postby Altrea » 31. December 2010 14:49

JuK wrote:Als ich die abc.php in abc.php5 umbenannt habe, hat sie auch der IE9 beta genommen und angezeigt.

Was die Sache noch merkwürdiger macht, denn im Apache ist nirgens definiert, wie er mit .php5 Dateien umgehen soll, bzw. werden diese Seiten vom Apache als reinen Plaintext einfach an den Browser weitergeleitet und NICHT durch den PHP Parser gejagt.

Aber das tut nichts mehr zur Sache. Da du dich nicht imstande siehst, die Fragen die du hier hinterlassen hast zu beantworten werde ich mich hier ausklinken.
Vielleicht hat noch einer der anderen freundlichen Helfer die Lust dir weiter jede Information mühsam aus der Nase zu ziehen.
Für mich ist das hier nurnoch vertane Zeit. Und da ich für meine Zeit hier nicht bezahlt werde, versuche ich lieber denen zu helfen, die auch gewillt sind sich helfen zu lassen.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8293
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Problem: Win7 Xampp und IE9 beta

Postby JuK » 01. January 2011 15:18

Hallo,

Aber das tut nichts mehr zur Sache. Da du dich nicht imstande siehst, die Fragen die du hier hinterlassen hast zu beantworten werde ich mich hier ausklinken.


Das ist das Beste, was Du machen kannst! Außer unsachliches Auslassen kam von Euch beiden NICHTS!
Dies solls zu diesem Thema gewesen sein.

viel Spaß beim weiteren im-eigenen-überheblichen-Saft-versauern!
JuK
 
Posts: 4
Joined: 29. December 2010 19:02


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 16 guests