Kompression - weder gzip noch deflate geht

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Kompression - weder gzip noch deflate geht

Postby Hexodus » 21. December 2010 12:12

Weder auf dem Localhost noch auf dem Webspace schaffe ich es die Kompression zuzuschalten und ich verstehe einfach nicht warum. Eigentlich müsste es funktionieren ... jetzt stehe ich da mit einem großen Fragezeichen über dem Kopf.
Auf meinem lokalen Rechner läuft ein neu installiertes Xampp ( Apache 2.2.14) und ich habe auch sichergestellt, dass in der httpd.conf das "mod_deflate.so" auch geladen wird. Auf meinem Webspace habe ich leider keine Einsicht in die Konfiguration des Apache, dort lief aber zumindest früher gzip - nur tut es das seit neuestem nicht mehr, warum auch immer (vermutlich hat Strato eine neuere Apache-Version aufgespielt die kein gzip - installiert).

Jedenfalls habe ich versucht per .htaccess sowohl gzip als auch deflate zum Laufen zu bekommen. Dabei habe ich so ziemlich alle Einstellungen die ich im Web finden konnte ausprobiert. z.B:

Code: Select all
AddOutputFilterByType DEFLATE text/html text/plain text/xml text/css
<FilesMatch "\\.(js|css|html|htm|php|xml)$">
SetOutputFilter DEFLATE
</FilesMatch>


Code: Select all
SetOutputFilter DEFLATE
AddOutputFilterByType DEFLATE text/css text/html text/plain text/xml text/js application/x-javascript application/javascript x-httpd-php


Code: Select all
<ifModule mod_gzip.c>
  mod_gzip_on Yes
  mod_gzip_dechunk Yes
  mod_gzip_item_include file \.(html?|txt|css|js|php|pl)$
  mod_gzip_item_include handler ^cgi-script$
  mod_gzip_item_include mime ^text/.*
  mod_gzip_item_include mime ^application/x-javascript.*
  mod_gzip_item_exclude mime ^image/.*
  mod_gzip_item_exclude rspheader ^Content-Encoding:.*gzip.*
</ifModule>


Ich weiß jetzt leider nicht wie ich das Problem einkreisen kann. Lässt es sich irgenwie herausfinden welche Module laufen und funktionieren? Oder kann hier jemand direkt sagen, woran das liegen könnte?
Hexodus
 
Posts: 4
Joined: 21. December 2010 12:00

Re: Kompression - weder gzip noch deflate geht

Postby Hexodus » 23. December 2010 15:06

Bin echt enttäuscht, dass hier keiner eine Idee dazu hat. Ich brauche echt Hilfe.
Hexodus
 
Posts: 4
Joined: 21. December 2010 12:00

Re: Kompression - weder gzip noch deflate geht

Postby Nobbie » 23. December 2010 15:12

Hexodus wrote:,Auf meinem Webspace habe ich leider keine Einsicht in die Konfiguration des Apache, dort lief aber zumindest früher gzip - nur tut es das seit neuestem nicht mehr, warum auch immer (vermutlich hat Strato eine neuere Apache-Version aufgespielt die kein gzip - installiert).,

...

Ich weiß jetzt leider nicht wie ich das Problem einkreisen kann. Lässt es sich irgenwie herausfinden welche Module laufen und funktionieren? Oder kann hier jemand direkt sagen, woran das liegen könnte?


Wahrscheinlich darfst Du es dann auch nicht in der .htaccess ändern. Die Einstellung von "AllowOverride" in httpd.conf (auf die Du aber keinen Zugriff hast) entscheidet darüber, was Du überhaupt via .htaccess beeinflussen darfst. Das solltest Du Strato fragen, das kann Dir hier niemand beantworten.

Die entscheidende Option für AllowOverride ist für diese Konfiguration der Wert "FileInfo", wenn AllowOverride diesen Wert nicht enthält (und auch nicht auf "All" steht), dann geht das eben nicht.
Nobbie
 
Posts: 8772
Joined: 09. March 2008 13:04

Re: Kompression - weder gzip noch deflate geht

Postby Hexodus » 24. December 2010 09:53

Dankeschön für diesen Hinweis. Bei dem Provider ist bestimmt nicht alles freigegeben, da müsste ich in der Tat nachfragen. Was mir jedoch Rätsel aufgibt ist die Tatsache, dass meine lokale Konfiguration definitiv auf AllowOverride All steht und das dennoch nicht geht. Page Speed meckert nach wie vor über keine Kompression und die Header zeigen auch keine Kompression an. Irgendwo muss ein Fehler stecken, nur komme ich nicht darauf. Gibt es eine Möglichkeit das zu debuggen?
Hexodus
 
Posts: 4
Joined: 21. December 2010 12:00

Re: Kompression - weder gzip noch deflate geht

Postby Nobbie » 24. December 2010 11:02

Ich habe es mal bei mir getestet, Xampp in der Standardauslieferung hat mod_deflate NICHT aktiv, da habe ich das Kommantarzeichen aus httpd.conf entfernt und ich habe eine .htaccess in htdocs angelegt, wo nur diese eine Zeile drin steht (Du haust da sinnlos alles rein, was Dir einfällt - aber auch hier gilt NICHT "viel hilft viel"):

Code: Select all
AddOutputFilterByType DEFLATE text/html text/plain text/xml text/css


Dann Apache neu starten und es funktioniert.

Ich habe kein Page Speed, kenne ich auch nicht, aber ich kann den Erfolg sehen, wenn ich phpinfo() ausführe mit DEFLATE, dann sagt mir Firefod unter "Extras => Seiteininformationen", dass die angezeigte Seite ca. 11kb groß ist, wenn ich die .htaccess wieder lösche und die Seite refreshe, ist sie 75kb groß. Also Kompression ca. Faktor 7.

Ich habe hier Xampp 1.7.3 unter Win7 Home Premium 64bit unter C:/Xampp installiert.
Nobbie
 
Posts: 8772
Joined: 09. March 2008 13:04

Re: Kompression - weder gzip noch deflate geht

Postby Hexodus » 04. January 2011 09:53

Danke Nobbie, Du hast ganz Recht. Deflate funktioniert auf meinem Localhost. Nur konnte ich das anhand der Header nicht erkennen. Über Dateigröße der Webseite ist der Unterschied jedoch klar zu erkennen.

Das Dumme ist nur, dass der Provider sowohl Deflate als auch Gzip abgestellt hat. Dort kann ich wohl nichts ausrichten :(
Hexodus
 
Posts: 4
Joined: 21. December 2010 12:00


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 5 guests