xampp Handbuch - Problem bei einer Beispielkonfiguration

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

xampp Handbuch - Problem bei einer Beispielkonfiguration

Postby xtest » 29. November 2010 19:56

Hallo Community,

ich habe mir das xampp Handbuch vorgenommen und will das von vorne bis hinten durcharbeiten.

Im Kapitel 3 unter 3.1 Virtual Hosts wird beschrieben wie Virtual Hosts eingebunden und angesprochen werden.
Ich habe wie im Buch beschrieben die Hosts Datei entsprechend geändert, also:
127.0.0.1 localhost1
127.0.0.2 localhost2 localhost 3

Folgende Anweisung ist in der httpd.conf "nicht" auskommentiert:
include conf/extra/httpd-vhosts.conf

Unter dem neu erstellten Verzeichnis "vhosts" habe ich die Ordner "htdocs" und "logs" jeweils unter ein neu erstelltes Verzeichnis "localhost1" "localhost2" und "localhost3" erstellt. Die Ordner htdocs enthalten
eine index.htm.

In der http-vhosts.conf habe ich folgende Einträge hinzugefügt:

NameVirtualHost 127.0.0.2

<VirtualHost 127.0.0.1:80>
ServerAdmin webmaster@localhost1
DocumentRoot d:/xampp 1.7.3/xampp/vhosts/localhost1/htdocs
ErrorLog d:/xampp 1.7.3/xampp/vhosts/localhost1/error_log
CustomLog d:/xampp 1.7.3/xampp/vhosts/localhost1/access_log common
</VirtualHost>

<VirtualHost 127.0.0.2:80>
ServerAdmin webmaster@localhost2
DocumentRoot d:/xampp 1.7.3/xampp/vhosts/localhost2/htdocs
ServerName localhost2
ErrorLog d:/xampp 1.7.3/xampp/vhosts/localhost2/error_log
customLog d:/xampp 1.7.3/xampp/vhosts/localhost2/access_log common
</VirtualHost>

<VirtualHost 127.0.0.2:80>
ServerAdmin webmaster@localhost3
DocumentRoot d:/xampp 1.7.3/xampp/vhosts/localhost3/htdocs
ServerName localhost3
ErrorLog d:/xampp 1.7.3/xampp/vhosts/localhost3/error_log
customLog d:/xampp 1.7.3/xampp/vhosts/localhost3/access_log common
</VirtualHost>

Jetzt soll ich laut Buch schön sehen können, wenn ich im Browser die "localhost1" oder 2 oder 3 aufrufe, wie dann meine index.htm angezeigt wird.
Jedoch komme ich gar nicht soweit denn mein Apache im Xampp startet nicht. Xampp bleibt kurz hängen, dann steht später unten im Info-Fenster "Apache service started" aber der ist nicht gestartet.
Im Ereignissprotokol steht: Der Dienst "Apache2.2" wurde mit folgendem dienstspezifischem Fehler beendet: 1 (0x1).

Was mache ich falsch?

vG

xtest
xtest
 
Posts: 2
Joined: 29. November 2010 19:38

Re: xampp Handbuch - Problem bei einer Beispielkonfiguration

Postby xtest » 29. November 2010 23:00

OK!
Das Handbuch heisst: Das xampp Handbuch von Kai Seidler, Kay Vogelsang.
Der Abschnitt 3.1 beschreibt die Funktionsweise von Virtual Hosts.

Als Beispielübung wird beschrieben, wie man die Funktionsweise selbst testen kann, indem man die Virtual Hosts in der vhost-conf einträgt
und zwar so wie oben von mir aufgeführt, beginnend mit "NameVirtualHost 127.0.0.2.
Im xamp Verzeichniss habe ich, gemäß Handbuch, einen Ordner "vhosts" angelegt und darin jeweils 3 Ordner für die Virtual Hosts angelegt, und in diesen
jeweils einen Ordner htdocs und einen Ordner logs. In den Ordnern "htdocs liegt jeweil eine index.html.

Jetzt soll man schön sehen können wie die entsprechende index.html im Browser erscheint wenn man http://localhost1 http://localhost2 http://localhost3
im Browser aufruft.

Und jetzt habe ich den Fehler auch entdeckt. Ich habe die vhosts Ordnerstruktur im Ordner apache hinterlegt und der muss unter dem gleichen Ordner wie der apache liegen, nämlich direkt unter xampp.

Vielen Dank wole für Deine Hinweise. Beim nächsten mal werde ich das Problem deutlicher schildern.

vG

xtest
xtest
 
Posts: 2
Joined: 29. November 2010 19:38


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 16 guests