XAMPP installiert, aber phpBB Bord funktioniert nicht!

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

XAMPP installiert, aber phpBB Bord funktioniert nicht!

Postby friendlyuser » 07. February 2004 00:58

Hallo!

Ich komme seit gestern bei diesem Problem nicht weiter.

Ich habe auf meinem Server Apache installiert, dann PHP4 und MySQL. Soweit ich das sehe, läuft alles wunderbar!

Wenn ich im Explorer das Board anwählen komm ich zur Installation.

Hier ein Screenshot davon: http://www.shebaka.org/bilder/install.jpg

Und dann kommt als Fehlermeldung:

Warning: mysql_connect(): Access denied for user: 'root@localhost' (Using password: YES) in D:\_http\www.shebaka.org\board\db\mysql4.php on line 48

Warning: mysql_error(): supplied argument is not a valid MySQL-Link resource in D:\_http\www.shebaka.org\board\db\mysql4.php on line 330

Warning: mysql_errno(): supplied argument is not a valid MySQL-Link resource in D:\_http\www.shebaka.org\board\db\mysql4.php on line 331
phpBB : Kritischer Fehler

Could not connect to the database


Okay. Ich habe mir dann auf meiner Workstation XAMPP installiert. Auf der XAMPP Testseite funktioniert alles, der Apache läuft, die Ampel ist auf grün! Ich habe auch die ODBC Driver installiert! Aber es kommt das gleiche Problem wie am Server!!!

Was muss ich tun, damit ich dieses Board installieren kann?

Ich wäre für Hilfe sehr dankbar!!!

Liebe Grüße!
friendlyuser
 
Posts: 4
Joined: 07. February 2004 00:39

Postby Wiedmann » 07. February 2004 01:14

Warning: mysql_connect(): Access denied for user: 'root@localhost' (Using password: YES) in D:\_http\www.shebaka.org\board\db\mysql4.php on line 330

Du hast wohl in der Konfig vom phpBB ein anderes Datenbankpasswort angeben als der Benutzer "root" in der Rechteverwaltung von MySQL hat.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Ich hab in der my.in nachgesehen! PW ist richtig...

Postby friendlyuser » 07. February 2004 01:38

...aber ich habe jetzt eine andere Fehlermeldung rausbekommen!

Warning: mysql_connect(): Can't connect to MySQL server on 'www.shebaka.org' (10061) in D:\_http\www.shebaka.org\board\db\mysql4.php on line 48

das (10061) ist neu!
friendlyuser
 
Posts: 4
Joined: 07. February 2004 00:39

Postby Wiedmann » 07. February 2004 01:46

Dann hast du jetzt wohl den Hostnamen in der phpbb-Konfig auf "www.shebaka.org" umgestellt, anstatt den auf "localhost" zu lassen.

(In der Regel, und aus Sicherheitsgründen, sollte ja der MySQL-Server beim Provider nur Anfragen von "localhost" akzeptieren.)
Last edited by Wiedmann on 07. February 2004 01:52, edited 1 time in total.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby friendlyuser » 07. February 2004 01:48

ist das schlecht? ich soll man localhost speichern oder den domainname vom server?
friendlyuser
 
Posts: 4
Joined: 07. February 2004 00:39

Postby Wiedmann » 07. February 2004 01:56

In der Anleitung vom phpBB steh ja auch "localhost". Ansonsten siehe den Nachtrag bei meinem letzten Post. Denk dran: Wenn das Script auf dem Server liegt und dort läuft, ist ja der MySQL-Server vom Script aus gesehen auf dem "localhost" zu erreichen.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 7 guests