MSSQL works on XAMPP 1.6.8 but not 1.7.3

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

MSSQL works on XAMPP 1.6.8 but not 1.7.3

Postby the_user2 » 30. October 2010 13:20

Hi,

I wanted to upgrade to XAMPP 1.7.3 from 1.6.8 but cannot get the MSSQL connection to work, I always get "Unable to connect to server".

The exact same php code works with the exact same MSSQL server on 1.6.8 but not on 1.7.3, so I can rule out password and MSSQL configuration issues.

I am using extension=php_mssql.dll and extension=php_pdo_mssql.dll.

I tried replacing the ntwdblib.dll 8.00.194 that comes with 1.7.3 with the one that came with 1.6.8.

Does anyone have any ideas?

Michael
the_user2
 
Posts: 2
Joined: 30. October 2010 13:11

Re: MSSQL works on XAMPP 1.6.8 but not 1.7.3

Postby the_user2 » 30. October 2010 20:55

Partially solved.

MSSQL and XAMPP are both running the same machine, which is Win7 with IPv6 enabled.
As mentioned, I use php_mssql.dll and the only protocol enabled in MSSQL is Shared Memory.

If I specify localhost\instance as hostname, it fails (but worked well with XAMPP 1.6.8 ).

If I specify [real hostname]\instance, it works.

Don't ask me why. If anybody can shed any light on this, I would appreciate it.

Michael
the_user2
 
Posts: 2
Joined: 30. October 2010 13:11

Re: MSSQL works on XAMPP 1.6.8 but not 1.7.3

Postby WilliL » 01. November 2010 12:20

a guess:
on XAMPP 1.6.8 IPv4 - 127.0.0.1
on XAMPP 1.7.3 IPv6 (enabled) - ::1
Willi
WilliL
 
Posts: 661
Joined: 08. January 2010 10:54
Operating System: Win7Home Prem 64 SP1


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 12 guests