Apache kann perl nicht finden (Problem gelöst)

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Re: Apache kann perl nicht finden (Problem gelöst)

Postby DieterW » 16. September 2010 15:17

Nachdem hier im Forum keine Problemlösung zu erreichen war, habe ich mich im Netz auf die Suche begeben und schließlich dies hier gefunden:
http://web.archiveorange.com/archive/v/rwZjAuuqDYAk16rwrbkY
Es handelt sich also eindeutig um einen Bug in der Apache Software.
Allerdings hatte niemand im Netz einen Workaround-Vorschlag anzubieten.

Nach einem Vergleich meiner Registry-Einträge (funktionierenden xampp-Installation unter Vista v.s. nicht funktionierende xampp-Version unter Win7) führten dann die folgenden Werte unter Win7 zum Erfolg.

HKEY_CLASSES_ROOT/.pl
Name: Standard
Type: REG_SZ
Wert: Perl

HKEY_CLASSES_ROOT/Perl
Name: Standard
Type: REG_SZ
Wert: (Wert nicht gesetzt)

HKEY_CLASSES_ROOT/PersistentHandler
Name: Standard
Type: REG_SZ
Wert: (Wert nicht gesetzt)

ScriptInterpreterSource Registry
findet nun, ohne Auswertung der Shebang Zeile, den Pfad zu perl und alle Scripte (die nicht auf eine MySql Datenbank zugreifen) laufen einwandfrei auf dem Apache.
Aber auch dieses MySql-Problem wird sicherlich zu lösen sein.

Warnung:
Die hier (und im Netz) zu findenden Vorschläge zur Verknüpfung der .pl Extension mit ExecCGI ist zwar nett, führt aber dazu dass Editoren (wie z.B. Komodo u.a.) dann immer zusammen mit dem Browser gestartet werden sobald über den Browser eine URL aufgerufen wird welche die Extension .pl beinhaltet.
Ich sehe gerade ...
User Nobbie hat seine entsprechenden Beiträge bereits gelöscht :)

Nachtrag:
Es wäre natürlich äußerst hilfreich, wenn man hinter
ScriptInterpreterSource
einfach das jeweilige Interpreterverzeichnis eintragen könnte - aber das funktioniert ja leider nicht.
DieterW
 
Posts: 11
Joined: 13. September 2010 23:39

Re: Apache kann perl nicht finden (Problem gelöst)

Postby DieterW » 17. September 2010 13:02

DieterW wrote:ScriptInterpreterSource Registry
findet nun, ohne Auswertung der Shebang Zeile, den Pfad zu perl und alle Scripte (die nicht auf eine MySql Datenbank zugreifen) laufen einwandfrei auf dem Apache.

Auch das letztgenannte Problem hat sich erledigt.
Ich hatte (bei der Neuinstallation der MySql Datenbank) lediglich versäumt, dem MySql-User ein Passwort zuzuweisen.

OK - alles läuft zur Zufriedenheit.
Weitere Hilfe von Seiten der hier aktiven Forumsmitglieder ist also nicht mehr erforderlich :lol:
DieterW
 
Posts: 11
Joined: 13. September 2010 23:39

Re: Apache kann perl nicht finden (Problem gelöst)

Postby DieterW » 17. September 2010 13:38

Noch ein Tipp für alle die vor einem Eingriff in die Registry zurückschrecken und in der http.conf
ScriptInterpreterSource Registry
nicht verwenden wollen.

Während der Installation des Perl-Pakets von ActiveState wird nach dem Installationsverzeichnis gefragt.
C:/usr
ist dann eine gute Wahl weil der Apache die Shebang Zeile
#!/usr/bin/perl
ausliest und somit den Interpreter im entsprechenden Windowsverzeichnis findet.
DieterW
 
Posts: 11
Joined: 13. September 2010 23:39

Previous

Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 10 guests