xampp setup fehler /apache/mysql...

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

xampp setup fehler /apache/mysql...

Postby lukkii » 03. September 2010 17:08

Hallo zusammen,


Nach dem Ausführen der selbstinstallierbaren .exe, erscheint ein Fenster für das Installationsverzeichnis. Ich wählte das Standartverzeichnis C:// ( installiert ist es also in C:\xampp ! ). Nach der Installation erschien ein Eingabefeld. Auf die Frage, ob ich gerne einen Shortcut hinzufügen möchte, antwortete ich mit yes und folgender Fehler wurde ausgegeben:

Failed to create COM object `Scripting.FileSystemObject': Das angegebene Modul w
urde nicht gefunden.
in C:\xampp\setup_xampp.bat on line 264
Stack trace:
#0 C:\xampp\setup_xampp.bat(264): com->com('Scripting.FileS...', NULL, 65001)
#1 C:\xampp\setup_xampp.bat(437): setup_XAMPP::doShortcuts()
#2 C:\xampp\setup_xampp.bat(493): setup_XAMPP::Run()
#3 {main}

Was auch immer das zu bedeuten hat. Aus einem Tutorial weiß ich, dass noch mehr Fragen kommen, die ich allerdings nicht beantworten kann, da nach dieser Meldung mit Return das Programm beendet wird.

Weiterhin habe ich ebenfalls im XAMPP Controlpanel Probleme :
Ich würde gerne die Apache und mysql Funktionen nutzen. Nach einem Haken bei svc and auf Start, erscheint zwar unten eine Meldung mit "Apachiservice started" aber das kleine Schild "running" wird mir bei beiden nicht angezeigt. Klicke ich dann auf eine andere Funktion, erscheint "busy..."

in den FAQ auf Ihrer Seite unter Vista-Probleme ist als Möglichkeit den UAC abzuschalten. Aber auch dannach kann ich weder den Apachi, noch den mysql server starten. Selbe Fehlermeldung, bzw. "busy..."

da ich überhaupt keinen Dunst habe und mir eigentlich webprogrammieren beibringen wollte, bin ich auf dem Gebiet leider total unfähig. Verzeiht also bitte, wenn das alles an einem kleinen Fehler liegen sollte.

Die zusätzliche Fehlermeldung ließ mich diesen neuen Thread eröffnen. Vllt hängt das ja mit dem apache/mysql - Problem zusammen...


Schöne Grüße aus Köln,
Lukas Kl.
lukasklein1990@gmx.de
lukkii
 
Posts: 3
Joined: 03. September 2010 17:02

Re: xampp setup fehler /apache/mysql...

Postby Altrea » 03. September 2010 17:16

Hallo Lukas,

Versuche bitte einmal xampp zu deinstallieren.

Danach mit der rechten Maustaste auf die Installationsdatei klicken und "als Administrator ausführen" auswählen.
Es kann sein, dass dein UAC dir schon bei der Installation dazwischengefunkt hat. Diese Vorgehensweise beugt dem vor.

Als Installationsverzeichnis natürlich wieder c:/ auswählen.
Ob das batch-script das danach aus mit diesen erhöhten Administratorenrechten ausgeführt wird und werden muss, weiß ich nicht. Sollte dies also danach immernoch fehlschlagen, dann starte bitte deine Eingabeaufforderung, natürlich ebenfalls wieder mit der vorgehensweise rechte Maustaste->als Administrator ausführen. Dort navigierst du dann mit den DOS-Befehlen zum Verzeichnis c:\xampp und startest die setup_xampp.bat.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8293
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: xampp setup fehler /apache/mysql...

Postby lukkii » 03. September 2010 17:46

Also via Admin ausführen hilft sowohl beim setup zur installation, als auch bei der control .exe nichts.
Vielleicht habe ich mich mit "ich habe keine Ahnung" falsch ausgedrückt. Ich meinte damit, dass ich keinen blassen schimmer habe und auch nicht weiß wie man mit Dos Befehlen Dateien öffnet?
also cmd schaff ich noch... dann würde ich sponten exec als befehl eingeben.
Code: Select all
C:\Users\Lukas>exec c:\servers\xampp\setup_xampp.bat

das funktioniert natrülich nicht. Also sei doch bitte so lieb und sag mir einfach genau was ich tun muss. Ach und wie startet man die CMD mit Admin rechten?!

ach übrigens. Deinstallieren kann ich nicht. Es erscheint ein Fehler. hier der screen http://s10.directupload.net/file/d/2271/bgp34ces_jpg.htm
Ich habs den Dir einfach gelöscht.

Was bedeutet der Fehlercode überhaupt? bzw die Fehler bei der CMD Eingabe?
und in dem Tutorial installiert er es einfach locker und es rennt alles :( echt traurig
lukkii
 
Posts: 3
Joined: 03. September 2010 17:02

Re: xampp setup fehler /apache/mysql...

Postby Altrea » 03. September 2010 18:01

lukkii wrote:Also via Admin ausführen hilft sowohl beim setup zur installation, als auch bei der control .exe nichts.

Schade. Für gewöhnlich ist bereits bei der Installation etwas schief gegangen, zum Beispiel dass die eine oder andere Datei nicht angelegt werden konnte. Das hätte zumindest deine Fehlermeldungen erklärt.
Was ich auchnicht verstehe ist, wieso dein Installationsverzeichnis nun c:\servers\ heißt statt c:\xampp\

lukkii wrote:also cmd schaff ich noch... dann würde ich sponten exec als befehl eingeben.

Noch einfacher. Mit
Code: Select all
cd C:\servers\xampp\
wechselst du in das Verzeichnis. Danach tippst du einfach die Datei die du ausführen möchtest ein, also setup_xampp.bat, ohne jedlichen Befehl davor.

lukkii wrote:Ach und wie startet man die CMD mit Admin rechten?!

Wenn du das neue Startmenu mit dem Suchfeld von Vista benutzt, gib ins Suchfeld "Eingabeaufforderung" oder "cmd" ein. Windows schlägt dir dann schon die richtige Datei vor. Auf diesen Link wie bereits beschrieben rechte Maustaste -> als Administrator ausführen.

lukkii wrote:und in dem Tutorial installiert er es einfach locker und es rennt alles :( echt traurig

Welches Tutorial denn? Für gewöhnlich ist die XAMPP installation auch relativ einfach.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8293
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: xampp setup fehler /apache/mysql...

Postby lukkii » 03. September 2010 18:11

hallo ich wieder...

also nix geht.

setup mit admin ausgeführt ->geht nicht
über admin cmd und die .bat datei gestartet -> geht nicht, kommt immer noch die fehlermeldung
xampp control exe mit admin gestartet -> es kommt immer noch das busy und es tut sich nix

so heißt einfach der ordner. auf der seite hier steht nur, dass man ihn nicht in c:/program files boxen darf...

naja ich hab keine ahnung was ich noch tun soll. ja ich sehe wie leicht sowas ist... not
lukkii
 
Posts: 3
Joined: 03. September 2010 17:02


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 14 guests