XAMPP braucht über eine halbe Stunde zum Starten

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

XAMPP braucht über eine halbe Stunde zum Starten

Postby kweber » 01. September 2010 08:42

Hallo,

ich habe schon seit längerem das Problem, dass XAMPP jeden Morgen, wenn ich meinen Rechner einschalte, extrem langsam startet - es braucht zwischen 1/2 und 1 Stunde, bis es bereit ist und auf Serveranfragen reagiert. Ich habe mich schon durch einige Foren gewühlt, aber keine Antwort auf mein spezifisches Problem gefunden (in den meisten Beiträgen unter Stichworten wie "langsam" oder "slow" werden Verzögerungen von 5-30 Sekunden behandelt, bei mir handelt es sich da ja um ganz andere Dimensionen).

Mein Betriebssystem ist XP SP2 auf einem 3.12 GHz Pentium4 Prozessor mit 512 RAM. Ich habe das XAMPP Basis Package 1.7.2 mit Apache 2.2.12 (IPV6 enabled) installiert. Die Systemvoraussetzung sagt, das Programm benötige XP (Server 2003) - vielleicht ist das schon die Lösung all meiner Probleme und der Einsatz dieser XAMPP-Version auf meinem Betriebssystem einfach nicht möglich?

Meine error.log-Datei sieht so aus:
Code: Select all
[Wed Sep 01 08:04:39 2010] [notice] Digest: generating secret for digest authentication ...
[Wed Sep 01 08:04:39 2010] [notice] Digest: done
[Wed Sep 01 08:15:49 2010] [notice] Apache/2.2.12 (Win32) DAV/2 mod_ssl/2.2.12 OpenSSL/0.9.8k mod_autoindex_color PHP/5.3.0 mod_perl/2.0.4 Perl/v5.10.0 configured -- resuming normal operations
[Wed Sep 01 08:15:49 2010] [notice] Server built: Jul 22 2009 11:35:54
[Wed Sep 01 08:15:49 2010] [notice] Parent: Created child process 3052
[Wed Sep 01 08:38:33 2010] [notice] Digest: generating secret for digest authentication ...
[Wed Sep 01 08:38:33 2010] [notice] Digest: done
[Wed Sep 01 08:53:40 2010] [notice] Child 3052: Child process is running
[Wed Sep 01 08:53:40 2010] [notice] Child 3052: Acquired the start mutex.
[Wed Sep 01 08:53:40 2010] [notice] Child 3052: Starting 150 worker threads.
[Wed Sep 01 08:53:40 2010] [notice] Child 3052: Starting thread to listen on port 80.
[Wed Sep 01 08:53:40 2010] [notice] Child 3052: Starting thread to listen on port 443.

XAMPP habe ich schon einige Minuten vor dem ersten Eintrag in der Logdatei gestartet; Anfragen an http://localhost/ bzw. die entsprechende IP-Adresse werden erst ab dem Moment beantwortet, wo in der Logdatei "Starting thread to listen on port 80" erscheint, d.h. es dauert ca. eine Stunde (!), bis das System läuft. Die CPU-Last sieht während dieser Zeit ganz entspannt aus, da scheint es keine Probleme zu geben. Irgendwo in einem Forum habe ich das Stichwort "Entropie" gelesen, aber das bezog sich glaube ich nicht auf ein Windows-System. Jedenfalls keine Ahnung, wie ich gegebenenfalls prüfe, ob mein System genug Entropie hat.

Bei den Ports scheint es auch keine Konflikte zu geben:
Image

Hat jemand eine Idee, an welcher Schraube ich drehen kann, um mein XAMPP etwas schneller in Bereitschaft zu versetzen? Welche Angaben müsste ich für eine eventuelle Ferndiagnose noch liefern?
kweber
 
Posts: 7
Joined: 01. September 2010 08:00

Re: XAMPP braucht über eine halbe Stunde zum Starten

Postby WilliL » 01. September 2010 20:06

hilft dir zwar nicht viel aber XPhome SP3 mit XAMPP 1.7.3 ist in klürzester Zeit gestartet

Anders als bei dir steht bei mir überall free hinter den Ports (habe alle 4 Dienste gestartet) über XAMPP Control Panel gestartet.
Hast du vielleicht die Haken bei Service (SVC) gesetzt? Wenn ja, bitte zum testen mal entfernen.

Für mich hört sich das eher nach einem Rechnerproblem an - bis der sich "sortiert" hat.
Ggf Platte für %temp% voll .. Desktop / Papierkorb voll
Willi
WilliL
 
Posts: 661
Joined: 08. January 2010 10:54
Operating System: Win7Home Prem 64 SP1

Re: XAMPP braucht über eine halbe Stunde zum Starten

Postby kweber » 02. September 2010 07:41

Danke für die Anregungen und Ideen. Wenn's ein generelles Rechnerproblem ist, werde ich weiter versuchen, die allgemeine Performance näher zu beobachten... Aber ein bisschen mysteriös ist das schon:
- Ich habe im XAMPP Control Panel keine Haken bei SVC gesetzt.
- ich habe 57GB frei auf der C:\-Platte, auf der auch XAMPP installiert ist, der C:\TEMP-Folder ist leer (der Temp-Folder unter "Dokumente und Einstellungen" ist nicht leer, aber den nutzt XAMPP ja sicher eh nicht - habe dort auch keine Dateien gesehen, die auf XAMPP hinweisen)
- CPU-Auslastung liegt immer so ca. bei 3-4 %
- die Größe der Auslagerungsdatei beträgt 445 MB - vielleicht ist das zu wenig?

P.S.: Immerhin, heute hat's "nur" 40 Minuten gedauert bis zur Meldung "listening on port 80" in error.log
kweber
 
Posts: 7
Joined: 01. September 2010 08:00

Re: XAMPP braucht über eine halbe Stunde zum Starten

Postby kweber » 02. September 2010 15:58

Wieder vielen Dank für die Anregungen.

wole wrote:Du könntest auch mal versuchesweise die "digest authentication" abschalten ob der Apache dann schneller startet.
Außerdem macht es wenig Sinn ein XP mit SP2 zu betreiben, SP3 ist heute der Standard (und auch nur der wird von MS unterstützt).


Ich hab' die digest authentication in der httpd.conf auskommentiert, das hat aber nichts geholfen, außer dass die Meldung dazu in der error.log nicht mehr auftaucht:

Code: Select all
[Thu Sep 02 14:20:07 2010] [notice] Parent: Child process exited successfully.
[Thu Sep 02 14:45:32 2010] [notice] Apache/2.2.12 (Win32) DAV/2 mod_ssl/2.2.12 OpenSSL/0.9.8k mod_autoindex_color PHP/5.3.0 mod_perl/2.0.4 Perl/v5.10.0 configured -- resuming normal operations
[Thu Sep 02 14:45:32 2010] [notice] Server built: Jul 22 2009 11:35:54
[Thu Sep 02 14:45:32 2010] [notice] Parent: Created child process 2128
[Thu Sep 02 15:33:50 2010] [notice] Child 2128: Child process is running
[Thu Sep 02 15:33:51 2010] [notice] Child 2128: Acquired the start mutex.
[Thu Sep 02 15:33:51 2010] [notice] Child 2128: Starting 150 worker threads.
[Thu Sep 02 15:33:51 2010] [notice] Child 2128: Starting thread to listen on port 443.
[Thu Sep 02 15:33:51 2010] [notice] Child 2128: Starting thread to listen on port 80.


Ich vermute jetzt sehr stark, dass das Problem an einer Software "Trend Microfilter" hängt (hier muss ich mich vielleicht entschuldigen, dass es so etwas gibt, hätte ich wohl früher merken und erwähnen sollen - aber mein ganzes Problem bezieht sich auf einen Rechner auf der Arbeit, wo ich keinen Einfluss auf die Systemadministration habe). Trend Microfilter ist eine Client-Server-basierte Antivirensoftware mit einer Echtzeit-Suche. So wie's aussieht, wird die mir vom LAN-Server vorgeschrieben und ich kann sie nicht ausschalten - muss also mal den Systemadministrator angehen, um zu klären, ob sich da was abschalten lässt. Das hier ist, was der Prozessviewer ausgeworfen hat:

Code: Select all
xampp_cli.exe, 3332, 02.09.2010 14:21, 02.09.2010 14:21, \\Pc25\c$\xampp\xampp_cli.exe, ERV\kw, xampp_cli.exe start apache, 0,

httpd.exe, 164, 02.09.2010 14:21, Running..., \\Pc25\c$\xampp\apache\bin\httpd.exe, ERV\kw, "\\Pc25\c$\xampp\apache\bin\httpd.exe" -f "\\Pc25 \c$\xampp\apache\conf\httpd.conf" -E "\\Pc25\c$\xampp\apache\logs\error.log", 259,

verclsid.exe, 1180, 02.09.2010 14:26, Running..., C:\WINDOWS\system32\verclsid.exe, ERV\kw, /S /C {2559A1F4-21D7-11D4-BDAF-00C04F60B9F0} /I {000214E6-0000-0000-C000-000000000046} /X 0x401, 259,

verclsid.exe, 2096, 02.09.2010 14:26, Running..., C:\WINDOWS\system32\verclsid.exe, ERV\kw, /S /C {2559A1F5-21D7-11D4-BDAF-00C04F60B9F0} /I {000214E6-0000-0000-C000-000000000046} /X 0x401, 259,

userinit.exe, 4040, 02.09.2010 14:26, 02.09.2010 14:27, C:\WINDOWS\system32\userinit.exe, ERV\kw, userinit.exe, 0,

httpd.exe, 2128, 02.09.2010 14:45, Running..., \\Pc25\c$\xampp\apache\bin\httpd.exe, ERV\kw, \\Pc25\c$\xampp\apache\bin\httpd.exe -d //Pc25/c$/xampp/apache -f \\Pc25\c$\xampp\apache\conf\httpd.conf -E \\Pc25\c$\xampp\apache\logs\error.log, 259,

bspatch.exe, 4072, 02.09.2010 14:50, 02.09.2010 14:50, C:\Programme\Trend Micro\Client Server Security Agent\bspatch.exe, NT-AUTORITÄT\SYSTEM, "C:\Programme\Trend Micro\Client Server Security Agent\bspatch.exe" "C:\Programme\Trend Micro\Client Server Security Agent\temp\BF.ptn" "C:\Programme\Trend Micro\Client Server Security Agent\temp\BF.new" "C:\Programme\Trend Micro\Client Server Security Agent\temp\BF.patch", 0,

bzip2.exe, 3940, 02.09.2010 14:50, 02.09.2010 14:50, C:\Programme\Trend Micro\Client Server Security Agent\bzip2.exe, NT-AUTORITÄT\SYSTEM, bzip2.exe -dc, 0,

bzip2.exe, 3840, 02.09.2010 14:50, 02.09.2010 14:50, C:\Programme\Trend Micro\Client Server Security Agent\bzip2.exe, NT-AUTORITÄT\SYSTEM, bzip2.exe -dc, 0,

bzip2.exe, 4084, 02.09.2010 14:50, 02.09.2010 14:50, C:\Programme\Trend Micro\Client Server Security Agent\bzip2.exe, NT-AUTORITÄT\SYSTEM, bzip2.exe -dc, 0,

SSMYPICS.SCR, 964, 02.09.2010 15:09, 02.09.2010 15:19, C:\WINDOWS\system32\SSMYPICS.SCR, ERV\kw, C:\WINDOWS\system32\SSMYPICS.SCR /s, 0,
 
bspatch.exe, 3308, 02.09.2010 15:33, 02.09.2010 15:33, C:\Programme\Trend Micro\Client Server Security Agent\bspatch.exe, NT-AUTORITÄT\SYSTEM, "C:\Programme\Trend Micro\Client Server Security Agent\bspatch.exe" "C:\Programme\Trend Micro\Client Server Security Agent\temp\BF.ptn" "C:\Programme\Trend Micro\Client Server Security Agent\temp\BF.new" "C:\Programme\Trend Micro\Client Server Security Agent\temp\BF.patch", 0,

bzip2.exe, 3548, 02.09.2010 15:33, 02.09.2010 15:33, C:\Programme\Trend Micro\Client Server Security Agent\bzip2.exe, NT-AUTORITÄT\SYSTEM, bzip2.exe -dc, 0,

bzip2.exe, 2756, 02.09.2010 15:33, 02.09.2010 15:33, C:\Programme\Trend Micro\Client Server Security Agent\bzip2.exe, NT-AUTORITÄT\SYSTEM, bzip2.exe -dc, 0,

bzip2.exe, 3240, 02.09.2010 15:33, 02.09.2010 15:33, C:\Programme\Trend Micro\Client Server Security Agent\bzip2.exe, NT-AUTORITÄT\SYSTEM, bzip2.exe -dc, 0,

utilPfwInstCondChecker.exe, 2476, 02.09.2010 15:49, 02.09.2010 15:49, C:\Programme\Trend Micro\Client Server Security Agent\utilPfwInstCondChecker.exe, NT-AUTORITÄT\SYSTEM, "utilPfwInstCondChecker.exe", 0, Trend Micro, Inc.

utilPfwInstCondChecker.exe, 2164, 02.09.2010 15:49, 02.09.2010 15:49, C:\Programme\Trend Micro\Client Server Security Agent\utilPfwInstCondChecker.exe, NT-AUTORITÄT\SYSTEM, "utilPfwInstCondChecker.exe", 0, Trend Micro, Inc.
kweber
 
Posts: 7
Joined: 01. September 2010 08:00

Re: XAMPP braucht über eine halbe Stunde zum Starten

Postby kweber » 02. September 2010 20:45

XP mit SP2 ist veraltet!


Ja, ja, ich glaub's Dir ja - ich war auch heut' Nachmittag schon auf windowsupdate.com, aber auch hier habe ich das Problem, dass ich wohl nichts ohne den Systemadministrator machen kann - der kommt nur einmal pro Woche für ein paar Stündchen vorbei. Die Windowsupdates sind bei mir so eingestellt, dass sie irgendwie über unseren LAN-Server laufen, nicht direkt möglich sind. Und sollte eine XP SP3-Lizenz die Firma teurer zu stehen kommen als eine XP SP2-Lizenz, dann könnte es auch durchaus sein, dass meine Chefin sparen wollte...

Aber die Links sind super, ich schau' morgen mal, wie ich verclsid.exe loswerde.
kweber
 
Posts: 7
Joined: 01. September 2010 08:00

Re: XAMPP braucht über eine halbe Stunde zum Starten

Postby Nobbie » 02. September 2010 21:01

Wieso beschäftigen wir uns hier eigentlicht mit firmeninternen Problemen? Sag Deinem Chef, mein Rechner ist Schrott, so kann ich nicht arbeiten. Dieses Forum ist ganz sicher nicht der richtige Ansprechpartner.
Nobbie
 
Posts: 8779
Joined: 09. March 2008 13:04

Re: XAMPP braucht über eine halbe Stunde zum Starten

Postby kweber » 02. September 2010 21:59

Mist, jetzt hab' ich das ganze Zeug zu Forumregeln gelesen und steh' trotzdem im Fettnapf. Sorry. War mir halt zu Beginn nicht klar, dass es ein firmeninternes Problem ist.
kweber
 
Posts: 7
Joined: 01. September 2010 08:00

Re: XAMPP braucht über eine halbe Stunde zum Starten

Postby kweber » 10. November 2010 09:36

Ich habe heute im Rahmen einer allgemeinen Aufräumaktion ein paar Programme deinstalliert und nun startet Apache über das XAMPP-Control-Panel wieder wie geschmiert, in Sekundenschnelle. Es muss also an einem Softwarekonflikt gelegen haben, ich kann aber nicht genau sagen, wo der genau lag. Folgende Programme kommen als "Konfliktpartner" in Frage:
Go to Meeting (Citrix), iTunes (Apple), ein Free PDF Writer (eher unwahrscheinlich?), zwei XML Editoren (eher unwahrscheinlich?), Nero Burn Rights
kweber
 
Posts: 7
Joined: 01. September 2010 08:00


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 5 guests