MySQL geht nicht?

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

MySQL geht nicht?

Postby Patrick1704 » 31. August 2010 21:27

Hallo ich habe das problem wenn ich bei xampp mein forum aufrufen will geht es nicht weil ich keinen zugriff bekomme und wenn ich phpMyAdmin aufrufe steht dan das:
Code: Select all
Fehler

MySQL meldet: Dokumentation
#1045 - Access denied for user 'root'@'localhost' (using password: NO)
phpMyAdmin hat versucht eine Verbindung zum MySQL-Server aufzubauen, jedoch hat dieser die Verbindung zurückgewiesen. Sie sollten Ihre Einstellungen für Host, Benutzername und Passwort in Ihrer config.inc.php überprüfen und sich vergewissern, dass diese den Informationen, welche Sie vom Administrator erhalten haben, entsprechen.

Der quellcode der config.inc.php datei:

Code: Select all
<?php /* * This is needed for cookie based authentication to encrypt password in * cookie / $cfg['blowfish_secret'] = 'xampp'; / YOU SHOULD CHANGE THIS FOR A MORE SECURE COOKIE AUTH! */

/* * Servers configuration */ $i = 0;

/* * First server */ $i++;

/* Authentication type and info */ $cfg['Servers'][$i]['auth_type'] = 'config'; $cfg['Servers'][$i]['user'] = 'root'; $cfg['Servers'][$i]['password'] = ''; $cfg['Servers'][$i]['AllowNoPassword'] = true;

/* Server parameters */ $cfg['Servers'][$i]['host'] = 'localhost'; $cfg['Servers'][$i]['connect_type'] = 'tcp'; $cfg['Servers'][$i]['compress'] = false;

/* Select mysqli if your server has it */ $cfg['Servers'][$i]['extension'] = 'mysqli';

/* User for advanced features */ $cfg['Servers'][$i]['controluser'] = 'pma'; $cfg['Servers'][$i]['controlpass'] = '';

/* Advanced phpMyAdmin features */ $cfg['Servers'][$i]['pmadb'] = 'phpmyadmin'; $cfg['Servers'][$i]['bookmarktable'] = 'pmabookmark'; $cfg['Servers'][$i]['relation'] = 'pmarelation'; $cfg['Servers'][$i]['tableinfo'] = 'pmatableinfo'; $cfg['Servers'][$i]['tablecoords'] = 'pmatablecoords'; $cfg['Servers'][$i]['pdfpages'] = 'pmapdfpages'; $cfg['Servers'][$i]['columninfo'] = 'pmacolumninfo'; $cfg['Servers'][$i]['history'] = 'pmahistory'; $cfg['Servers'][$i]['designercoords'] = 'pmadesignercoords';

/* * End of servers configuration */

/* * Directories for saving/loading files from server */ $cfg['UploadDir'] = ''; $cfg['SaveDir'] = '';

$cfg['AllowAnywhereRecoding'] = true; $cfg['DefaultCharset'] = 'utf-8'; $cfg['DefaultLang'] = 'en-utf-8'; $cfg['DefaultConnectionCollation'] = 'utf8generalci';

$cfg['MySQLManualBase'] = 'http://dev.mysql.com/doc/refman/5.1/en'; $cfg['MySQLManualType'] = 'searchable';

?>

Was muss ich machen das es wider geht?
Gestern ging alles noch Tipp Top!
Patrick1704
 
Posts: 26
Joined: 31. August 2010 16:50

Re: MySQL geht nicht?

Postby Patrick1704 » 01. September 2010 09:38

Bitte kan mir keiner helfen?
Patrick1704
 
Posts: 26
Joined: 31. August 2010 16:50

Re: MySQL geht nicht?

Postby Altrea » 01. September 2010 09:50

Ich kann dir nur sagen, wo das Problem liegt:

der XAMPP user root hat ein Passwort verpasst bekommen (wieso und weshalb solltest du wissen. Wenn du das nicht weißt, würde ich mir Gedanken machen, wer oder was das Passwort noch geändert haben könnte. Von alleine ändert es sich in der Regel nicht.).
Deshalb funktioniert der Verbindungsaufruf ohne Passwort nicht und das produziert diese Fehlermeldung.

Das neue Passwort kann niemand von uns wissen, demzufolge kann dir auch niemand wirklich helfen.
Das einzige was du noch tun könntest wäre, das resetroot.bat-Script im mysql Ordner auszuführen, um das root Kennwort zurückzusetzen.

Das ist aber nicht wirklich eine Lösung, denn wenn sich dein root-Kennwort einfach so ohne dein zutun ändert, kann dies auch immer wieder passieren. Deshalb solltest du an der Ursache arbeiten, und dabei kann dir wie gesagt niemand helfen.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8294
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: MySQL geht nicht?

Postby Nobbie » 01. September 2010 10:01

Ist Dein Forum "öffentlich" erreichbar, oder nur zu Hause (lokal)?
Nobbie
 
Posts: 8775
Joined: 09. March 2008 13:04

Re: MySQL geht nicht?

Postby Patrick1704 » 01. September 2010 10:06

lokal
habs auf 127.0.0.1
wenn ich die resetroot aufrufe kommt das:
Code: Select all
C:\xampp\mysql>resetroot
100901 11:07:40 [Warning] Can't create test file \usr\local\mysql\data\AcerAspir
e5538G.lower-test
100901 11:07:40 [Warning] Can't create test file \usr\local\mysql\data\AcerAspir
e5538G.lower-test
mysql\bin\mysqld.exe: Can't change dir to '\usr\local\\mysql\data\' (Errcode: 2)

100901 11:07:40 [ERROR] Aborting

100901 11:07:40 [Note] mysql\bin\mysqld.exe: Shutdown complete


Passwoerter fuer Benutzer "root" und "pma" wurden nicht geloescht!
Passwords for user "root" and "pma" were not deleted!

Drücken Sie eine beliebige Taste . . .

C:\xampp\mysql>u musst im Admin MySql Freigeben du hast Ihn wohl schreib und Les
e geschützt!

Kann es sein das das alles nicht geht weil es schreibgeschützt ist?
Wenn ja:
Wie kann ich den schreib und lese schutz entfernen?
Patrick1704
 
Posts: 26
Joined: 31. August 2010 16:50

Re: MySQL geht nicht?

Postby Nobbie » 01. September 2010 12:15

Die Fehlermeldungen sehen so aus, als würde für MySQL eine falsche Konfigurationsdatei herangezogen (mit Linux Pfaden anstelle von Windows Pfaden). Entweder hast Du die my.ini aus dem mysql/bin Ordner zerschossen, oder MySQL wird so aufgerufen, dass es eine andere Konfigurationsdatei lädt.
Nobbie
 
Posts: 8775
Joined: 09. March 2008 13:04

Re: MySQL geht nicht?

Postby Patrick1704 » 01. September 2010 12:35

Ja und was muss ich jetzt machen?
Der eine sagt es könnte sein das die lese und schreibrecht fehlen der andere sagt das das es was falsches läd!
*Heul* *Verzweifel*
Also kan mir jetzt einer geau sagen was ich tun soll?
Oder sollte ich XAMPP neu installieren?
Aber wenn ich das mache gehen dan die foren und die sachen die ich per datenbank installiert habe noch? :?: :?: :?: :?:
Edit: Ich habe gerade gemerkt als ich testen wollte ob es geht und MySQL abgeschaltet habe und wieder einschalten wollte das es nicht einschalten geht!
Ist XAMPP jetzt ganz am Ar*** :?: :?: :?:
Patrick1704
 
Posts: 26
Joined: 31. August 2010 16:50

Re: MySQL geht nicht?

Postby Nobbie » 01. September 2010 13:14

Patrick1704 wrote:Ja und was muss ich jetzt machen?


Ruhe bewahren und nicht so blöd herum heulen. Du hast selbst irgendeinen Scheiß gebaut, das ist aus der Entfernung nicht so ganz einfach zu beheben - aber wir arbeiten ja daran.

Patrick1704 wrote:Also kan mir jetzt einer geau sagen was ich tun soll?


S.o. - erst einmal Ruhe bewahren.

Patrick1704 wrote:Oder sollte ich XAMPP neu installieren?


NEIN!! Das machen nur Idioten, dann ist nämlich GANZ SICHER ALLES KAPUTT!

Patrick1704 wrote:Aber wenn ich das mache gehen dan die foren und die sachen die ich per datenbank installiert habe noch? :?: :?: :?: :?:


Siehst Du - genau das. Deswegen: Ruhe bewahren.

Patrick1704 wrote:Edit: Ich habe gerade gemerkt als ich testen wollte ob es geht und MySQL abgeschaltet habe und wieder einschalten wollte das es nicht einschalten geht!
Ist XAMPP jetzt ganz am Ar*** :?: :?: :?:


Das überrascht mich gar nicht - im Gegenteil: es bestätigt meine Vermutung, dass die Konfigurationsdatei "kaputt" ist (überschrieben, gelöscht, verschoben - irgendetwas).

Das kriegen wir heraus, nur keine Hektik. Jetzt beantwortest Du erst einmal ein paar Fragen:

a) wo (in welchem Ordner) hast Du Xampp installiert?
b) gehe dort in den Unterordner "mysql" und von dort weiter in den Ordner "bin". Lass Dir die Dateien im Explorer anzeigen: gibt es eine Datei mit dem Namen "my.ini"? Evtl. werden bei Dir die Extensions (*.ini) nicht angezeigt, dann siehst Du nur "my" und als Beschreibung irgendwie "Konfiguration" o.ä.
c) wenn es diese Datei gibt: dann öffne sie mit einem Editor (Notepad zur Not), kopiere den kompletten Inhalt und stelle ihn hier in das Forum (in "Code" Tags eingepackt, das ist der 5. Button oben von links gesehen).
d) wie startest Du Xampp bzw. MySQL?
e) ist MySQL als Dienst (Service) installiert?
Last edited by Nobbie on 01. September 2010 13:16, edited 1 time in total.
Nobbie
 
Posts: 8775
Joined: 09. March 2008 13:04

Re: MySQL geht nicht?

Postby kweber » 01. September 2010 13:15

Patrick1704 wrote:Ja und was muss ich jetzt machen?
Der eine sagt es könnte sein das die lese und schreibrecht fehlen der andere sagt das das es was falsches läd!
*Heul* *Verzweifel*


Hallo Patrick,

ich bin hier auch Newbie, würde mich aber nicht drüber beschweren, dass der eine sagt, es könnte dies, der andere sagt, es könnte jenes sein. So sind Computerprobleme nun mal. Meines Erachtens wäre die richtige Reaktion auf Deine Frage "Ja und was muss ich jetzt machen?": Beides mal ausprobieren.
Auch wenn es natürlich zum Heulen und Verzweifeln ist, das kann ich schon verstehen...
kweber
 
Posts: 7
Joined: 01. September 2010 08:00

Re: MySQL geht nicht?

Postby Patrick1704 » 01. September 2010 13:30

Danke für eure hilfe,ich bin echt foh das ihr mir helft den ich habe das glaub ich im Blut das alles schiff geht.
Also:
a) im ordner Acer(C:)/xampp
b)ja hab ich
c)
Code: Select all
# Example MySQL config file for medium systems.
#
# This is for a system with little memory (32M - 64M) where MySQL plays
# an important part, or systems up to 128M where MySQL is used together with
# other programs (such as a web server)
#
# You can copy this file to
# /etc/my.cnf to set global options,
# mysql-data-dir/my.cnf to set server-specific options (in this
# installation this directory is @localstatedir@) or
# ~/.my.cnf to set user-specific options.
#
# In this file, you can use all long options that a program supports.
# If you want to know which options a program supports, run the program
# with the "--help" option.

# The following options will be passed to all MySQL clients
[client]
#user        = your_username
#password   = your_password
host        = .
port        = 3306
socket        = "MySQL"

# Here follows entries for some specific programs

# The MySQL server
[mysqld]
basedir                 = "C:/xampp/mysql/"
datadir                 = "C:/xampp/mysql/data/"
port                    = 3306
socket                    = "MySQL"
skip-locking
key_buffer              = 16M
max_allowed_packet      = 1M
table_cache             = 64
sort_buffer_size        = 512K
net_buffer_length       = 8K
read_buffer_size        = 256K
read_rnd_buffer_size    = 512K
myisam_sort_buffer_size = 8M

default-time-zone       = "Europe/Paris"

log_error           = "C:/xampp/mysql/data/mysql.err"
pid_file            = "mysql.pid"
general_log         = 0
general_log_file    = "C:/xampp/mysql/data/mysql.log"
slow_query_log      = 0
slow_query_log_file = "C:/xampp/mysql/data/mysql-slow.log"

# Don't listen on a TCP/IP port at all. This can be a security enhancement,
# if all processes that need to connect to mysqld run on the same host.
# All interaction with mysqld must be made via Unix sockets or named pipes.
# Note that using this option without enabling named pipes on Windows
# (via the "enable-named-pipe" option) will render mysqld useless!
#
#skip-networking
enable-named-pipe

# Disable Federated by default
skip-federated

# Replication Master Server (default)
# binary logging is required for replication
#log-bin = mysql-bin

# binary logging format - mixed recommended
#binlog_format = mixed

# required unique id between 1 and 2^32 - 1
# defaults to 1 if master-host is not set
# but will not function as a master if omitted
server-id = 1

# Replication Slave (comment out master section to use this)
#
# To configure this host as a replication slave, you can choose between
# two methods :
#
# 1) Use the CHANGE MASTER TO command (fully described in our manual) -
#    the syntax is:
#
#    CHANGE MASTER TO MASTER_HOST=<host>, MASTER_PORT=<port>,
#    MASTER_USER=<user>, MASTER_PASSWORD=<password> ;
#
#    where you replace <host>, <user>, <password> by quoted strings and
#    <port> by the master's port number (3306 by default).
#
#    Example:
#
#    CHANGE MASTER TO MASTER_HOST='125.564.12.1', MASTER_PORT=3306,
#    MASTER_USER='joe', MASTER_PASSWORD='secret';
#
# OR
#
# 2) Set the variables below. However, in case you choose this method, then
#    start replication for the first time (even unsuccessfully, for example
#    if you mistyped the password in master-password and the slave fails to
#    connect), the slave will create a master.info file, and any later
#    change in this file to the variables' values below will be ignored and
#    overridden by the content of the master.info file, unless you shutdown
#    the slave server, delete master.info and restart the slaver server.
#    For that reason, you may want to leave the lines below untouched
#    (commented) and instead use CHANGE MASTER TO (see above)
#
# required unique id between 2 and 2^32 - 1
# (and different from the master)
# defaults to 2 if master-host is set
# but will not function as a slave if omitted
#server-id       = 2
#
# The replication master for this slave - required
#master-host     = <hostname>
#
# The username the slave will use for authentication when connecting
# to the master - required
#master-user     = <username>
#
# The password the slave will authenticate with when connecting to
# the master - required
#master-password = <password>
#
# The port the master is listening on.
# optional - defaults to 3306
#master-port     = <port>
#
# binary logging - not required for slaves, but recommended
#log-bin         = mysql-bin

# Point the following paths to different dedicated disks
tmpdir             = "C:/xampp/tmp/"
#log-update      = "C:/xampp/tmp/mysql"

# Uncomment the following if you are using InnoDB tables
#skip-innodb
innodb_data_home_dir            = "C:/xampp/mysql/data/"
innodb_data_file_path           = ibdata1:10M:autoextend
innodb_log_group_home_dir       = "C:/xampp/mysql/data/"
# You can set .._buffer_pool_size up to 50 - 80 %
# of RAM but beware of setting memory usage too high
innodb_buffer_pool_size         = 16M
innodb_additional_mem_pool_size = 2M
# Set .._log_file_size to 25 % of buffer pool size
innodb_log_file_size            = 5M
innodb_log_buffer_size          = 8M
innodb_flush_log_at_trx_commit  = 1
innodb_lock_wait_timeout        = 50

[mysqldump]
quick
max_allowed_packet = 16M

[mysql]
no-auto-rehash
# Remove the next comment character if you are not familiar with SQL
#safe-updates

[isamchk]
key_buffer = 20M
sort_buffer_size = 20M
read_buffer = 2M
write_buffer = 2M

[myisamchk]
key_buffer = 20M
sort_buffer_size = 20M
read_buffer = 2M
write_buffer = 2M

[mysqlhotcopy]
interactive-timeout

d)ich öffne die XAMPP Panel application(xampp_start) und dan drücke ich bei MySQL und die anderen start
e)wie merke ich das? Wie gesagt gestern ging alles ich hab alles installiert und nichts gelöscht.
Ps:Ich habe gerade gemerkt ich kann MySQL doch wieder starten aber das mit dem datenbank ereichen geht wie gesagt immer noch nicht!
Ich bekomme keinen zugriff: es steht zugriff verwigert
Patrick1704
 
Posts: 26
Joined: 31. August 2010 16:50

Re: MySQL geht nicht?

Postby Nobbie » 01. September 2010 13:53

Aha, also MySQL geht noch. Die Konfigurationsdatei ist richtig, das Problem liegt u.a. bei resetroot.bat, das Script ist fehlerhaft. Kannst Du nicht benutzen.

Weitere Fragen:

a) hast Du im Xampp irgendwelche neuen Benutzer für MySQL angelegt? Oder irgendeinen bestehen Benutzer gelöscht? Oder ein Passwort geändert?
b) gehe mit dem Explorer nach C:/xampp/mysql/data/mysql - da stehen jede Menge Dateien. Einige von denen heißen "user.frm" und "user.MYD" und "user.MYI". Welches Änderungsdatum zeigt Explorer für diese Dateien an?
Nobbie
 
Posts: 8775
Joined: 09. March 2008 13:04

Re: MySQL geht nicht?

Postby Nobbie » 01. September 2010 14:12

Ich habe inzwischen auch die resetroot.bat durchgeschaut, da muss eine Zeile angepasst werden, dann funktioniert die auch wieder.

Auf Zeile 18 steht dieser mysqld.exe Aufruf:

Code: Select all
mysql\bin\mysqld.exe --no-defaults --bind-address=127.0.0.1 --bootstrap --console --skip-grant-tables --skip-innodb --standalone <resetroot.sql  >resetroot.err 2>&1


Das funktioniert nicht, weil das Datenverzeichnis von MySQL nicht gefunden wird. Man muss noch eine Option angeben, damit das gefunden wird. Für eine Installation in c:/xampp lautet die richtige Anweisung so

Code: Select all
mysql\bin\mysqld.exe --no-defaults --datadir=c:/xampp/mysql/data --bind-address=127.0.0.1 --bootstrap --console --skip-grant-tables --skip-innodb --standalone <resetroot.sql  >resetroot.err 2>&1


Also einfach hinter dem "--no-defaults" noch die Option "--datadir=c:/xampp/mysql/data" einfügen. Dazu muss man resetroot.bat nur editieren, diese Option einfügen (natürlich ohne die Gänsefüßchen und mit Leerstelle davor und dahiner) und abspeichern. Anschließend resetroot.bat ausführen, das setzt nun für "root" und "pma" die Passwörter wieder zurück (die haben dann kein Passwort mehr, wie es auch in der Anfangseinstellung von Xampp ist).
Nobbie
 
Posts: 8775
Joined: 09. March 2008 13:04

Re: MySQL geht nicht?

Postby Patrick1704 » 01. September 2010 14:15

also:
a) nein nicht das ich wüste aber ich weiß nichteinmal wie das geht!
b)ich glub hier ist das problem:
user.frm:19.12.2009
user.MYD: 30.8.2010 20:18
user.MYI:30.8.2010 20:29
Patrick1704
 
Posts: 26
Joined: 31. August 2010 16:50

Re: MySQL geht nicht?

Postby Patrick1704 » 01. September 2010 14:27

Danke danke danke danke es geht hab alles zurückgesetzt und es geht!!!
Also das problemm war das das passwort geändert wurde,oder?
Aber wie kan man das machen? Das passwort ändern?
Ich hab das nicht mit absicht gemacht.
Aber:
Danke nochmal! :) :) :) :D :D :lol: :lol: :lol: :lol: :lol:
:lol: :lol: :lol: :lol: :lol: :lol: :lol: :P :P :P :P :P :P :P :o :o :o :D :D :D :D :D
:lol: :lol: :lol: :lol: :lol: :lol:
Patrick1704
 
Posts: 26
Joined: 31. August 2010 16:50

Re: MySQL geht nicht?

Postby Nobbie » 01. September 2010 15:00

Patrick1704 wrote:Aber wie kan man das machen? Das passwort ändern?


Vielleicht ist Dein Rechner vom Internet aus zu erreichen? Wie bist Du angeschlossen? Hast Du einen Router? Oder bist Du direkt angeschlossen?

Sonst überlege mal, was Du am 30.08. (vorgestern) abends um 20.30 Uhr ungefähr am Rechner getan hast?!
Nobbie
 
Posts: 8775
Joined: 09. March 2008 13:04

Next

Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 17 guests