Neuling mit Installationsproblemen

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Neuling mit Installationsproblemen

Postby MiBe » 23. August 2010 16:01

Hallo,
bin xampp/Jooomla-Neuling und komme nicht weiter:
unter Win7 64Bit soll eine lokale Entwicklungsumgebung unter xampp-win32-1.7.3 und Joomla_1.5.20-Stable-Full_Package_German entstehen. Beide Anwendungen lassen sich prinzipiell sauber und glatt installieren. Es scheint kein Problem zu sein, xampp-win32-1.7.3 auf Win7 64Bit zu installieren.

Problem: habe mich bei der Installation an ein Buch (Joomla! 1.5 für Einsteiger, Galileo Computing) gehalten. Dort wurde empfohlen, xampp nach c:/apachefriends/xampp zu installieren - wobei nicht vermittelt wurde, dass das Verzeichnis /xampp automatisch angelegt wird und /apachefriends im Vorfeld nicht. Somit ergab sich nach der Installation ein Verzeichnispfad c:/apachefriends/xampp/xampp. Nach einigen Versuchen gelang es mir, durch Eingabe "localhost" die xampp-Startseite "XAMPP für Windows" zu öffnen, der Start von Apache und MySQL wurde mit "running" quittiert. Bis dahin war es leicht holprig aber erfolgreich.
Lt. Buch sollte nun das Joomla-Package in c:/apachefriends/xampp/htdocs entpackt werden. Da das Verzeichnis /htdocs nicht vorhanden ist, schien c:/apachefriends/xampp/xampp/htdocs naheliegend. Darin sollte sich nun der Verzeichnispfad c:/apachefriends/xampp/xampp/htdocs/joomla ergeben. Der Start von Joomla gelang, ebenso die Installation. Jedoch konnte Joomla mit localhost/joomla noch mit localhost/joomla/administrator NICHT gestartet werden.

Da die Tatsache, zweier aufeinanderfolgender Verzeichnispfade /xampp/xampp mir seltsam vorkam, löschte ich das Verzeichnis c:/apachefriends komplett (via Explorer) und installierte xampp neu. Wobei ich (man lernt ja dazu) nicht mehr c:/apachefriends/xampp als Verzeichnis vorgab (sonst wäre ja wieder /xampp/xampp das Resultat) sondern lediglich c:/apachefriends. Beim Start von Apache als auch MySQL kann ich nun jedoch KEIN "running" mehr erzielen.

Also das Verzeichnis c:/apachefriends erneut gelöscht und bei der xampp-Installation gar keinen Verzeichnispfad angegeben. Hätte ja sein können, dass die Installation den Pfad c:/apachefriends/xampp automatisch einträgt. Nun beginnt die Installation natürlich in c:/xampp. Was vielleicht noch nicht mal ein Problem darstellen könnte (wobei ich das nicht weiß), jedoch erziele ich hierbei ebenfalls kein "running" mehr.

Komme da nicht weiter. In der Vergangenheit (wohl so 3-4 Jahre her) hatte ich schonmal eine Entwicklungsumgebung aufgesetzt. Diese war problemlos und eindeutig. Bei der anschließenden Recherche habe ich irgendwo einen hinweis gefunden, dass man unter Windows nicht einfach so das entsprechende Verzeichnis löschen kann, man muss wohl explizit die Deinstallationsroutine fahren. Unter XAMPP habe ich keine Deinstallationsroutine gefunden, bei Windows ist unter Systemsteuerung/Programme_und_Funktionen XAMPP nicht eingetragen.

Frage:
- ist XAMPP und Joomla tatsächlich komplett gelöscht, wenn das Verzeichnis c:/apachefriends/... gelöscht wird?
- ... oder muss ich da "anders" deinstallieren. Wenn, wie?
- Wie kriege ich eine neue bzw. saubere Installation hin?
- Worin lag mein Fehler bei der a) XAMPP-Installation und b) Joomla-Installation?

Vielen Dank für verständliche, gut nachvollziehbare und weiterführende Tipps!

MiBe
MiBe
 
Posts: 5
Joined: 23. August 2010 14:48

Re: Neuling mit Installationsproblemen

Postby glitzi85 » 23. August 2010 16:12

OK, fangen wir erstmal mit einer sauberen Deinstallation an. Prinzipiell ist es richtig, einfach den kompletten Ordner zu löschen. Allerdings nur, falls keines der Programme mehr läuft und kein Dienst installiert ist.
Solltest du jetzt irgendwo noch eine XAMPP-Installation auf der Platte haben, diese mal löschen. Dann den Rechner neu starten (wichtig!). Dann auf Start -> Ausführen -> services.msc eingeben und auf OK -> In dem Fenster nach Apache und/oder MySQL suchen. Solltest du sowas finden, dann bitte unbedingt melden. Ansonsten kannst du jetzt mit einer Neuinstallation von XAMPP beginnen. Einfach den Installer starten und den Pfad so lassen wie er ist. Danach solltest du dann ein Lauffähiges XAMPP haben.

mfg glitzi
User avatar
glitzi85
 
Posts: 1920
Joined: 05. March 2004 23:26
Location: Dahoim

Re: Neuling mit Installationsproblemen

Postby MiBe » 23. August 2010 16:34

Hi glitzi85! Vorab Danke!
Ok, ich gehe gleich mal so vor, wie von Dir beschrieben. Vielleicht aber vorab noch kurz zu meinem Verständnisproblem:
glitzi85 wrote:Ansonsten kannst du jetzt mit einer Neuinstallation von XAMPP beginnen. Einfach den Installer starten und den Pfad so lassen wie er ist. Danach solltest du dann ein Lauffähiges XAMPP haben.

...und so lassen wie er ist?!? Schon klar, ich gehe da mal ganz nach dem Büchlein vor ... also ich gebe im Verzeichnispfad "c:/apachefriends" ein und die Installationsroutine macht mir dann "c:/apachefriends/xampp" daraus? Und darin finde ich dann das ebenfalls automatisch erstellte Verzeichnis ../htdocs in welchem ich dann manuell ein Verzeichnis "Joomla" anlege oder geschieht dies automatisch, dass die Extraktion das Verzeichnis "Joomla" in ../htdocs anlegt und in "Joomla" auch hinein-extrahiert wird?
Ohjee, hoffentlich könnt ihr folgen? :oops:
MiBe
MiBe
 
Posts: 5
Joined: 23. August 2010 14:48

Re: Neuling mit Installationsproblemen

Postby glitzi85 » 23. August 2010 16:43

OK, ist auch kein Problem XAMPP woanders hin zu installieren.

Nur zum Verständnis: Das htdocs-Verzeichnis im xampp-Ordner bedeutet dein Root. Das bedeutet:

C:\xampp\htdocs\joomla = http://localhost/joomla
C:\apachefriends\xampp\htdocs\joomla = http://localhost/joomla

Egal wo du XAMPP hin installierst, der htdocs-Ordner ist immer dein Ausgangspunkt!

Hab mir grad mal Joomla gezogen. Du erstellst einen Ordner joomla innerhalb von htdocs und da hinein entzippst du dann das Joomla-Zip. Allerdings direkt da rein, nicht wieder in einen Unterordner (viele Zip-Programme haben da einen extra Menüeintrage, um den ganzen Inhalt in einen neuen Ordner zu extrahieren - das nicht!).
Nun solltest du im Joomla-Ordner 13 Ordner (components, images...) und 11 Dateien (CHANGELOG.php, configuration.php-dist...) haben. Dann einfach die Installation über http://localhost/joomla/ beginnen.

mfg glitzi
User avatar
glitzi85
 
Posts: 1920
Joined: 05. March 2004 23:26
Location: Dahoim

Re: Neuling mit Installationsproblemen

Postby MiBe » 23. August 2010 17:04

Ich glaube, langsam wird der Ball rund :D

Vielleicht vorab noch 2 Fragen zu ...
glitzi85 wrote:OK, ist auch kein Problem XAMPP woanders hin zu installieren.
Nur zum Verständnis: Das htdocs-Verzeichnis im xampp-Ordner bedeutet dein Root. Das bedeutet:
C:\xampp\htdocs\joomla = http://localhost/joomla
C:\apachefriends\xampp\htdocs\joomla = http://localhost/joomla

Aha! Ist also vollkommen Wurscht, ob das übergeordnete Verzeichnis "apachefriends" existent ist oder nicht? Das Verzeichnis "xampp\.." könnte theoretisch auch unter c:\karotte\apfel\birne\xampp liegen?

Und ... ist es richtig, wenn ich sage, das letzte "joomla" in "c:\xampp\htdocs\joomla" könnte auch "c:\xampp\htdocs\Proj01", "c:\xampp\htdocs\Proj02", "c:\xampp\htdocs\Proj03" usw. heißen? Also ein Verzeichnis für ein bestimmtes Joomla- oder sonstwelches Projekt sein? Nur zum ... Verständnis! Ich könnte dann also mit der Browsereingabe "localhost/proj01", "localhost/proj02" usw. verschiedene Projekte ansprechen und bearbeiten, oder? Würde also in jedes dieser Verzeichnisse Joomla wieder jungfräulich frisch hineinextrahieren und bearbeiten. Wäre dies die richtige Vorgehensweise? Natürlich sollte dann für jedes Projekt eine eigene Datenbank angelegt werden, oder? (aber hierzu später ggfs. mehr ... Nachfragen meinerseits :) )
MiBe
 
Posts: 5
Joined: 23. August 2010 14:48

Re: Neuling mit Installationsproblemen

Postby MiBe » 23. August 2010 18:57

Hi glitzi85!
Hat alles wunderbar geklappt. Unter services.msc war nix zu finden, Installation problemlos, Apache + MySQL = RUNNING. Habe Joomla in c:\xampp\htdocs\#001 entpackt (habe den Ordner also nicht "joomla" genannt, macht das was? Ist das zwingend?). Somit finden sich im Ordner "htdocs" nun 2 Dateien (index.html + index.php) sowie 2 Ordner (#001 + xampp). Gebe ich "localhost" ein, wird aus der Browserzeile "http://localhost/xampp/" und das gewünschte "XAMPP-für-Windows-Fenster" wird angezeigt. Alles bestens!

MiBe wrote:Nun solltest du im Joomla-Ordner 13 Ordner (components, images...) und 11 Dateien (CHANGELOG.php, configuration.php-dist...) haben.

Im Ordner "#001" finden sich nach der Installation aber nun 15 (!) Ordner und 11 Dateien - nicht 13 Ordner wie bei Dir!?! Diese beginnen namentlich mit "administrator" und "cache", gefolgt von "components", "images" usw. wie von Dir aufgelistet. Findest Du die beiden erstgenannten Ordner bei Dir auch?

MiBe wrote:Dann einfach die Installation über http://localhost/joomla/ beginnen.

Bei der anschließenden Eingabe von "localhost/#001" (in Anlehnung an localhost/joomla) ändert sich die Browserzeile in "http://localhost/xampp/#001" und das eben beschriebene "XAMPP-für-Windows-Fenster" erscheint?!?

Bin ratlos :cry:
MiBe
 
Posts: 5
Joined: 23. August 2010 14:48

Re: Neuling mit Installationsproblemen

Postby Nobbie » 23. August 2010 19:15

MiBe wrote:Bei der anschließenden Eingabe von "localhost/#001" (in Anlehnung an localhost/joomla) ändert sich die Browserzeile in "http://localhost/xampp/#001" und das eben beschriebene "XAMPP-für-Windows-Fenster" erscheint?!?


Was logisch ist, denn das #-Symbol hat eine eklatante Sonderbedeutung im HTML Umfeld, es dient dazu, den Browser auf bestimmte "Anker" zu positionieren. Du hast ein besonderes Talent, schneller in Fettnäpfchen zu latschen als man sie aufstellen kann. Man nennt Ordner nicht so chaotisch mit # am Anfang. Nimm einen normalen Namen (wie wäre es mit "Ordner01") und es funktioniert.

Und außerdem lies mal ein wenig Doku zu HTML und was es bedeutet, in der URL ein # anzugeben.
Nobbie
 
Posts: 8770
Joined: 09. March 2008 13:04

Re: Neuling mit Installationsproblemen

Postby glitzi85 » 23. August 2010 19:50

Nobbie hat ja das meiste schon geschrieben. Sonderzeichen in Ordnernamen sind immer schlecht. Dass die Anzahl der Ordner unterschiedlich ist könnte daran liegen, dass du die Deutsche version hast und ich ne Englische. Solange es funktioniert ist es ja aber auch egal.

Wichtig ist noch, dass jede Joomla-Installation ihre eigene Datenbank benötigt. Sonst beeinflussen sie sich gegenseitig (außer natürlich da ist gewünscht, weil man mit dem gleichen Datenbestand mehrere Themes entwickelt oder so).

mfg glitzi
User avatar
glitzi85
 
Posts: 1920
Joined: 05. March 2004 23:26
Location: Dahoim

Re: Neuling mit Installationsproblemen

Postby MiBe » 23. August 2010 20:06

@glitzi85
@nobbie

Vielen Dank! Nun hat alles bestens geklappt.
Gruß MiBe
MiBe
 
Posts: 5
Joined: 23. August 2010 14:48


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 19 guests