Xampp unter Windows 7 64 bit

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Xampp unter Windows 7 64 bit

Postby Racer93 » 15. August 2010 22:07

Hallo,
ich habe gerade Windows 7 Ultimate 64 bit installiert und möchte nun auch wieder mit xampp arbeiten(war sehr zufrieden^^).
Ich habe von vielen Leuten gehört, dass es bei ihnen ohne Probleme unter win7 64 bit lief.

Nun habe ich xampp in C:\Programme(x86) installiert, das Control Panel startet, aber wenn ich bei Apache auf "Start" gehe, dann erscheint ganz kurz das grüne Label "Running", dann verschwindet es wieder. MySql startet, aber der Apache funktioniert einfach nicht.

Mache ich etwas falsch?

Wäre echt für jede Hilfe dankbar und bedanke mich auch schon im Voraus :D
Racer93
 
Posts: 3
Joined: 15. August 2010 22:02

Re: Xampp unter Windows 7 64 bit

Postby Altrea » 15. August 2010 22:33

- XAMPP Installationsdatei "als Administrator ausführen" (Rechtsklick Kontextmenu)
- XAMPP NICHT ins Program Files (x86) Verzeichnis installieren, sondern direkt unter C:\
- XAMPP Control Panel ebenfalls "als Administrator ausführen"

sollte Apache wider erwarten immernochnicht starten:
- Apache als Windows Service regististrieren
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8294
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Xampp unter Windows 7 64 bit

Postby Racer93 » 15. August 2010 22:50

Habe die Installations exe mit Rechtsklick->Als admin ausführen geöfnet, als installationspfad C: angegeben. Jetzt liegt die xampp-control.exe unter C:\xampp. Habe dabn rechtsklick auf dieselbe und als admin ausführen. Wie vorher kurz running, dann weg. Habe dann den SvC hacken gesetzt und erneut versucht. Die Error log zeigt:
(OS 10013)Der Zugriff auf einen Socket war aufgrund der Zugriffsrechte des Sockets unzulässig. : make_sock: could not bind to address [::]:80
(OS 10013)Der Zugriff auf einen Socket war aufgrund der Zugriffsrechte des Sockets unzulässig. : make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs
(OS 10013)Der Zugriff auf einen Socket war aufgrund der Zugriffsrechte des Sockets unzulässig. : make_sock: could not bind to address [::]:80
(OS 10013)Der Zugriff auf einen Socket war aufgrund der Zugriffsrechte des Sockets unzulässig. : make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs
(OS 10013)Der Zugriff auf einen Socket war aufgrund der Zugriffsrechte des Sockets unzulässig. : make_sock: could not bind to address [::]:80
(OS 10013)Der Zugriff auf einen Socket war aufgrund der Zugriffsrechte des Sockets unzulässig. : make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs


EDIT: Beim Portcheck wird auch bei http-apache "process: system" angezeigt

Weißt ja doch iwie auf zugriffsfehler hin, aber ich kenn mich da nich so aus^^. Wenn ich localhost bzw. 127.0.0.1 eingebe kommt dieses IIS, ist das vl das Problem?
Racer93
 
Posts: 3
Joined: 15. August 2010 22:02

Re: Xampp unter Windows 7 64 bit

Postby Racer93 » 15. August 2010 23:22

Also er läuft jetzt!
Ich habe den IIS7 ausgeschaltet, warscheinlich lags am Port. Aber eben auch an vorherigem.

Ich danke dir für deine Hilfe, denn ohne dich hätts ichs nich geschafft ^^
Racer93
 
Posts: 3
Joined: 15. August 2010 22:02

Re: Xampp unter Windows 7 64 bit

Postby Altrea » 16. August 2010 04:51

Nichts zu danken, hauptsache es läuft :D
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8294
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 9 guests