PHP wird nicht angezeigt.

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

PHP wird nicht angezeigt.

Postby Sphinx_77 » 30. July 2010 12:06

Hallo,

ich habe hier ein Problem mit der Anzeige der Php Dateien, glaube ich.

Also ich habe die Startseite aufgerufen mit localhost/uni/main.php
Allerdings kann ich da nur ein Bild sehen, das innerhalb dieser php Datei mit html eingefügt wurde.

Was ich daran nicht verstehe, ist, dass ich diese Probleme mit zwei anderen Notebooks nicht habe. Auf dem Server und auf den beiden anderen Notebooks läuft es einwandfrei.

Meine Main.php sieht folgendermassen aus: (wurde von mir nicht wirklich geschrieben sondern nur an ein oder zwei stellen etwas modifiziert.

Code: Select all
<?
 $page_id=1;
 $secondary_id=0;
 require 'php/config.inc.php';
 require 'php/func.inc.php';
 require "php/conn.php";
 require "php/lang.php";
 require "php/head.php";
 require "php/top.php";
?>

<table cellspacing="0" cellpadding="0" border="0" align="center">
<tr><td width=199 valign=top align=right>
   <img src="Fotos/im/bl.gif" alt="" width=199 height=1><br>
 <br />
 <? require "php/menu.php"; ?> <br />
 <div class=txt_title align=right><?=$tit[$ln][1];?></div>
 <? $n=1;include "php/counter.php"; ?>
 <? $n=2;include "php/counter.php"; ?>
</td>
<td width=1 bgcolor=#999999 valign=top>
<img src="Fotos/im/bl.gif" alt="" width=1 height=1><br></td>
<td width=550  valign=top>
<img  src="Fotos/im/bl.gif" alt="" width=550 height=10><br>
 
 

 <div class=txt_title><?=$tit[$ln][3];?></div>
 <? $rov=1;include "php/update.php"; ?>
 <? $rov=2;include "php/update.php"; ?>
 <div class="txt2" align=right>[ <a href="http://marsrovers.jpl.nasa.gov/mission/status.html"><?=$tit[$ln][5];?></a> ]</div><br>

 <img alt="" src="Fotos/im/job2.jpg" hspace="5">
 <div class=txt_title><?=$tit[$ln][4];?></div>
 <? $t=1;$n=5;include "php/news.php"; ?>
 <div class="txt2" align=right>[ <a href="mer.php"><?=$tit[$ln][6];?></a> ]</div><br>

<div class=txt_title><?=$tit[$ln][7];?></div>
 
 <? $t=2;$n=5;include "php/news.php"; ?>
 <div class="txt2" align=right>[ <a href="archive.php"><?=$tit[$ln][8];?></a> ]</div><br>
 <? if ($ln=="deu") include "htm/Team/group_d.htm";
 else include "htm/Team/group_e.htm"; ?>

<br>
</td></tr>
</table>


<?
 include "php/bottom.php";
?>


Die Seitenquelldatei sieht folgendermassen aus:

Code: Select all
<?
 $page_id=1;
 $secondary_id=0;
 require 'php/config.inc.php';
 require 'php/func.inc.php';
 require "php/conn.php";
 require "php/lang.php";
 require "php/head.php";
 require "php/top.php";
?>

<table cellspacing="0" cellpadding="0" border="0" align="center">
<tr><td width=199 valign=top align=right>
   <img src="Fotos/im/bl.gif" alt="" width=199 height=1><br>
 <br />
 <? require "php/menu.php"; ?> <br />
 <div class=txt_title align=right><?=$tit[$ln][1];?></div>
 <? $n=1;include "php/counter.php"; ?>
 <? $n=2;include "php/counter.php"; ?>

</td>
<td width=1 bgcolor=#999999 valign=top>
<img src="Fotos/im/bl.gif" alt="" width=1 height=1><br></td>
<td width=550  valign=top>
<img  src="Fotos/im/bl.gif" alt="" width=550 height=10><br>
 
 

 <div class=txt_title><?=$tit[$ln][3];?></div>
 <? $rov=1;include "php/update.php"; ?>
 <? $rov=2;include "php/update.php"; ?>
 <div class="txt2" align=right>[ <a href="http://marsrovers.jpl.nasa.gov/mission/status.html"><?=$tit[$ln][5];?></a> ]</div><br>

 <img alt="" src="Fotos/im/job2.jpg" hspace="5">
 <div class=txt_title><?=$tit[$ln][4];?></div>
 <? $t=1;$n=5;include "php/news.php"; ?>
 <div class="txt2" align=right>[ <a href="mer.php"><?=$tit[$ln][6];?></a> ]</div><br>

<div class=txt_title><?=$tit[$ln][7];?></div>
 
 <? $t=2;$n=5;include "php/news.php"; ?>
 <div class="txt2" align=right>[ <a href="archive.php"><?=$tit[$ln][8];?></a> ]</div><br>

 <? if ($ln=="deu") include "htm/Team/group_d.htm";
 else include "htm/Team/group_e.htm"; ?>

<br>
</td></tr>
</table>


<?
 include "php/bottom.php";
?>





Ich denke, dass die anderen php Dateien nicht mit eingebunden werden, sowie die mysql Dateien nicht. Ich habe aber gar keine Ahnung woran das liegen könnte.

Hat jemand eine Idee? Im Fehlercode vom Apache steht nur was von
[Fri Jul 30 12:33:00 2010] [error] [client ::1] File does not exist: C:/xampp/htdocs/uni/im, referer: http://localhost/uni/

Das habe ich aber schon behoben und bezog sich auf die Index.html

Vielen Dank, ich hoffe ich habe nicht etwas total dummes übersehen.
Sphinx_77
 
Posts: 6
Joined: 30. July 2010 06:53

Re: PHP wird nicht angezeigt.

Postby Altrea » 30. July 2010 12:31

Thema short_open_tags.
Trillionen mal gelöst und über die Forensuche findbar.

jedes 2. Thema (gefühlt) handelt davon, weshalb du meinen Unmut gerade vllt verstehen kannst.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8294
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: PHP wird nicht angezeigt.

Postby Sphinx_77 » 30. July 2010 12:39

ich habe in der php.ini im ordner xamp/php die änderungen mit den short open tags geändert auf on

short_open_tag
; Default Value: On
; Development Value: On
; Production Value: On


Oder gibt es da noch eine andere Stelle wo ich das ändern muss?
Auf jeden Fall hat das nichts geholfen.

Das hatte ich vergessen zu schreiben. Aber ich kann deinen Unmut verstehen.:-)
Sphinx_77
 
Posts: 6
Joined: 30. July 2010 06:53

Re: PHP wird nicht angezeigt.

Postby Altrea » 30. July 2010 12:43

Mach die Änderungen bitte wieder Rückgängig.

Die Einstellung ist definiert in Zeile ~226 der php.ini.
Dort muss die Einstellung von Off auf On gewechselt werden.
Und danach ganz wichtig: Apache neustarten.

Zum Schluß noch die Anmerkung: Es wird empfohlen die Einstellung auf Off stehen zu lassen und stattdessen auf short_open_tags zu verzichten (also die vollständige lange Form zu verwenden). Diese Empfehlung ist natürlich nur bei kleineren Webanwendungen wirklich durchsetzbar, wo man nicht mehrere Zehntausend dieser Tags rausschmeißen müsste.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8294
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: PHP wird nicht angezeigt.

Postby Sphinx_77 » 30. July 2010 12:55

ok, habe ich gemacht, ich kann aber leider nicht sehen, ob es geklappt hat, da jetzt der Fehler my sql error kommt:-)

Muss ich da auch noch irgendwo etwas ändern, damit das auch klappt? Das meiste auf der Seite kommt aus dieser Datenbank.

Es tut mir echt leid wegen der Fragen, aber ich weiß echt nicht mehr weiter. Ich habe es jetzt seit Montag irgendwie so versucht, auch indem ich die Einstellungen der anderen beiden Notebooks übernommen hatte, das hatte aber auch nicht geklappt.

Vielen Dank schon mal
Sphinx_77
 
Posts: 6
Joined: 30. July 2010 06:53

Re: PHP wird nicht angezeigt.

Postby Sphinx_77 » 30. July 2010 12:56

sorry, habe es mit dem my sql gefunden. Der hatte ein passwort reingemacht, wovon ich nichts wusste.

Vielen Dank nochmal!!! :D
Sphinx_77
 
Posts: 6
Joined: 30. July 2010 06:53


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 14 guests