Virtual Host Konfiguration

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Virtual Host Konfiguration

Postby goldfisch2k » 27. July 2010 11:28

Hallo Zusammen,

ich habe einige Schwierigkeiten mit der Virtual Host Konfiguration.
Fehlerbild beim Starten:
Code: Select all
Diese Eingabeforderung nicht waehrend des Running beenden
Bitte erst bei einem gewollten Shutdown schliessen
Please close this command only for Shutdown
Apache 2 is starting ...
[Tue Jul 27 12:32:45 2010] [warn] _default_ VirtualHost overlap on port 80, the
first has precedence
(OS 10048)Normalerweise darf jede Socketadresse (Protokoll, Netzwerkadresse oder
 Anschluss) nur jeweils einmal verwendet werden.  : make_sock: could not bind to
 address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs

Apache konnte nicht gestartet werden
Apache could not be started
Drücken Sie eine beliebige Taste . . .


Und hier meine Host Datei:

Code: Select all
<VirtualHost *:80>
    ServerAdmin noreply@DOMAIN.tk
    DocumentRoot /webserver/htdocs/
    ServerName DOMAIN.tk
    ServerAlias wap.DOMAIN.tk
    ServerAlias hs.DOMAIN.eu
    ServerAlias hs.DOMAIN.com
    ErrorLog @rel_logfiledir@/DOMAIN.tk_errlog
    CustomLog @rel_logfiledir@/DOMAIN.tk-access_log common
</VirtualHost>

<VirtualHost *:80>
    ServerAdmin noreply@mailentry.tk
    DocumentRoot /webserver/htdocs/to
    ServerName go.DOMAIN.tk
    ServerAlias to.DOMAIN.tk
    ErrorLog @rel_logfiledir@/go.DOMAIN.tk_errlog
    CustomLog @rel_logfiledir@/go.DOMAIN.tk-access_log common
</VirtualHost>


Ich bin mir nicht sicher, ob hier alle Domains reinmüssen.
Ich möchte soweit alle Domains in /htdocs bis auf einige Außnahmen.
Die Xampp Installation liegt bei mir in d:\webserver
das http Homeverzechnis lautet d:\webserver\htdocs

In der http.conf habe ich den Listen 80 ausgeklammert, jedoch ohne erfolg...
Danach erschien folgende Fehlermeldung:
Code: Select all
Diese Eingabeforderung nicht waehrend des Running beenden
Bitte erst bei einem gewollten Shutdown schliessen
Please close this command only for Shutdown
Apache 2 is starting ...
[Tue Jul 27 12:40:00 2010] [warn] _default_ VirtualHost overlap on port 80, the
first has precedence
(OS 10048)Normalerweise darf jede Socketadresse (Protokoll, Netzwerkadresse oder
 Anschluss) nur jeweils einmal verwendet werden.  : make_sock: could not bind to
 address 0.0.0.0:443
no listening sockets available, shutting down
Unable to open logs

Apache konnte nicht gestartet werden
Apache could not be started
Drücken Sie eine beliebige Taste . . .


Ich habe den Port 80 danach in 8080 in allen Dateien geändert, da oben etwas von einer Kollation stand.
Auch kein Erfolg. Gleicher fehler, abgesehen vom overlap.

Hoffe Ihr habt einen Tipp für mich :-)
goldfisch2k
 
Posts: 19
Joined: 13. August 2008 18:58

Re: Virtual Host Konfiguration

Postby Altrea » 27. July 2010 14:22

Hi,

goldfisch2k wrote:In der http.conf habe ich den Listen 80 ausgeklammert, jedoch ohne erfolg...

Der Apache braucht mindestens einen Port auf den er lauschen kann. Wenn du Port 80 ausklammerst weiß ich nicht, was das fürn Sinn machen soll.

goldfisch2k wrote:Und hier meine Host Datei:

Code: Select all
<VirtualHost *:80>
    ServerAdmin noreply@DOMAIN.tk
    DocumentRoot /webserver/htdocs/
    ServerName DOMAIN.tk
    ServerAlias wap.DOMAIN.tk
    ServerAlias hs.DOMAIN.eu
    ServerAlias hs.DOMAIN.com
    ErrorLog @rel_logfiledir@/DOMAIN.tk_errlog
    CustomLog @rel_logfiledir@/DOMAIN.tk-access_log common
</VirtualHost>

<VirtualHost *:80>
    ServerAdmin noreply@mailentry.tk
    DocumentRoot /webserver/htdocs/to
    ServerName go.DOMAIN.tk
    ServerAlias to.DOMAIN.tk
    ErrorLog @rel_logfiledir@/go.DOMAIN.tk_errlog
    CustomLog @rel_logfiledir@/go.DOMAIN.tk-access_log common
</VirtualHost>


Du möchtest namebased VHosts verwenden. Wo ist deine namevirtualhost Zeile?
Lies dir nochmal die nötigen Passagen in der Doku durch. Alle ServerAliase zu einem VHost kann man zum Beispiel in einer Zeile schreiben.

goldfisch2k wrote:
Code: Select all
[Tue Jul 27 12:32:45 2010] [warn] _default_ VirtualHost overlap on port 80, the
first has precedence

Weil deine namevirtualhost Zeile fehlt, widersprechen sich deine beiden VHosts, weil beide nur auf die IP (in deinem Fall alle IPs) und den Port (in deinem Fall Port 80) lauschen. Das führt dazu, dass IMMER der erste VHost aufgerufen wird, weil dieser immer als Standardhost gilt.

goldfisch2k wrote:
Code: Select all
(OS 10048)Normalerweise darf jede Socketadresse (Protokoll, Netzwerkadresse oder
 Anschluss) nur jeweils einmal verwendet werden.  : make_sock: could not bind to
 address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs

Du hast, neben deinem Apache, noch etwas anderes auf Port 80 lauschen (Skype, IIS, Teamviewer, ...). Deshalb kann dein Apache garnichterst gestartet werden.

goldfisch2k wrote:Ich bin mir nicht sicher, ob hier alle Domains reinmüssen.
Ich möchte soweit alle Domains in /htdocs bis auf einige Außnahmen.

Dann definier dir in deiner VHost Datei den ersten VHost auf dein htdocs verzeichnis (das ist dein Default VHost) und nur den/die darunter lässt du auf bestimmte Servernamen lauschen.

goldfisch2k wrote:Hoffe Ihr habt einen Tipp für mich :-)

Ich hoffe meine Tipps bringen dich ein wenig forwärts. :)
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8288
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Virtual Host Konfiguration

Postby goldfisch2k » 27. July 2010 18:49

Hi,

danke für Eure Antworten.
Der Server startet jetzt, aber ich habe keine PHP Unterstützung mehr.

So sieht mein Neuer Code nun aus:

Code: Select all
 NameVirtualHost *
 
<VirtualHost *:80>
    ServerName DOMAIN.tk
    ServerAlias wap.DOMAIN.tk hs.DOMAIN.eu hs.DOMAIN.com
   ServerAdmin noreply@DOMAIN.tk
    DocumentRoot d:/webserver/htdocs
     <Directory "d:/webserver/htdocs">
        AllowOverride All
        Options IncludesNoExec
        Order allow,deny
        Allow from all
    </Directory>
</VirtualHost>

<VirtualHost *:80>
    ServerName go.DOMAIN.tk
    ServerAlias www.go.DOMAIN.tk
    ServerAdmin noreply@DOMAIN.tk
    DocumentRoot d:/webserver/htdocs/to
     <Directory "d:/webserver/htdocs/to">
        AllowOverride All
        Options IncludesNoExec
        Order allow,deny
        Allow from all
    </Directory>
</VirtualHost>

# Options +Indexes IncludesNoExec  ( Das +Indexes veranlasst den Apache, das Verzeichnis aufzulisten, wenn keine index.html/php vorhanden ist. )
# AllowOverride All ( Veranlasst den Apachen, auch .htaccess Anweisungen zu beachten (z.b. Passwortschutz) )
goldfisch2k
 
Posts: 19
Joined: 13. August 2008 18:58

Re: Virtual Host Konfiguration

Postby Altrea » 28. July 2010 04:50

goldfisch2k wrote:Der Server startet jetzt, aber ich habe keine PHP Unterstützung mehr.

Was aber nichts mit deiner VHost Einstellung zu tun haben sollte.

Folgende Ursachen sind sind die wahrscheinlichsten:
- du verwendest short_open_tags obwohl diese Einstellung deaktiviert ist (Suche nach short_open_tags in der Forumsuche)
- Du öffnest die Seite ohne sie über den Webserver anzufragen (Einfach im Browser ziehen oder über "öffnen mit..." funktioniert PHP nicht).
- deine PHP-Datei hat eine andere Dateiendung als .php (php wird nicht in html-Dateien ausgeführt! Ebenso weiß der Server in der Standardkonfiguration nichts mit .php5 Dateien oder ähnlichem anzufangen)
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8288
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Virtual Host Konfiguration

Postby goldfisch2k » 28. July 2010 11:44

Altrea wrote:
goldfisch2k wrote:Der Server startet jetzt, aber ich habe keine PHP Unterstützung mehr.

Was aber nichts mit deiner VHost Einstellung zu tun haben sollte.


Vorher funktionierte es doch ;-)
goldfisch2k
 
Posts: 19
Joined: 13. August 2008 18:58

Re: Virtual Host Konfiguration

Postby Altrea » 28. July 2010 11:49

goldfisch2k wrote:Vorher funktionierte es doch ;-)

Vor was? Vor dem definieren der VHosts?
Dann kann es eigentlich nur an den Pfaden in deiner Webanwendung liegen.

Um genaueres sagen zu können wäre aber eine Erläuterung von "keine PHP-Unterstützung" hilfreich.
Wodurch macht sich das bemerkbar?
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8288
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Virtual Host Konfiguration

Postby goldfisch2k » 28. July 2010 13:49

Altrea wrote:
goldfisch2k wrote:Vorher funktionierte es doch ;-)

Vor was? Vor dem definieren der VHosts?
Dann kann es eigentlich nur an den Pfaden in deiner Webanwendung liegen.

Um genaueres sagen zu können wäre aber eine Erläuterung von "keine PHP-Unterstützung" hilfreich.
Wodurch macht sich das bemerkbar?


Ja, bevor ich mit der vHost Konfiguration angefangen habe.
Das macht sich dadurch bemerkbar, dass ich den Quelltext in Textform im Browser lese.
goldfisch2k
 
Posts: 19
Joined: 13. August 2008 18:58

Re: Virtual Host Konfiguration

Postby Altrea » 28. July 2010 13:55

goldfisch2k wrote:Ja, bevor ich mit der vHost Konfiguration angefangen habe.
Das macht sich dadurch bemerkbar, dass ich den Quelltext in Textform im Browser lese.


Außer den VHosts hast du in der Zwischenzeit nichts verändert?
Nimm die VHosts doch nochmal raus und berichte ob PHP wieder ordnungsgemäß arbeiten.

Das wäre sehr ungewöhnlich, denn ich kann mir nicht erklären, wie deine VHosts so ein Verhalten hervorrufen könnten.
Vielleicht hat jemand anders dazu ja noch eine Idee.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8288
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Virtual Host Konfiguration

Postby goldfisch2k » 28. July 2010 15:46

Den Server scheint es komplett zerschossen zu haben.
Hast du oder jemand nochmal die Original vHost Datei? Ich habe diese leider nicht gesichert.

Aber sebst wenn ich sie in der httpd.conf ausklammer (# vor include) stellt er kein PHP Inhalt mehr da.
goldfisch2k
 
Posts: 19
Joined: 13. August 2008 18:58

Re: Virtual Host Konfiguration

Postby Altrea » 28. July 2010 16:23

Die VHost Datei besteht nach einer Frischen installation nur aus auskommentierten Beispielen.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8288
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Virtual Host Konfiguration

Postby goldfisch2k » 28. July 2010 17:08

das heißt wenn ich ein leeres dokument speicher sollte ich den urzustand haben, richtig?
goldfisch2k
 
Posts: 19
Joined: 13. August 2008 18:58

Re: Virtual Host Konfiguration

Postby Altrea » 28. July 2010 17:25

Oder du den include davon auskommentierst, was du bereits getan hast.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8288
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 16 guests