suche php.ini wg Zeitzonenproblem

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

suche php.ini wg Zeitzonenproblem

Postby jdgf » 14. June 2010 08:28

Hallo,
ich habe das Problem mit den Zeitzonen und Joomla. Zu dem Thema habe ich diesen Thread (viewtopic.php?f=4&t=37168) gefunden, der auf die /xampp/apache/bin/php.ini verweist, dass dort der Eintrag berlin/europe richtigerweise in europe/berlin geändert werden muss, damit joomla 1.5.18 mit der zeitzonenregelung klarkommt.

Mein Problem ist, dass in der Version xampp 1.7.3 im Verzeichnis apache/bin keine php.ini sich befindet.

Ich bekomme die Fehlermeldung, wenn ich Joomla aufrief. Als ich XAMPP aufrief, erhielt ich eine ähnliche Fehlermeldung mit PEAR. Ist das dasselbe Problem?

Code: Select all
Warning: date() [function.date]: It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'Europe/Paris' for '2.0/DST' instead in C:\xampp\php\PEAR\PEAR\Info.php on line 911


Gruß Dietmar
jdgf
 
Posts: 8
Joined: 30. July 2007 17:39

Re: suche php.ini wg Zeitzonenproblem

Postby Nobbie » 14. June 2010 08:41

jdgf wrote:Mein Problem ist, dass in der Version xampp 1.7.3 im Verzeichnis apache/bin keine php.ini sich befindet.


Das ist richtig, aber sowohl die Suchfunktion unter Windows als auch die phpinfo() Funktion (teil des Xampp Menus) ist in der Lage, den Standort der php.ini mitzuteilen.
Nobbie
 
Posts: 8775
Joined: 09. March 2008 13:04

Re: suche php.ini wg Zeitzonenproblem

Postby jdgf » 14. June 2010 13:53

Ich habe jetzt die Kommentierung entfernt und als Zeitzone "europe/berlin" eingefügt. Der Fehler wird nicht mehr angezeigt. Danke.
jdgf
 
Posts: 8
Joined: 30. July 2007 17:39

Re: suche php.ini wg Zeitzonenproblem

Postby jdgf » 15. June 2010 09:06

Joomla und xampp 1.7.3 harmonieren nicht. In einem Thread fand ich den Hinweis, stattdessen xampp 1.7.1 zu verwenden. Hier passt alles ohne jegliche Fehlermeldung. :-)
jdgf
 
Posts: 8
Joined: 30. July 2007 17:39

Re: suche php.ini wg Zeitzonenproblem

Postby Nobbie » 15. June 2010 11:32

jdgf wrote:Joomla und xampp 1.7.3 harmonieren nicht. In einem Thread fand ich den Hinweis, stattdessen xampp 1.7.1 zu verwenden. Hier passt alles ohne jegliche Fehlermeldung. :-)


Das ist nicht ganz richtig, das Problem besteht im Zusammenspiel mit PHP ab Version 5.3. Aber neuere Versionen von Joomla harmonieren mit PHP 5.3 und somit auch mit Xampp 1.7.3 (bis auf die OpenID Library - was mir allerdings nichts sagt, ich benutze kein Joomla):

Aus der Installationsbeschreibung von Joomla:

Joomla! versions 1.5.15 + are compatible with PHP 5.3. Note that the OpenID library is not yet compatible with PHP 5.3.
Nobbie
 
Posts: 8775
Joined: 09. March 2008 13:04


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 9 guests