[gelöst] Apache will nicht ohne Netzwerk

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

[gelöst] Apache will nicht ohne Netzwerk

Postby kaioliver » 13. May 2010 08:57

Hallo,
wieder mal ein neuer und vermutlich ein altes Problem, aber ich kann nichts finden. Ich habe mir XAMPP auf ein Stick installiert (Portable Apps). Dieser ist in meinem Laptop. Bin in in der Firma kann ich wenn ich hier mein Netzerkstecker eingesteckt habe XAMPP nutzen und auf meine php scripte zugreifen. Habe ich kein Netzwerkstecker sondern nur WLAN an und starte dann den Apache geht es nicht mehr. Bin ich zu Haus uns starte XAMPP geht es weder über Netzwerk oder über WLAN wenn ich es starte. Und das muss anders werden ;-)
- Mein System: Windows Vista
- Firewall ist unten
- Zugriff geht weder über localhost noch über 127.0.0.1 oder eine andere zugewiesene IP ( also: http://localhost )
- in der hosts steht ein Eintrag mit 127.0.0.1 localhost.
- Apache sagt er läuft. Netstat -a zeigt mir auch erst nach dem Start des Apache das der Port 80 belegt ist.
- Das error.log sieht meines Erachtens auch ok aus:
Code: Select all
[Thu May 13 09:35:14 2010] [warn] pid file C:/PortableApps/xampp/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
[Thu May 13 09:35:17 2010] [notice] Digest: generating secret for digest authentication ...
[Thu May 13 09:35:17 2010] [notice] Digest: done
[Thu May 13 09:35:17 2010] [notice] Apache/2.2.14 (Win32) DAV/2 mod_ssl/2.2.14 OpenSSL/0.9.8l mod_autoindex_color PHP/5.3.1 mod_apreq2-20090110/2.7.1 mod_perl/2.0.4 Perl/v5.10.1 configured -- resuming normal operations
[Thu May 13 09:35:17 2010] [notice] Server built: Nov 11 2009 14:29:03
[Thu May 13 09:35:17 2010] [notice] Parent: Created child process 5492
[Thu May 13 09:35:21 2010] [notice] Digest: generating secret for digest authentication ...
[Thu May 13 09:35:21 2010] [notice] Digest: done
[Thu May 13 09:35:21 2010] [notice] Child 5492: Child process is running
[Thu May 13 09:35:21 2010] [notice] Child 5492: Acquired the start mutex.
[Thu May 13 09:35:21 2010] [notice] Child 5492: Starting 150 worker threads.
[Thu May 13 09:35:22 2010] [notice] Child 5492: Starting thread to listen on port 443.
[Thu May 13 09:35:22 2010] [notice] Child 5492: Starting thread to listen on port 80.

- Der IE meldet: Internet Explorer cannot display the webpage
- Firefox und Chrome gehen auch nicht.

Das hier sah sehr vielversprechend aus, ist aber leider für Linux :-(
http://community.apachefriends.org/f/viewtopic.php?p=132930

Hmm, mehr weiß ich jetzt auch nicht was ich an Daten noch liefern muss oder kann...

ach ja, mit einem telnet localhost 80 komme ich auchnicht durch.
Last edited by deepsurfer on 18. May 2010 19:22, edited 1 time in total.
Reason: Titel Änderung auf gelöst
kaioliver
 
Posts: 2
Joined: 13. May 2010 08:42

Re: Apache will nicht ohne Netzwerk

Postby kaioliver » 14. May 2010 11:30

...so, ich habe es gelöst. Auf meinem Rechner war noch eine zweite Firewall installiert :shock:
kaioliver
 
Posts: 2
Joined: 13. May 2010 08:42


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 9 guests