[gelöst] Problem mit date()

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

[gelöst] Problem mit date()

Postby alexuschi » 26. April 2010 09:47

Hallo
Habe seit V173 folgende Meldung:
================
Warning: date() [function.date]: It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'Europe/London' for '1.0/DST' instead in x:\xxxxxxxxxxxxxxxxxxxline 21
===============
Möchte aber nicht alle Seiten wo ich date() verwende umschreiben.
Wo kann ich das wieder abstellel?
Last edited by deepsurfer on 19. May 2010 09:50, edited 1 time in total.
Reason: Titel Änderung auf "gelöst"
Alex
GC
alexuschi
 
Posts: 16
Joined: 25. January 2007 10:10

Re: Problem mit date()

Postby Altrea » 26. April 2010 10:07

Hast du die setup_xampp.bat Datei nach der "Installation" ausgeführt?
Dort wird normalerweise die Zeitzone in der php.ini festgelegt.

Ansonsten kannst du die Zeitzone auch selbst in der php.ini eintragen.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8293
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Problem mit date()

Postby alexuschi » 26. April 2010 13:01

Alles klar. Das wars.
Verwende immer die selbe php.ini, weil ich da einige änderungen gemacht habe.
In der Original php.ini war die date_timezone = "Europe/London".
Genau diese habe ich mir "rüber" geholt und jetzt funkt es.
danke schön :D
Alex
GC
alexuschi
 
Posts: 16
Joined: 25. January 2007 10:10


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 23 guests