Fehler: Verbindung unterbrochen

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Fehler: Verbindung unterbrochen

Postby H0MER » 15. April 2010 13:13

Hallo Liebes Forum.

Folgendes Problem:

Ich habe auf einem win7 Rechner Xampp 1.7.3. installiert.
Auf einer Debian Box habe ich Apache2 sowie MySql installiert und wollte jetzt einige Seiten und Datenbanken auf die XAMPP installation rüberschieben.

Nach dieser Aktion funktioniert ein Oxid eShop und PHPMYadmin und dergleichen alles ohne probleme.
Wenn ich jetzt aber eine Seite aufrufe, in der ich per mysqli selber eine Verbindung zum Datenbankserver aufbaue erhalte ich die fehlermeldung (habe ich gekürzt) :
Code: Select all
Fehler: Verbindung unterbrochen

Die Verbindung zum Server wurde zurückgesetzt, während die Seite geladen wurde.


Jetzt habe ich auf 2 Seiten ein wenig rumgespielt und festgestellt, dass Daten über ein Formular sehr wohl in der Datenbank gespeichert werden - Ich erhalte aber trotzdem diesen Fehler und die Seite wird einfach nicht angezeigt.
Die Seiten mit dem von mir geschriebenen Datenbankverbindungen funktionieren sowohl auf meiner Debian Box im Netzt als auch auf meinem Debian Rootserver.
Nur halt nicht unter XAMPP.

Hat da jemand nen Rat für mich?

Die error.log des Apachen liest sich nicht erfreulich, jedoch werde ich nicht schlau daraus:

Code: Select all
[Thu Apr 15 14:00:04 2010] [notice] Apache/2.2.14 (Win32) DAV/2 mod_ssl/2.2.14 OpenSSL/0.9.8l mod_autoindex_color PHP/5.3.1 mod_apreq2-20090110/2.7.1 mod_perl/2.0.4 Perl/v5.10.1 configured -- resuming normal operations
[Thu Apr 15 14:00:04 2010] [notice] Server built: Nov 11 2009 14:29:03
[Thu Apr 15 14:00:04 2010] [notice] Parent: Created child process 3844
[Thu Apr 15 14:00:07 2010] [notice] Digest: generating secret for digest authentication ...
[Thu Apr 15 14:00:07 2010] [notice] Digest: done
[Thu Apr 15 14:00:07 2010] [notice] Child 3844: Child process is running
[Thu Apr 15 14:00:07 2010] [notice] Child 3844: Acquired the start mutex.
[Thu Apr 15 14:00:07 2010] [notice] Child 3844: Starting 150 worker threads.
[Thu Apr 15 14:00:07 2010] [notice] Child 3844: Starting thread to listen on port 443.
[Thu Apr 15 14:00:07 2010] [notice] Child 3844: Starting thread to listen on port 443.
[Thu Apr 15 14:00:07 2010] [notice] Child 3844: Starting thread to listen on port 80.
[Thu Apr 15 14:00:07 2010] [notice] Child 3844: Starting thread to listen on port 80.
[Thu Apr 15 14:01:18 2010] [error] [client 192.168.0.123] File does not exist: D:/xampp/htdocs/favicon.ico
[Thu Apr 15 14:01:21 2010] [error] [client 192.168.0.123] File does not exist: D:/xampp/htdocs/favicon.ico
[Thu Apr 15 14:01:27 2010] [notice] Parent: child process exited with status 255 -- Restarting.
[Thu Apr 15 14:01:28 2010] [notice] Digest: generating secret for digest authentication ...
[Thu Apr 15 14:01:28 2010] [notice] Digest: done


Vielen Dank für Eure Hilfe.

Mfg
H0MER


/edit: an der php.ini und der httpd.conf habe ich nicht rumgefummelt - die sind noch original
H0MER
 
Posts: 53
Joined: 11. June 2003 17:30

Re: Fehler: Verbindung unterbrochen

Postby WilliL » 15. April 2010 20:16

da wirst den script / .htaccess durchgehen müssen..
hier könnte ein Pfad nicht richtig sein (z.B. .htuser nicht mit absoluter Pfadangabe)
Code: Select all
[Thu Apr 15 14:01:21 2010] [error] [client 192.168.0.123] File does not exist: D:/xampp/htdocs/favicon.ico
Willi
WilliL
 
Posts: 661
Joined: 08. January 2010 10:54
Operating System: Win7Home Prem 64 SP1


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 17 guests