httpd.conf umgeschrieben, trotzdem falscher index angezeigt

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

httpd.conf umgeschrieben, trotzdem falscher index angezeigt

Postby EddWood » 12. April 2010 13:00

Bin Neuling ohne große XAMPP Erfahrung.
Habe XAMPP installiert, die httpd.conf wie folgt umgeschrieben, und komme bei Browsereingabe http://lokalhost/ immer in das xampp verzeichnis statt auf meine lokale Seite.

httpd.conf wie folgt geändert:

...
# ServerRoot: The top of the directory tree under which the server's
# configuration, error, and log files are kept.
#
# Do not add a slash at the end of the directory path. If you point
# ServerRoot at a non-local disk, be sure to point the LockFile directive
# at a local disk. If you wish to share the same ServerRoot for multiple
# httpd daemons, you will need to change at least LockFile and PidFile.
#
ServerRoot "/xampp/apache" <----hab ich gelassen>

...

# DocumentRoot: The directory out of which you will serve your
# documents. By default, all requests are taken from this directory, but
# symbolic links and aliases may be used to point to other locations.
#
DocumentRoot "L:/Alpenhof/Webseite" <----hab ich geändert. in "Webseite" ist mein komplettes Verzeichnis mit index.html>

...

# This should be changed to whatever you set DocumentRoot to.
#
<Directory "L:/Alpenhof/Webseite"> <----hab ich geändert. in "Webseite" ist mein komplettes Verzeichnis mit index.html>


Mehr als die zwei (DocumentRoot und Directory) hab ich auch nicht geändert.
Finde auch im Internet nur die zwei Vorgeschlagenen nötigen Änderungen.
Ich hoffe mir kann jemand helfen.
Danke schon mal.
Alexander
Denke mal, dass ist ein einfaches Problem, hab allerdings keine Lösungen trotz langem suchen gefunden.
EddWood
 
Posts: 6
Joined: 12. April 2010 11:00

Re: httpd.conf umgeschrieben, trotzdem falscher index angezeigt

Postby Nobbie » 12. April 2010 13:57

EddWood wrote:und komme bei Browsereingabe http://lokalhost/ immer in das xampp verzeichnis statt auf meine lokale Seite.


Glaube ich nicht - bei http://lokalhost kommt bestimmt eine Fehlermeldung (Seite nicht gefunden). Ich würde es mit http://localhost versuchen.

EddWood wrote:Denke mal, dass ist ein einfaches Problem, hab allerdings keine Lösungen trotz langem suchen gefunden.


Denke ich auch:

a) starte Apache neu (falls noch nicht geschehen)
b) lösche den Browsercache
Nobbie
 
Posts: 8775
Joined: 09. March 2008 13:04

Re: httpd.conf umgeschrieben, trotzdem falscher index angezeigt

Postby EddWood » 12. April 2010 17:07

Das war es nicht. Hab den Computer runtergefahren. Immernoch die falsche index. Muss man bei wechsel eines anderen Laufwerkes (nicht C: in der xampp ausgeführt wird, sondern L: in der die Datei liegt) etwas besonderes beim installieren beachten?
Cache gelöscht und verschiedene Browser hab ich auch schon ausprobiert.
EddWood
 
Posts: 6
Joined: 12. April 2010 11:00

Re: httpd.conf umgeschrieben, trotzdem falscher index angezeigt

Postby Nobbie » 12. April 2010 17:49

EddWood wrote:Das war es nicht.


Dann hast Du irgendwo eine zweite httpd.conf (vielleicht sogar ein doppeltes Xampp o.ä.) oder Du hast VirtualHosts angelegt, die diese Einstellung überschreiben.

EddWood wrote:Muss man bei wechsel eines anderen Laufwerkes (nicht C: in der xampp ausgeführt wird, sondern L: in der die Datei liegt) etwas besonderes beim installieren beachten?


Nein, nur wenn man die ganze Xampp Installation verschiebt. Aber davon war ja keine Rede, Du willst ja lediglich ein anderes Verzeichnis als DocumentRoot haben.
Nobbie
 
Posts: 8775
Joined: 09. March 2008 13:04

Re: httpd.conf umgeschrieben, trotzdem falscher index angezeigt

Postby EddWood » 13. April 2010 10:38

Eine zweite httpd.conf kann ich auf meinem Computer nicht finden.
Ein VirtualHosts hab ich nicht bewusst angelegt. Kann ich das irgendwie rausfinden ob ich das unbewusst angelegt habe?
EddWood
 
Posts: 6
Joined: 12. April 2010 11:00

Re: httpd.conf umgeschrieben, trotzdem falscher index angezeigt

Postby Nobbie » 13. April 2010 12:04

EddWood wrote:Eine zweite httpd.conf kann ich auf meinem Computer nicht finden.
Ein VirtualHosts hab ich nicht bewusst angelegt. Kann ich das irgendwie rausfinden ob ich das unbewusst angelegt habe?


"Irgendwie"? Schau in die httpd.conf und in die httpd-vhosts.conf (im Unterverzeichnis extra).

Und lass mal einen phpinfo() laufen und zeige uns hier die Ausgabe.

Was ist eigentlich der Inhalt von "L:/Alpenhof/Webseite"? Vielleicht liegt es ja daran.
Nobbie
 
Posts: 8775
Joined: 09. March 2008 13:04

Re: httpd.conf umgeschrieben, trotzdem falscher index angezeigt

Postby EddWood » 13. April 2010 12:17

in httpd-vhosts.conf steht folgendes.
....
##<VirtualHost *:80>
##ServerAdmin postmaster@dummy-host.localhost
##DocumentRoot "/xampp/htdocs/dummy-host.localhost"
##ServerName dummy-host.localhost
##ServerAlias www.dummy-host.localhost
##ErrorLog "logs/dummy-host.localhost-error.log"
##CustomLog "logs/dummy-host.localhost-access.log" combined
##</VirtualHost>
...

allerdings hab ich in einer httpd-ssl Datei etwas gefunden, was zumindest zu der nicht gewollten index Datei (It works) führt.
...
<VirtualHost _default_:443>
# General setup for the virtual host
DocumentRoot "/xampp/htdocs" <-----hier hab ich nichts geändert, muss ich das auch ändern?>
ServerName localhost:443
ServerAdmin webmaster@localhost
ErrorLog "logs/error.log"
<IfModule log_config_module>
CustomLog "logs/access.log" combined
</IfModule>
...
Von phpinfo laufen lassen hab ich zu wenig Ahnung. Wüsste nicht mal wie oder wo ich so was ausführen soll.
Der Inhalt von "L:/Alpenof/Webseite" ist meine Homepage. Sie funktioniert wenn ich sie komplett in das Verzeichnis "/xampp/htdocs" einfüge. Was ich allerdings vermeinden wollte.
EddWood
 
Posts: 6
Joined: 12. April 2010 11:00

Re: httpd.conf umgeschrieben, trotzdem falscher index angezeigt

Postby Altrea » 13. April 2010 13:36

EddWood wrote:Von phpinfo laufen lassen hab ich zu wenig Ahnung. Wüsste nicht mal wie oder wo ich so was ausführen soll.

Ahnung ist dafür nicht vonnöten.
In deinem XAMPP-Backend (der Seite mit den ganzen XAMPP Beispielanwendungen wie cdcol und co) gibt es auch ein Link mit der Beschriftung phpinfo()

Alternativ dazu könntest du auch eine php Datei mit folgendem Inhalt erstellen
Code: Select all
<?php phpinfo(); ?>

In einem Ordner ablegen, den du über localhost ansteuern kannst, und die Datei im Browser aufrufen.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8294
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: httpd.conf umgeschrieben, trotzdem falscher index angezeigt

Postby EddWood » 13. April 2010 19:10

OK, hab das phpinfo() gefunden. Alles zu kopieren wäre wohl etwas lang und viel. Denke aber die ersten Spalten sind die Aussagekräftigen. Denke sogar erst ab PHP-Credits. Weiter unten in "Apache Environment" hab ich auch ein Document_Root gefunden, welches auf xampp/htdocs verweist. Wie ich das ändern kann weis ich nicht. Ich finde tatsächlich keine zweite httpd.conf auf meinem Rechner.

....

System Windows NT BÜRO 6.1 build 7600 ((null)) i586
Build Date Nov 20 2009 17:20:57
Compiler MSVC6 (Visual C++ 6.0)
Architecture x86
Configure Command cscript /nologo configure.js "--enable-snapshot-build"
Server API Apache 2.0 Handler
Virtual Directory Support enabled
Configuration File (php.ini) Path no value
Loaded Configuration File C:\xampp\php\php.ini
Scan this dir for additional .ini files (none)
Additional .ini files parsed (none)
PHP API 20090626
PHP Extension 20090626
Zend Extension 220090626
Zend Extension Build API220090626,TS,VC6
PHP Extension Build API20090626,TS,VC6
Debug Build no
Thread Safety enabled
Zend Memory Manager enabled
Zend Multibyte Support disabled
IPv6 Support enabled
Registered PHP Streams https, ftps, php, file, glob, data, http, ftp, compress.zlib, compress.bzip2, phar, zip
Registered Stream Socket Transports tcp, udp, ssl, sslv3, sslv2, tls
Registered Stream Filters convert.iconv.*, string.rot13, string.toupper, string.tolower, string.strip_tags, convert.*, consumed, dechunk, zlib.*, bzip2.*

Zend logo This program makes use of the Zend Scripting Language Engine:
Zend Engine v2.3.0, Copyright (c) 1998-2009 Zend Technologies



PHP Credits
Configuration
apache2handler
Apache Version Apache/2.2.14 (Win32) DAV/2 mod_ssl/2.2.14 OpenSSL/0.9.8l mod_autoindex_color PHP/5.3.1 mod_apreq2-20090110/2.7.1 mod_perl/2.0.4 Perl/v5.10.1
Apache API Version 20051115
Server Administrator postmaster@localhost
Hostname:Port localhost:80
Max Requests Per Child: 0 - Keep Alive: on - Max Per Connection: 100
Timeouts Connection: 300 - Keep-Alive: 5
Virtual Server No
Server Root C:/xampp/apache
Loaded Modules core mod_win32 mpm_winnt http_core mod_so mod_actions mod_alias mod_asis mod_auth_basic mod_auth_digest mod_authn_default mod_authn_file mod_authz_default mod_authz_groupfile mod_authz_host mod_authz_user mod_cgi mod_dav mod_dav_fs mod_dav_lock mod_dir mod_env mod_headers mod_include mod_info mod_isapi mod_log_config mod_mime mod_negotiation mod_rewrite mod_setenvif mod_ssl mod_status mod_autoindex_color mod_php5 mod_perl mod_apreq2

Directive Local Value Master Value
engine 1 1
last_modified 0 0
xbithack 0 0


Apache Environment
Variable Value
MIBDIRS /xampp/php/extras/mibs
MYSQL_HOME \xampp\mysql\bin
OPENSSL_CONF /xampp/apache/bin/openssl.cnf
PHP_PEAR_SYSCONF_DIR \xampp\php
PHPRC \xampp\php
TMP \xampp\tmp
HTTP_HOST localhost
HTTP_USER_AGENT Mozilla/5.0 (Windows; U; Windows NT 6.1; de; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3
HTTP_ACCEPT text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
HTTP_ACCEPT_LANGUAGE de-de,de;q=0.8,en-us;q=0.5,en;q=0.3
HTTP_ACCEPT_ENCODING gzip
HTTP_ACCEPT_CHARSET ISO-8859-1,utf-8;q=0.7,*;q=0.7
HTTP_KEEP_ALIVE 115
HTTP_CONNECTION keep-alive
HTTP_REFERER http://localhost/xampp/navi.php
PATH C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0\;C:\Program Files (x86)\EgisTec\MyWinLocker 3\x86;C:\Program Files (x86)\EgisTec\MyWinLocker 3\x64;C:\Program Files (x86)\Common Files\Ulead Systems\MPEG;C:\Program Files (x86)\Common Files\Ulead Systems\DVD;C:\Program Files (x86)\QuickTime\QTSystem\
SystemRoot C:\Windows
COMSPEC C:\Windows\system32\cmd.exe
PATHEXT .COM;.EXE;.BAT;.CMD;.VBS;.VBE;.JS;.JSE;.WSF;.WSH;.MSC
WINDIR C:\Windows
SERVER_SIGNATURE <address>Apache/2.2.14 (Win32) DAV/2 mod_ssl/2.2.14 OpenSSL/0.9.8l mod_autoindex_color PHP/5.3.1 mod_apreq2-20090110/2.7.1 mod_perl/2.0.4 Perl/v5.10.1 Server at localhost Port 80</address>
SERVER_SOFTWARE Apache/2.2.14 (Win32) DAV/2 mod_ssl/2.2.14 OpenSSL/0.9.8l mod_autoindex_color PHP/5.3.1 mod_apreq2-20090110/2.7.1 mod_perl/2.0.4 Perl/v5.10.1
SERVER_NAME localhost
SERVER_ADDR ::1
SERVER_PORT 80
REMOTE_ADDR ::1
DOCUMENT_ROOT C:/xampp/htdocs <-----Sollte doch eigentlich mit dem httpd.conf geändert sein.>
SERVER_ADMIN postmaster@localhost
SCRIPT_FILENAME C:/xampp/htdocs/xampp/phpinfo.php
REMOTE_PORT 61853
GATEWAY_INTERFACE CGI/1.1
SERVER_PROTOCOL HTTP/1.1
REQUEST_METHOD GET
QUERY_STRING no value
REQUEST_URI /xampp/phpinfo.php
SCRIPT_NAME /xampp/phpinfo.php
EddWood
 
Posts: 6
Joined: 12. April 2010 11:00

Re: httpd.conf umgeschrieben, trotzdem falscher index angezeigt

Postby Nobbie » 13. April 2010 20:43

DOCUMENT_ROOT C:/xampp/htdocs <-----Sollte doch eigentlich mit dem httpd.conf geändert sein.>


Richtig. Weißt Du, was ich vermute: Du bearbeitest die Datei mit Notepad, und anstatt sie unter dem Namen httpd.conf wieder zu speichern, legt Notepad (als blödster Editor der Welt) eine neue Datei an mit dem Namen httpd.conf.txt

Irgendso etwas wird es sein. Aus irgendeinem Grund kommen Deine Änderungen nämlich nicht an.
Nobbie
 
Posts: 8775
Joined: 09. March 2008 13:04

Re: httpd.conf umgeschrieben, trotzdem falscher index angezeigt

Postby EddWood » 14. April 2010 09:21

Wow, tatsächlich. Hab es mit Dreamweaver geöffnet, dann im Explorer gelöscht, wieder neu gespeichert, xampp neu gestartet, und siehe da-- es funktioniert.

Einen riesigen Dank an dich! Wie kann man sich hier einbringen, um zu zeigen wie happy ich bin? :P Toller Support.
EddWood
 
Posts: 6
Joined: 12. April 2010 11:00

Re: httpd.conf umgeschrieben, trotzdem falscher index angezeigt

Postby Altrea » 14. April 2010 09:29

EddWood wrote:Wie kann man sich hier einbringen, um zu zeigen wie happy ich bin?

Euer Glücksgefühl ist unser Antrieb, oder so ähnlich :D
Wenn du natürlich Beiträge von anderen Usern findest, bei denen du mit deinem Wissen weiterhelfen kannst, kannst du dich auch auf diesem Wege einbringen.

btw: Du kannst natürlich auch mit dem Windows Explorer die Konfigurationsdateien editieren. Du musst beim speichern dann nur darauf achten, dass als Dateityp "Alle Dateien" und nicht "Textdateien (.txt)" steht.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8294
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 6 guests