Modul Installation, Regulierung Bandbreite

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Modul Installation, Regulierung Bandbreite

Postby Junkfood » 01. April 2010 11:58

Hallo,

ich habe ein kleines Problem mit Apache, also eigentlich läuft Apache wunderbar, Installation und Konfiguration hat wunderbar geklappt. Nur ich wollte dann die Bandbreite kontrollieren, was scheinbar "ab Werk" bei Xampp nicht möglich ist (oder ich habs nicht gefunden) die Suche im Internet brachte mich dann auf das Modul "mod_cband".
Dachte mir herunterladen das Ding in den Ordner "c:\xampp\apache\modules" kopieren und es über die über die Datei "http.conf" mit dem Befehl LoadModule laden. :roll:
Nachdem herunterladen des Modules ist mir aber aufgefallen das in dem Paket keine Datei mit der Endung "*.so" zu finden ist.
Wie es scheint muss das Modul wohl erst kompiliert werden. Meine Frage aber dann wie kompiliere ich das Modul?
Das Problem scheint hier wohl Windows zu sein, anleitungen wie das unter Linux funktionieren würde habe ich gefunden nur für Windows leider nicht.
Oder gibt's das ganze auch irgendwo zum Download als mod_cban.so?? Auch hier lieferte meine Suche keine brauchbaren ergebnisse.

Kurz die Infos zu meinem System:
Habe die aktuelleste Xampp installiert also Apache 2.2.14, das ganze läuft unter Windows Server 2008.

Alternativen wie ich die Bandbreite sonst noch regulieren könnte sind natürlich auch willkommen!

Danke schon mal im voraus.

Andy
Junkfood
 
Posts: 4
Joined: 01. April 2010 11:33

Re: Modul Installation, Regulierung Bandbreite

Postby Junkfood » 01. April 2010 15:56

Klingt ja vielversprechend. :wink:
Aber danke schon mal.
Junkfood
 
Posts: 4
Joined: 01. April 2010 11:33

Re: Modul Installation, Regulierung Bandbreite

Postby Junkfood » 01. April 2010 16:45

Jetzt läuft's! :shock:

Problem war die DLL. Hab mir jetzt eine neuere DLL von http://ivn.cl/category/apache/ heruntergeladen.
Dann klappt alles

Ob ich jetzt damit glücklich werde, weiss ich nicht, bekomm das Modul eh nicht zum laufen.

Doku klang ja wirklich einfach.
Code: Select all
    Download mod_bw-2.0.54.dll from the home site, to c:\apache2\modules
    Edit httpd.conf, and add LoadModule bw_module modules/mod_bw-2.0.54.dll
    Restart Apache.

Also die Datei "mod_bw.dll" wie beschrieben in den "modules" Ordner kopiert.

Die Datei "http.conf" um die Zeile "LoadModule bw_module modules/mod_bw.dll" erweitert.

Und noch Testweise folgende Änderungen in der Datei "http-vhost.conf" durchgeführt:
Code: Select all
   BandWidthModule On
   ForceBandWidthModule ON
   BandWidth all 100000


Aber leider startet der Apache dann nicht mehr. Bringt mir nur folgende Fehlermeldung:
httpd: Syntax error on line 138 of C:/xampp/apache/conf/httpd.conf: Cannot load C:/xampp/apache/modules/mod_bw.dll into server: Das angegebene Modul wurde nicht gefunden.
Junkfood
 
Posts: 4
Joined: 01. April 2010 11:33

Re: Modul Installation, Regulierung Bandbreite

Postby Junkfood » 03. April 2010 07:39

Naja, wie gesagt war echt nur die *.dll kopieren, das modul natürlich laden und dann noch die Moduleinstellung bei
den virtuellen Hosts machen.
Problematisch ist nur das die Einstellungen nicht angenommen werden so wie ich das will.
Ich schaffs einfach nicht die die Geschwindigkeit auf 2 oder 3 MByte zu drosseln. Entweder es wird alles
auf ca. 0,6 Mbyte gedrosselt oder er pendelt sich bei 10 bis 12 MByte ein, oder halt voll. :roll:
Junkfood
 
Posts: 4
Joined: 01. April 2010 11:33


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 9 guests