Wo ist die php.ini??

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Wo ist die php.ini??

Postby garnetz » 29. March 2010 08:39

Hallo, ich glaube, ich bin blind.
Um ioncube lokal zu installieren muss ich in der "LAUFWERK*:\*PFAD*\XAMPP\apache\bin\php.ini" Änderungen vornehmen. In meiner alten xampp-Installation (1.6.6a) hatte ich dort auch eine solche Datei.
Jetzt ist da nichts mehr. Die einzige php.ini habe ich in LAUFWERK*:\*PFAD*\XAMPP\apache\php\php.ini gefunden.
Meine Frage nun:
Gibt es die o. g. Datei nicht mehr und wenn nicht, wo muss ich die Änderungen eintragen oder ist meine Installation fehlerhaft?

Danke für die Hilfe
garnetz

[Edit]
Ich habe gerade mal mit php.info nachgeschaut: Loaded Configuration File C:\apachefriends\xampp\php\php.ini
Allerdings kann ich die php.ini nicht wie vorgegeben installieren, weil sie nicht die gleichen Angaben hat, wie in der Anleitung beschrieben:

1. APACHE server ggf. installieren

2. IonCube Loader Ordner in das XAMPP Verzeichnis kopieren

(*LAUFWERK*:\*PFAD*\XAMPP\) Hab ich gemacht.

3. php.ini Datei editieren:

(*LAUFWERK*:\*PFAD*\XAMPP\apache\bin\php.ini) Habe ich gesucht und nicht gefunden, ersatzweise die \XAMPP\php\php.ini genommen

3.1. Suche nach: [Zend] Gibt es bei mir so nicht.

3.2. Danach (direkt als 1.Zeile nach [Zend]) folgende Zeile einfügen und anpassen:

zend_extension_ts = "*LAUFWERK*:*PFAD*\ioncube\ioncube_loader_win_5.2.dll" Habe ich eingefügt nach ";zend_extension = "C:\apachefriends\xampp\php\ext\php_xdebug.dll""

3.3. Suche nach: zend_optimizer.enable_loader = 0 Gibt es bei mir nicht

Ersetzen mit: zend_optimizer.enable_loader = 1

4. Apache-Server neu Starten. Habe ich gemacht

5. xt:Commerce VEYTON Server Test Script in das Document Root (htdocs) entpacken und im Browser ausführen. Die Seite bleibt weiß, ohne Fehlermeldung.

Komisch? Oder Fehler? Oder beides?
garnetz
 
Posts: 25
Joined: 14. July 2006 09:15

Re: Wo ist die php.ini??

Postby Altrea » 29. March 2010 09:52

garnetz wrote:Hallo, ich glaube, ich bin blind.

Ich hoffe nicht, sonst könntest du das hier jetzt nicht lesen :D

garnetz wrote:Die einzige php.ini habe ich in LAUFWERK*:\*PFAD*\XAMPP\apache\php\php.ini gefunden.

Das ist auch die einzig richtige.

Mit Ioncube wirst du bei PHP5.3 derzeit kein Glück haben. PHP 5.3 Support ist von Ioncube zwar angekündigt aber nochnicht veröffentlicht. Das liegt wohl größtenteils auch daran, dass Zend noch keinen Zend Guard (und damit auch noch keinen Zend Optimizer) für PHP 5.3 veröffentlicht hat. Auch dieser war schon vor einem dreiviertel Jahr angekündigt.

garnetz wrote:zend_extension_ts = "*LAUFWERK*:*PFAD*\ioncube\ioncube_loader_win_5.2.dll" Habe ich eingefügt nach ";zend_extension = "C:\apachefriends\xampp\php\ext\php_xdebug.dll""

XDebug könntest du zum Laufen bekommen. Genau dazu ist diese zend_extension Zeile da. Das _ts am Ende ist in der neuen Version weggefallen, deshalb macht deine eingefügte Zeile keinen Sinn

garnetz wrote:Komisch? Oder Fehler? Oder beides?

Nichts von beidem. Einfach eine veraltete Anleitung für eine ältere PHP Version.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8286
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Wo ist die php.ini??

Postby garnetz » 29. March 2010 10:43

Altrea, vielen Dank.

1. Ich bin nicht blind!! Das ist schon mal von großem Vorteil. Auch weil ich dadurch deine Antwort lesen konnte. :wink:
2. Ich bin auch nicht blöd!! Jedenfalls nicht blöder als die meisten.

Nur, was mache ich jetzt? Auf einem Test-Webspace kann ich es nicht installieren, weil dort ioncube nicht läuft, denn ich kann ja die php.ini nicht ändern.
Meine lokale Version läuft nicht, weil zu neu.
Muss ich tatsächlich xampp deinstallieren und eine ältere Version installieren (Ich habe 4 virtuelle Server eingerichtet und ca. 30 lokale CMS-Installationen? Oder gibt es eine Art "Downgrade"?

Vielen Dank noch einmal für die Hilfe und den Rat.
garnetz
garnetz
 
Posts: 25
Joined: 14. July 2006 09:15

Re: Wo ist die php.ini??

Postby Altrea » 29. March 2010 10:53

Du kannst mehrere XAMPP Versionen auf ein und demselben System einrichten.

Einfach XAMPP1.7.1 (das ist die letzte mit PHP 5.2) als zip Version herunterladen, auf deinem lokalen Rechner (oder wo du auch immer deine Scripte entwickelst) entpacken (am besten in einem selbstsprechendem Verzeichnis, wie z.B.: C:\xampp171\), nach deinen Wünschen konfigurieren, fertig.

Du kannst natürlich nicht mehrere Apache und mysql Server gleichzeitig laufen lassen (außer du vergibst unterschiedliche Ports), aber bei reinen Entwicklungssystemen ist das in der Regel kein Problem.

Das ist, denke ich, vom Aufwand her das sinnvollste.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8286
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Wo ist die php.ini??

Postby garnetz » 29. March 2010 11:02

Musik in meinen Ohren!

Aber wie mache ich denn die Installation? (Bin doch etwas blöder, anscheinend :oops: )
Bisher habe ich mir immer die .exe-Datei heruntergeladen und installiert.

Jetzt mache ich was? Gibt es dazu eine Anleitung, wie man versch. Versionen laufen lässt?

Vielen Dank
garnetz
garnetz
 
Posts: 25
Joined: 14. July 2006 09:15

Re: Wo ist die php.ini??

Postby Altrea » 29. March 2010 11:08

Keine Panik, alles ganz einfach.

Du lädst dir die zip-Version herunter.
Diese entpackst du dann einfach irgendwohin (nicht ins root-Verzeichnis deiner Festplatte, denn da liegt ja schon dein anderes xampp-Paket)
Dann benennst du den Ordner um in zum Beispiel "xampp171"
Diesen Ordner verschiebst du dann ins root-Verzeichnis deiner Festplatte.

Dann solltest du soetwas hier haben:
C:\xampp\ = dein bisheriger XAMPP in Version 1.7.3 (?)
C:\xampp171\ = dein XAMPP 1.7.1

Dann führst du noch die setup_xampp.bat Datei in deinem xampp171 Ordner aus, damit alle pfade angepasst werden.

Und schon ist dein zweiter xampp lauffähig. Zum starten musst du deinen anderen xampp (besser gesagt, vorallem den Apache und MySQL Server) natürlich beenden
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8286
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Wo ist die php.ini??

Postby garnetz » 29. March 2010 11:47

OK, das hört sich wirklich nicht so schlimm an.

Hat alles geklappt. Viiiiieeeeelen Dank. :D

Dann mache ich mich jetzt mal an ioncube :evil: . *fürcht*

Liebe Grüße
garnetz
garnetz
 
Posts: 25
Joined: 14. July 2006 09:15

Re: Wo ist die php.ini??

Postby Altrea » 29. March 2010 11:50

Kein Problem.

Ich wünsche dir gutes Gelingen :)
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8286
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Wo ist die php.ini??

Postby garnetz » 29. March 2010 15:08

Tja, das Fürchten war begründet.

Ioncube läuft nicht.

Folgendes steht jetzt bei mir in der php.ini:
[Zend]
zend_extension_ts = "C:\apachefriends\xampp171\ioncube\ioncube_loader_win_5.2.dll"
zend_extension_ts = "C:\apachefriends\xampp171\php\zendOptimizer\lib\ZendExtensionManager.dll"
zend_extension_manager.optimizer_ts = "C:\apachefriends\xampp171\php\zendOptimizer\lib\Optimizer"
zend_optimizer.enable_loader = 1
zend_optimizer.optimization_level=15
;zend_optimizer.license_path =
; Local Variables:
; tab-width: 4
; End:

Leider bekomme ich immer (trotz mehrerer Apache-Stopps und Neustarts) diese Fehlermeldung:
Site error: the file C:\apachefriends\xampp171\htdocs\server_test\index.php requires the ionCube PHP Loader ioncube_loader_win_5.2.dll to be installed by the site administrator.

Wie man sieht, ist der loader aber in der php.ini eingetragen.
Was mache ich denn nun schon wieder falsch???

Lieben Gruß
garnetz
garnetz
 
Posts: 25
Joined: 14. July 2006 09:15


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 8 guests