curl php

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

curl php

Postby nxwphp » 11. March 2010 13:56

Hallo zusammen

Ich habe ein Problem mit PHP Curl unter XAMPP (V. 1.5.4a auf Windows Server 2003.

Im Browser erfolgt die Meldung Fatal error: Call to undefined function curl_init().

Ich habe aber die dll für Curl in der PHP-Ini aktiviert.

Weiss jemand an was das liegen könnte? :?

mit freundlichen Grüssen

DW
nxwphp
 
Posts: 6
Joined: 11. March 2010 13:50

Re: curl php

Postby Nobbie » 11. March 2010 15:34

Hast Du auch mit phpinfo() überprüft (Antwort: nein, natürlich nicht) ob Curl auch wirklich geladen wird?

Hast Du auch mit phpinfo() überprüft (Antwort: nein, natürlich nicht) ob Du überhaupt die richtige php.ini editiert hast?
Nobbie
 
Posts: 8780
Joined: 09. March 2008 13:04

Re: curl php

Postby nxwphp » 11. March 2010 15:37

ja das habe ich sie wird nich geladen. Habe vergessen dass zu erläutern vorher.

Ja habe ich auch gemacht. Habe jedoch sicherheitshalber nach php*.ini gesucht und jede editiert.
nxwphp
 
Posts: 6
Joined: 11. March 2010 13:50

Re: curl php

Postby Nobbie » 11. March 2010 16:25

Dann schaue in den Apache error_log, da steht drin, warum Curl nicht geladen wird.

Falls Du wirklich die richtige php.ini erwischt hast. Einfach "alle" zu bearbeiten ist Blödsinn, schau gezielt mit phpinfo() nach, welches die richtige ist und ändere diese.
Nobbie
 
Posts: 8780
Joined: 09. March 2008 13:04

Re: curl php

Postby nxwphp » 12. March 2010 11:19

Nein in meinem error.log File steht nichts von einem Problem mit cURL. Es steht überhaupt nichts von einem Problem.

Soll ich nun die anderen Einträge wieder entfernen in den .ini Dateien welche nicht massgebend sind dafür?
nxwphp
 
Posts: 6
Joined: 11. March 2010 13:50

Re: curl php

Postby Nobbie » 12. March 2010 11:23

Dann gehe ich weiterhin davon aus, dass nicht die richtige php.ini bearbeitet wurde. Kannst Du das Ergebnis von phpinfo() hier zeigen?
Nobbie
 
Posts: 8780
Joined: 09. March 2008 13:04

Re: curl php

Postby nxwphp » 12. March 2010 11:30

Ich hoffe das reicht. Oder wird noch irgendwo anderst bestimmt welche ini Datei zieht?

Image
nxwphp
 
Posts: 6
Joined: 11. March 2010 13:50

Re: curl php

Postby nxwphp » 16. March 2010 14:32

Ich habe nun rausgefunden das ich über die KOmmandozeile alles gut läuft. Nur im Browser nicht? an was kann das liegen?
nxwphp
 
Posts: 6
Joined: 11. March 2010 13:50

Re: curl php

Postby Nobbie » 16. March 2010 14:46

nxwphp wrote:Ich hoffe das reicht. Oder wird noch irgendwo anderst bestimmt welche ini Datei zieht?

Image


Ist genau falsch. Die Zeile darunter sagt Dir, welche php.ini geladen wird. Da steht in der linken Spalte: Loaded Configuration File
Nobbie
 
Posts: 8780
Joined: 09. March 2008 13:04

Re: curl php

Postby nxwphp » 16. March 2010 14:48

ne eine zeile darunter steht PHP API 20041225 :shock:
nxwphp
 
Posts: 6
Joined: 11. March 2010 13:50

Re: curl php

Postby Nobbie » 16. March 2010 17:27

Du arbeitest ja ohnehin mit einer Steinzeitversion, es spielt auch keine Rolle, ob das drüber oder drunter steht, aber wenn Du es finden kannst, dann eben nicht. Es ist Dein Problem, nicht meines.
Nobbie
 
Posts: 8780
Joined: 09. March 2008 13:04


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 9 guests