Apache läuft nur kurz und stopt dann. McAfee Problem

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Apache läuft nur kurz und stopt dann. McAfee Problem

Postby KDB_QLB » 04. March 2010 14:49

Hallo, bin als Neuling mit XAMPP sofort auf ein Problem gestossen. Installation wurde erfolgreich unter Windows XP im Verzeichnis C:\XAMPP\xampplite durchgeführt. IIS wurde gestoppt und über das Controlpanel Apache gestartet. Für etwa 1 - 2 Sekunden wurde durch grüne Anzeige Funktionsfähigkeit signalisiert. Dann erfolgte Stop.
Im Logfile steht :
(OS 10013)Der Zugriff auf einen Socket war aufgrund der Zugriffsrechte des Sockets unzulässig. : make_sock: unable to listen for connections on address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs

Portcheck meldet u.a. Apache < HTTP > 80 free

Erneute Versuche Apache zu starten bringen nicht mehr die grüne Signalisierung
Wer kann mir Tips geben.
Vielen Dank

LÖSUNG : Es ist eindeutig McAfee Virenschutz. Diesem zuerst mitteilen, daß Apache ins Internet darf. Dann Apache starten und dann in McAfee Apache wieder sperren und alles funktioniert.
Last edited by KDB_QLB on 15. March 2010 10:35, edited 3 times in total.
KDB_QLB
 
Posts: 2
Joined: 04. March 2010 14:13

Re: Apache läuft nur kurz und beendet dann

Postby MoodyMammoth » 05. March 2010 12:16

Hi,

habe ich das richtig verstanden, der IIS ist vorher auf dem Rechner gelaufen?
Oder kann es eventuell sein, dass bei Dir auf dem Rechner Skype läuft? Dann ist Port 80 nämlich auch erst mal blockiert und muss in Skype freigegeben werden.

Gruß
Manfred
MoodyMammoth
 
Posts: 7
Joined: 19. August 2009 08:51

Re: Apache läuft nur kurz und beendet dann

Postby KDB_QLB » 05. March 2010 13:42

Skype läuft nicht auf dem Rechner. Portcheck zeigt an, daß Port 80 frei ist. Dieses stimmt auch mit dem Erscheinungsbild überein, daß apache für wenige Sekunden als laufend ( grüner Eintrag ) dargestellt wird. Im Übrigen ist die Fehlermeldung (OS 10013) ... nirgendwo erklärt bzw. ich finde keine Erklärung.
Danke
KDB
KDB_QLB
 
Posts: 2
Joined: 04. March 2010 14:13

Re: Apache läuft nur kurz und beendet dann

Postby Altrea » 05. March 2010 13:55

KDB_QLB wrote:Portcheck zeigt an, daß Port 80 frei ist. Dieses stimmt auch mit dem Erscheinungsbild überein, daß apache für wenige Sekunden als laufend ( grüner Eintrag ) dargestellt wird.

Das ist leider kein Indikator dafür. Selbst wenn Port 80 belegt wäre, würde das grüne "running" Schildchen kurz aufleuchten um wieder zu erlöschen.

KDB_QLB wrote:Im Übrigen ist die Fehlermeldung (OS 10013) ... nirgendwo erklärt bzw. ich finde keine Erklärung.

Dann hast du nicht nach den richtigen Stichworten gesucht. Im übrigen ist der Fehlertext "Der Zugriff auf einen Socket war aufgrund der Zugriffsrechte des Sockets unzulässig." schon sehr aussagekräftig und liefert bei Google den einen oder anderen Treffer.

Du hast nicht die benötigte Berechtigung diesen Port zu öffnen. Entweder verhindert deine Firewall dies, oder die Windows UAC (deine Benutzerrechte).
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8299
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 7 guests