Virtueller Server mit SSL?

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Virtueller Server mit SSL?

Postby Mirko » 26. February 2003 15:06

Tach auch!

Habe da ein mittelmäßiges Problem:
Virtuelle Server sind ja kein Hit. Genauso wie diese mit SSL - bis auf den kleinen Punkt, das bei mir immer das Zertifikat des ersten VS "ausgeliefert" wird, wenn eine Anfrage gestellt wird. Wenn ich von dem SSL Server aber ein Doku anfordere, was nicht vorhanden ist (https://server3/doku_das_es_nicht_gibt.html/), steht grundsätzlich aber unten in der letzten Zeile der Fehlermeldung des Apache, das es sich um den "richtigen" Server auf den "richtigen" Port handelt.

Meine schematische httpd.conf:
Code: Select all
NameVirtualHost 192.168.123.252:80   
NameVirtualHost 192.168.123.252:443
##############################################################################
### Server 1 Port 80
##############################################################################
<VirtualHost 192.168.123.252:80>
   ServerName server1
   ServerAdmin webmaster@server1
   DocumentRoot /wampp13a/server/server1/htdocs
   ErrorLog "/wampp13a/server/server1/logs/error_log.txt"
   TransferLog "/wampp13a/server/server1/logs/access_log.txt"

</VirtualHost>
##############################################################################
#SSL Server1 Port 443
##############################################################################
<VirtualHost 192.168.123.252:443>
   ServerName server1
   ServerAdmin webmaster@server1
   DocumentRoot /wampp13a/server/server1/htdocs
   ErrorLog "/wampp13a/server/server1/logs/error_log_443.txt"
   TransferLog "/wampp13a/server/server1/logs/access_log_443.txt"

   SSLEngine on
   SSLCertificateFile "/wampp13a/server/server1/security/server1.crt"
   SSLCertificateKeyFile "/wampp13a/server/server1/security/server1.key"
   SetEnvIf User-Agent ".*MSIE.*" \
      nokeepalive ssl-unclean-shutdown \
      downgrade-1.0 force-response-1.0
</VirtualHost>

##############################################################################
### Server 2 Port 80
##############################################################################
<VirtualHost 192.168.123.252:80>
   ServerName server2
   ServerAdmin webmaster@server2
   DocumentRoot /wampp13a/server/server2/htdocs
   ErrorLog "/wampp13a/server/server2/logs/error_log.txt"
   TransferLog "/wampp13a/server/server2/logs/access_log.txt"
   
</VirtualHost>
##############################################################################
#SSL  Server2 Port 443
##############################################################################
<VirtualHost 192.168.123.252:443>
   ServerName server2
   ServerAdmin webmaster@server2
   DocumentRoot /wampp13a/server/server2/htdocs
   ErrorLog "/wampp13a/server/server2/logs/error_log_443.txt"
   TransferLog "/wampp13a/server/server2/logs/access_log_443.txt"

   SSLEngine on
   SSLCertificateFile "/wampp13a/server/server2/security/server2.crt"
   SSLCertificateKeyFile "/wampp13a/server/server2/security/server2.key"
   SetEnvIf User-Agent ".*MSIE.*" \
      nokeepalive ssl-unclean-shutdown \
      downgrade-1.0 force-response-1.0   
</VirtualHost>

##############################################################################
###  Server3 Port 80
##############################################################################
<VirtualHost 192.168.123.252:80>
   ServerName server3
   ServerAdmin webmaster@server3
   DocumentRoot /wampp13a/server/server3/htdocs
   ErrorLog "/wampp13a/server/server3/logs/error_log.txt"
   TransferLog "/wampp13a/server/server3/logs/access_log.txt"


</VirtualHost>
##############################################################################
#SSL server3 Port 443
##############################################################################
<VirtualHost 192.168.123.252:443>
   ServerName server3
   ServerAdmin webmaster@server3
   DocumentRoot /wampp13a/server/server3/htdocs
   ErrorLog "/wampp13a/server/server3/logs/error_log_443.txt"
   TransferLog "/wampp13a/server/server3/logs/access_log_443.txt"

   SSLEngine on
   SSLCertificateFile "/wampp13a/server/server3/security/server3.crt"
   SSLCertificateKeyFile "/wampp13a/server/server3/security/server3.key"
   SetEnvIf User-Agent ".*MSIE.*" \
      nokeepalive ssl-unclean-shutdown \
      downgrade-1.0 force-response-1.0
</VirtualHost>

Sorry wegen dem langen Listing, sollte aber vollständig sein.

Also wie gesagt: Zugriffe werden korrekt verzweigt, jedoch werden bei server2 & server3 das Zertifikat von server1 angezeigt.

Der Apache gibt im Error_log von Windows KEINEN fehler aus! Was bedeuten würde, das hier alles syntaktisch richtig ist.

Nur 'ne beiläufige Frage: "Ist es normal, das es bei dieser Konf. im Leerlauf nur 2 Apache-Prozesse gibt?" Kommt mir ein wenig seltsam vor, aber naja.

Also für Hilfe vielmals Danke
Grüße aus dem sonnigen Potsdam
Mirko
 

Vergessen

Postby Mirko » 26. February 2003 15:08

Die Zertifikate sind definitiv, wenn auf die richtigen zugegriffen werden würde, richtig konfiguriert.

Gruß Mirko
Mirko
 

Postby Oswald » 26. February 2003 16:22

Hallo Mirko!

Nach meinem Verständnis von SSL würd ich sagen, dass jeder SSL Virtual Host eine eigene IP-Adresse braucht. Man kann locker mehrere normale Virtual Hosts auf einer IP-Adresse fahren, aber wenn man mehrere SSL Virtual Hosts haben möchte, dann braucht jeder eine eigene IP-Adresse.

Das fällt mir jedenfalls jetzt als erstes an der Konfigurationsdatei auf.

Viel Erfolg,
Oswald ;)
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
XAMPP Version: 5.5.19
Operating System: Linux

Hmm...

Postby Mirko » 26. February 2003 16:55

Hi Kai!

Doofe Sache. Dabei benötige ich genau eine solche Konfiguration.

UND: Teilweise funzt es ja! Bei Fehlermeldungen (z.B. 404) wird unten der Server_Text ausgegeben wo ja alles richtig da steht, und wie gesagt auch die richtigen Files werden gelinkt.

Der einzige Fehler ist, das nur ein falsches Zertifikat beim Aufbau der Verbindung zurükgeliefert wird.

Gruß Mirko
Mirko
 

Postby Mirko » 12. March 2003 12:04

Hallo allerseits!

Also ich war gerade im Bücherladen und habe mir das Thema SSL und Virtuelle Hosts nochmal professionell rein gezogen (Apache Webserver. Installation, Konfiguration, Administration - ISBN: 3826608291).


Fazit: Es geht doch! (Zu mindest mit einem Apache 2)


Naja ich werde also das Thema nochmal näher unter die Lupe nehmen und dann posten.

Gruß Mirko
Mirko
 

Postby Pc-dummy » 12. March 2003 12:57

@ Mriko

Ja bitte poste deine lösung wenn du es geschafft
hast

würde auch mich brennend interresieren

MFG

Pc-Dummy
--
a 13 year old Newbie
Pc-dummy
AF Moderator
 
Posts: 784
Joined: 29. December 2002 01:46
Location: AT-Vorarlberg-Feldkirch

Postby Oswald » 12. March 2003 18:57

Huhu Mirko!

Ich möcht' ja wieder mal nicht rechthaberisch sein. Aber... ;)

Wie ich schon vermutete sind name-based virtual hosts wirklich nicht geeignet um https (SSL) server zu betreiben. Ich denke und hoffe mal, Du hast Dich verlesen und das steht nicht wirklich so in dem Buch.

Hier ein Zitat aus der besten Quelle überhaupt: dem Apache-Referenz-Manual von apache.org:

Name-based virtual hosting cannot be used with SSL secure servers because of the nature of the SSL protocol.

Quelle: http://httpd.apache.org/docs-2.0/vhosts/name-based.html

Lieben Gruß,
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
XAMPP Version: 5.5.19
Operating System: Linux

Postby Mirko » 12. March 2003 22:55

So ein Mist!

gerade ( kurz bevor das Bettchen ruft) wollte ich mir noch mal die Doku rein zerren und bin auf exakt den gleichen Link mit dem gleichen Zitat gekommen.

Blöde Sache!

Die Frage wäre jetzt, ob das ganze mit IP basierten VHosts bastelbar wäre - aber da die meisten sowieso nur eine Adresse haben..... :cry:

Gruß Mirko
Mirko
 


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 7 guests