"Post" Problem IE6

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

"Post" Problem IE6

Postby sydios » 23. February 2010 11:28

Hi,

ich werd hier noch verrückt, und zwar habe ich hier ein sehr seltsames Problem.
In ein paar Formularen benutze ich die Methode "post" mit der ich dann die Formulardaten an
ein php Script übergebe.
Nur leider werden die Daten manchmal eben nicht übergeben, wenn ich das auf get umstelle funktioniert
das bis jetzt ohne Probleme.
Hat jemand das gleiche Problem schon mal gehabt oder weiß an was es liegt ?

Vielen dank schonmal ...

syd ...
sydios
 
Posts: 4
Joined: 27. January 2010 16:05

Re: "Post" Problem IE6

Postby Altrea » 23. February 2010 11:39

Bei mir funktionieren beide Übertragungsarten im IE6 seit Jahren und unzähligen XAMPP Versionen zuverlässig.

Welche XAMPP Version setzt du ein?
Hast du irgendwelche Anpassungen an der Standardinstallation vorgenommen?
Kannst du uns ein Codebeispiel (Formular + Verarbeitung) zur Überprüfung liefern?
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8286
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: "Post" Problem IE6

Postby werkbonn » 26. February 2010 15:01

Hallo, ich habe das problem auch und zwar im Firefox. Xampp 1.7.3 ist installiert und ich lese tatsächlich nur den Formular-Feld-Namen auf der Folgeseite aus - und es klappt nicht. Für Hilfe bin ich dankbar - vielleicht gibt es auch einen Link zu dem Problem.

LG
werkbonn
 
Posts: 2
Joined: 26. February 2010 14:57

Re: "Post" Problem IE6

Postby Nobbie » 26. February 2010 15:16

Kein Sourcecode -> keine Hilfe.
Nobbie
 
Posts: 8758
Joined: 09. March 2008 13:04

Re: "Post" Problem IE6

Postby WilliL » 26. February 2010 16:23

$_post('varnam') geht bei Xampp 1.7.3 (Standardinstallation) sowohl mit IE6 (6.0.2) als auch mit Firefox (3.0.14 ..18)
Willi
WilliL
 
Posts: 661
Joined: 08. January 2010 10:54
Operating System: Win7Home Prem 64 SP1

Re: "Post" Problem IE6

Postby werkbonn » 26. February 2010 18:17

WilliL wrote:$_post('varnam') geht bei Xampp 1.7.3 (Standardinstallation) sowohl mit IE6 (6.0.2) als auch mit Firefox (3.0.14 ..18)


Jaja ... jetzt habe ich's auch. Ganz lieben Dank

Bei mir waren die Einstellungen in der php.ini seit dem Betriebssystemwechsel und durch die Neuinstallation des Xampp verändert und deswegen hatte ich mit der Einstellung der
Code: Select all
register_globals = off
nicht gerechnet.
Es hat ein wenig gedauert, dann habe ich aber, ohne Anpassung der PHP.ini (wovon u.a. Heise abrät - Ihr sicher auch) die globalen Variablen ($_GET, $_POST, $_COOKIE et cetera) gefunden.

Besser spät als nie, dennoch nochmals lieben Dank für die Hilfe.

Anbei die beiden Links die mir geholfen haben

http://www.heise.de/newsticker/meldung/PHP-Version-4-1-0-freigegeben-50426.html
http://www.heise.de/security/artikel/Grundsicherung-fuer-PHP-Software-270918.html

Schönes WE noch
werkbonn
 
Posts: 2
Joined: 26. February 2010 14:57


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 6 guests