PHP 5 funktioniert unter Xampp 1.7.3 nicht

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Re: PHP 5 funktioniert unter Xampp 1.7.3 nicht

Postby Crashbreaker » 18. February 2010 20:13

Altrea wrote:Ah, okay. Der Eintrag in der httpd-xampp.conf ist mir so nochnie aufgefallen. Aber bei mir steht der ebenso, also wird er wohl seine Richtigkeit haben.
Deshalb würde ich dir vorschlagen die AddType Zeile direkt in der httpd.conf (dort gibts schon so einen tollen Mime Block) zu schreiben und die httpd-xampp.conf wieder auf standard zu stellen.

Du kannst Den MIME type auch direkt in der Datei mime.types eintragen. Sollte ebenfalls klappen (ungetestet)


Okay das klingt gut.
Werde ich machen, doch wo genau soll ich es setzten, denn da gibt es glaube ich mehrere Mime Blocks ???

MfG
Daniel
Crashbreaker
 
Posts: 11
Joined: 18. February 2010 18:28

Re: PHP 5 funktioniert unter Xampp 1.7.3 nicht

Postby Altrea » 18. February 2010 20:19

Woran hat das gelegen bzw. wo steht davon der Eintrag denn ???


ebenfalls in der httpd-xampp.conf die beiden Blöcke oberhalb des mime_module Eintrags (je nachdem ob PHP-CGI oder PHP aktiv ist).
Denke ich zumindest.

Werde ich machen, doch wo genau soll ich es setzten, denn da gibt es glaube ich mehrere Mime Blocks ???

Es gibt da nur einen, der aber mit den vielen Kommentaren dafür recht lang ist.

Ich habs zum Beispiel folgendermaßen reingeschrieben:

aus
Code: Select all
#
AddType text/html . shtml
AddOutputFilter INCLUDES .shtml


mach
Code: Select all
#
AddType text/html . shtml
AddType application/x-httpd-php .php5
AddOutputFilter INCLUDES .shtml


An welcher Stelle in dem mime_module du es genau hinschreibst bleibt aber dir überlassen. Am besten so dass es für dich übersichtlich, logisch und wieder auffindbar ist ;)
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8297
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: PHP 5 funktioniert unter Xampp 1.7.3 nicht

Postby Crashbreaker » 18. February 2010 21:18

Oh Dankeschön, hat super geklappt.
Crashbreaker
 
Posts: 11
Joined: 18. February 2010 18:28

Previous

Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 14 guests