Mod Rewrite Problem?

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Mod Rewrite Problem?

Postby Stoke » 06. February 2010 12:45

Hallo,

ich hab bereits die Google und die SuFu bemüht, aber leider konnte ich keine Lösung für mein Problem finden. Es haben zwar viele das selbe oder ein ähnliches Problem, aber bei mir hats wohl eine andere Ursache.
Ich verwende XAMPP jetzt schon seit Ewigkeiten und es ist nie etwas vergleichbares aufgetreten, immer hat alles wunderbar funktioniert.

Vor kurzem habe ich XAMPP neu installiert, weil ich aus versehen die phpMyAdmin Tabelle gelöscht hab und ich konnte mir nicht anders helfen :roll:

Seit dem scheint mod_rewrite nicht mehr zu funktionieren. Das Modul ist aber mit Sicherheit aktiviert, hab die httpd.conf überprüft. Jedes mal wenn ich eine rewrite-url aufrufe, also zB localhost/wordpress/testseite
werde ich auf localhost/xampp weitergeleitet.

Hat jemand eine Idee woran das liegen könnte? Danke
Stoke
 
Posts: 2
Joined: 06. February 2010 12:37

Re: Mod Rewrite Problem?

Postby Nobbie » 06. February 2010 15:39

Stoke wrote:Seit dem scheint mod_rewrite nicht mehr zu funktionieren. Das Modul ist aber mit Sicherheit aktiviert, hab die httpd.conf überprüft. Jedes mal wenn ich eine rewrite-url aufrufe, also zB localhost/wordpress/testseite
werde ich auf localhost/xampp weitergeleitet.


Ich denke, das ist ein gutes Zeichen dafür, dass mod_rewrite tatsächlich funktioniert. Ich habe mal bei wordpress eine .htaccess gesehen, da wird einfach gnadenlos alles auf /index.php geroutet. Und wenn da eine jungfräuliche Xampp Installation liegt, dann leitet die dortige index.php weiter auf localhost/xampp.

Jetzt ist nur die Frage, ob Du wordpress richtig installiert hast und ob da wirklich so eine .htaccess drin liegt. Schau doch einfach mal nach.
Nobbie
 
Posts: 8779
Joined: 09. March 2008 13:04

Re: Mod Rewrite Problem?

Postby Stoke » 08. February 2010 20:32

Das wars, danke.

Komisch dass der Fehler erst jetzt auftrat und voher nicht?
Da hab ich wohl wirklich in der Eile was beim Installieren übersehen.
Stoke
 
Posts: 2
Joined: 06. February 2010 12:37

Re: Mod Rewrite Problem?

Postby Crashbreaker » 18. February 2010 18:39

Stoke wrote:Das wars, danke.

Komisch dass der Fehler erst jetzt auftrat und voher nicht?
Da hab ich wohl wirklich in der Eile was beim Installieren übersehen.



Hallo,

also was der Nobbie geschrieben hat ist meines erachtens totaler bullshit.
Dein Problem hierbei ist ganz einfach die Virtualhosts die du vergessen hast nach zu tragen.
Hierbei müsstest du auch für den localhost einen Virtualhost eintragen.

Dann dürfte es nicht mehr auf die xampp Verzeichnis umgeleitet werden.
Warum und inwiefern dein ModRewrite nicht funktioniert liegt hierbei zu wenig information.

MfG
Daniel
Crashbreaker
 
Posts: 11
Joined: 18. February 2010 18:28


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 8 guests

cron